problem so spustenim Compiz (co ktomu treba doinstalovat)

Ked spustim Compiz, preblikne obrazovka a v lavom hornom rohu vypisse: Compiz hes not enabled. (v KDE)
v Gnome pri spusteni efektoch cela obrazovka zostane biela. :o(
geForce 8500GT - Fedora ju zdetekuje
Obrazovku tiez nastavim tak, ze ju rozozna.

Treba k tomu nejaky akcelerator? Hladal som, ale vsetko je tu o Radeonoch.

Dakujem.

ps: Tie navody su super (zaklady prikazove rady, jak instalovat,…) Dost som sa toho naucil… :o) Takze este raz Diky…

Predpokladam ze nainstalovany ovladac nvidia mas. Nejsem si tim 100% jist, ale KDE ma vlastni kompozitni manager a compiz neni prilis pro nej. Jak compiz zapinas, rpipadne co si instaloval? Jakou verzi Fedory pouzivas?

Fedora 9 DVD

Ked som ho instaloval, zaskrtol som vsetko z KDE4 a potom aj efekty. nVidia ovladac som neinstaloval… detekoval ho sam…

To ano, ale je potreba podle prirucky doinstalovat ovladac vydavany primo nvidii (jmenuje se nvidia, zatimco ten v originalni instalaci je pravdepodbne nv), jinak akcelerace nemuze fungovat.

Pockajte skusim to takto urobit… :o) Dakujem za radu, este som o tom nepocul.

Takze skusil som toto:
odinstaloval so “nv - graphic driver” v Add/remove software…
Na www.nVidia.com som si nasiel ovladace pre Linux AMD64/EM64
Boli tam 2 verzie pre radu 71xx a 96xx (kedze mam 8600 predpokladam ze mam stiahnut 96xx. Ale preistotu som stiahol obe)
Stiahol som si k tomu aj subor “X config file” podla navodu na stranke “http://www.nvidia.com/object/linux_display_amd64_96.43.07.html
V linuxe cez Alt+Ctrl -> F1 som sa dostal do ROOT a podla navodu napisal:

sh NVIDIA-Linux-x86_64-96.43.07-pkg2.run

Stacilo 2x zakliknut OK.

potom som prepisal cez “mc” /etc/X11/xorg.config na:
Driver “nv” -> Driver “nvidia”

a vytvoril podla navodu adlsiu sekciu:
Section “Module”
Load “extmod”
Load “dbe”
Load “type1”
Load “freetype”
Load “glx”
EndSection

ulozil a restartoval… Po restarte mi nabehlo len:
“Login:” a zozaciatku trosku poblikovala obrazova.

zrejme mi nespustilo X11… :o(

A teraz som sa stratil… Neviem vazne co dalej. Neda sa nejako cez ten prikaz “yum -y xxxx ftp://xxxxxxx.xxx install nvidia” vyzera byt velmi inteligentny, ked dom cez neho nainstaloval KDE4 (yum -y groupinstall KDE) Cital som aj o .repo suboroch, dokazal by som ho vytvorit. Len nejaku radu ako to spravit.

dakujem

Psal jsem ze ho mate nainstalovat podle prirucky! Evidentne zbytecne, takze je mi lito, ale chyba neni na me strane.

yum install kmod-nvidia
tada pokud mate přidán repozitář livna
pokud ne tak nejdříve přidat repozitář a potom instalovat ovladač
rpm -Uvh ://rpm.livna.org/livna-release-9.rpm
rpm --import /etc/pki/rpm-gpg/*
rpm --import ://rpm.livna.org/RPM-LIVNA-GPG-KEY
yum install kmod-nvidia
vše samozřejmě jako root
a přečtěte si příručku vše je tam popsáno
před : je potřeba u dvou příkazů dopsat http

Funguje to… :slight_smile: Dakujem…

Klucove slova aj pre inych co to hladaju vsade po internete ako som hladal ja: :smiley:
Jak / Ako instalovat nVidia pre Fedoru Linux // install nVidia driver for fedora Linux .cz .sk

instalacia repozitara Livna:
Podrobnosti v casti “Pridani repozitare”: (ak by som sa nahodou pomilil… :slight_smile: ) http://wiki.fedora.cz/doku.php?id=navody:prirucka:instalace_aplikaci

Ako root:


 yum -Uvh "http://rpm.livna.org/livna-release-9.rpm"
 rpm --import /etc/pki/rpm-gpg/*"
 rpm --import "http://rpm.livna.org/RPM-LIVNA-GPG-KEY"

Instalacia ovladaca:


 yum -y install kmod-nvidia

(-y) - pocas instalacie netreba stlacat “y”

v subore /etc/X11/xorg.conf treba prepisat Driver “nv” na Driver “nvidia”
Ak nevies ako, nainstaluj si neieco take ako NortonCommander (editovat subor F4 / koniec F10) napis:


 yum -y install mc
 mc

a nakoniec


 reboot

:smiley: Vaca - velmi si mi pomohol… velke DIIIK!!!

http://wiki.fedora.cz/doku.php?id=navody:prirucka:hardware#instalace_ovladacu_pro_graficke_karty_nvidia_a_ati

compiz este stale nefunguje. pise to iste. V lavom hornom rohu : Compiz hes not enabled.
Z toho odkazu, co mi napisal covex mi vypisalo:


[wwlado@localhost ~]$ glxinfo | grep -i render
Error: glXCreateContext failed
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  4 (X_DestroyWindow)
  Resource id in failed request:  0x0
  Serial number of failed request:  24
  Current serial number in output stream:  26
Locking assertion failure.  Backtrace:
#0 /usr/lib64/libxcb-xlib.so.0 [0x380c60097c]
#1 /usr/lib64/libxcb-xlib.so.0(xcb_xlib_lock+0x17) [0x380c600af7]
#2 /usr/lib64/libX11.so.6 [0x380d24c610]
#3 /usr/lib64/libX11.so.6(XESetCloseDisplay+0x43) [0x380d22e693]

Skusal som ja doinstalovat:


yum -y install xorg-x11-drv-nvidia

Ale nestiahlo ho, lebo zevraj je to starsia verzia… :frowning:
Kde moze byt chyba?? :o(

Prvni chyab se stala v okamziku kdy si nainstaloval ovladac ze stranek nvidia, tim sis v systemu nadlala pekny binec. V jakem stavu to je ted uz lze jen stezi hadat. Pokud ma
sh NVIDIA-Linux-x86_64-96.43.07-pkg2.run
nejakou volbu na odinstalaci tak to zkus, pak teprve instaluj dalsi veci.

Kdyz uz zminujes nejakou chybu yumu tak ji sem take zkopiruj, z tve interpretace sme se toho moc nedozvedeli.

Za to sa ospravednujem…


yum -y install xorg-x11-drv-nvidia

Package yum -y install xorg-x11-drv-nvidia-173.14.12-1.lvn9.x86_64 alredy installed and latest version
Nothing to do

Takze som sa rozhodol, ze to preinstalujem a pojdem pekne poporiadku.
-Fedora 9 Gnome
-KDE4
-dopisat balicky Livna
-Grafika

( yum -y install kmod-nvidia <- moze sa nainstalovat este pred KDE?? ked je tam ten KMOD)

xorg-x11-drv-nvidia-173.14.12-1.lvn9.x86_64 yum ho nenainstaluje ,protože ho už máte
nainstalovaný. nainstaloval se vám spolu s kmod-nvidia kvůli závislostem.
Po instalaci už není potřeba žádná editace xorg.conf
Já tam třeba žádnou Section “Module” nemám.
kmod-nvidia mužete nainstalovat před instalací KDE

zde je třeba muj xorg.conf

Xorg configuration created by livna-config-display

Section “ServerLayout”
Identifier “Default Layout”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
EndSection

Section “Files”
ModulePath “/usr/lib/xorg/modules/extensions/nvidia”
ModulePath “/usr/lib/xorg/modules”
EndSection

Section “ServerFlags”
Option “AIGLX” “on”
Option “Xinerama” “0”
EndSection

Section “InputDevice”

keyboard added by rhpxl

Identifier  "Keyboard0"
Driver      "kbd"
Option	    "XkbModel" "pc105"
Option	    "XkbLayout" "cz"
Option	    "XkbVariant" "qwertz"

EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “TV-0”
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
EndSection

Section “Monitor”
Identifier “Monitor1”
VendorName “Unknown”
ModelName “TV-0”
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
EndSection

Section “Device”
Identifier “Videocard0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce 7600 GS”
Option “AddARGBGLXVisuals” “True”
EndSection

Section “Device”
Identifier “Videocard1”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce 7600 GS”
Option “AddARGBGLXVisuals” “True”
BusID “PCI:2:0:0”
Screen 1
EndSection

Section “Screen”

Removed Option “TwinView” “0”

Removed Option “metamodes” “DFP: nvidia-auto-select +0+0”

Identifier "Screen0"
Device     "Videocard0"
Monitor    "Monitor0"
DefaultDepth     24
Option	    "TwinView" "1"
Option	    "metamodes" "TV: nvidia-auto-select +1440+0, DFP: nvidia-auto-select +0+0"
SubSection "Display"
	Depth     24
EndSubSection

EndSection

Section “Screen”
Identifier “Screen1”
Device “Videocard1”
Monitor “Monitor1”
DefaultDepth 24
Option “TwinView” “0”
Option “metamodes” “TV: nvidia-auto-select +0+0”
EndSection

Section “Extensions”
Option “Composite” “Enable”
EndSection

Ked Bod da, aj ja budem mat taky vypis… :slight_smile: (na par zmien)

K veci… Preinstaloval som to uplne na novo. pri instalaci gr. karty vybehla chyba.


Missing Dependency: kernel-uname-r=26.25.14-108.fc9.86_64 is need by package kmod-nvidia-2.6.25.14-108.fc9.x86_64-173.14.12-3.lvn9.x86_64

Tak teda som to skusil tak:


yum -y install kmod-nvidia-2.6.25.14-108.fc9.x86_64-173.14.12-3.lvn9.x86_64

A on tu istu chybu napisal este raz.
Nechal som ho cez den, nech sa zaktualizuje, mozno ta chyba bola nejako oravena.

Bud je chyba medzi monitorm a stolicku, alebo monitorom a zasuvkou (to ako ze moj PC). :smiley:

Este sa chcem opytat:
Funguje na tom aj DualView (dve rozne plochy)?
Aky je rozdiel medzi Xgl a Glx?? (predpokladam ze GL je odvodene z openGL)

Tato chyba muze vzniknout v dobe kdy nejsou na stejnych verzich moduly v repozitarich fedora a livna, coz se zvlaste v dnesnich dnech kdy se rozbyhaji aktualizace po vypadku celeho fedoraprojektu muze stat celkem snadno.
DualView “udajne” jde, ale tak daleho jsem nedospel, takze jsem to nikdy prakticky nezkousel.
Xgl a GLX jsou akceleracni technologie. Xgl byl pred casem pozmeneny X server od Novellu s OpenGL akceleraci vsech prvky grafickeho prostredi. Tato technologie upadla v zapomeni a byla prekonana technologii GLX, resp. AIGLX kterou podporoval RedHat a ktera je dnes pouzivana snad ve vsech distribucich. Taktez vyuziva OpenGL, ale jinak.

máte už nainstalovány všechny aktualizace?
co vám vypíše uname -rm
na livne ten baliček pro toto jádro je.

Chlapci… Uz to fici… Aktualizoval som Fedoru a popri tom som v niektorich .repo suboroch poprepinal Enable na 1.

Spustil som aj ten compiz, ale som trosku sklamany… neviem kde sa to nasavuje. (cube, efekty)… este stale stahuje nejake aktualizacie… som zvedavy, co tam chce este vopchat.

Ak mam Infra Port MA620 da sa nejako ovladat PC z dialkovim?? Niekde som videl utilitku na RithmBox. RithmBox uz mi hraje… Ale nejako to tam nieje…:frowning: ale aj tak Vam velmi dakujem…

zasa sa to updatlo a vyhodilo mi ten ovladac… Uz zasa nefunguje… :frowning:
Ale aj to bolo pekne ze aspon na chvilku…

Napchal sa mi na plochu superKaramba a vzdy ziada Kross modul, a namiesto ikonok (apletov) mam iba biele stvorceky. Pozeral som na nete ale nenasiel som taky modul na stiahnutie. Ani v Add/Remove softvare to nenaslo… :frowning:

popri tom som v niektorich .repo suboroch poprepinal Enable na 1

… doufam, ze vis co delas :slight_smile: Mozna sis to dalsim updatem cele rozhasil. :frowning:
Napis jaky mas kernel a kmod-nvidia

rpm -qa kmod-nvidia\* kernel