Numlock po startu


#1

Ahoj, mam takovy problemek, nove jsem nainstaloval Feroru 22 a chci numlock zapnuty po startu PC, takze jsem podle manualu pridal
[ -x /usr/bin/numlockx ] && /usr/bin/numlockx on.

Jenze ted to dela to, ze zacne bootovat Ferdora a numlock se zapne a tesne pred skocenim na prihlasovaci obrazovku se zase vypne.

Co s tim prosim?


#2

Myslím, že gdm běží na waylandu.

Zkus https://ask.fedoraproject.org/en/question/69200/why-is-num-lock-always-an-issue-with-each-release-its-2015/?answer=70205#post-id-70205 Tu odpověď s 1 plusovým bodem.

Nebo

gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state on

?Ale T/F se přehazuje num lock klávesou, tak nevím jestli to jde nastavit jako default.


#3

Proč někdo z Linuxu neudělá už do finále takovou prkotinu, jako je spuštění NumLcku při startu??? Kdo má furt hledat návody, které s novou verzí té které distribuce nějak nefungují. To je snad jediná věc, která mě u Linuxu štve… jinak je to samozřejmě bezvadný operační systém na který nemá ani drahý Windows :wink:
Na F23 samozřejmě nefunguje návod z wiki, ani výše uvedený na ask.fedoraproject.org


#4

creep73:
ten tvuj prikaz nepomuze, terminal napise: Poskytnutá hodnota je mimo platný rozsah.
Tamto ten odkaz jsem nezkousel, ja jsem ted ve Fedore novacek, ale jestli mi tam bezi ten novy vsemi opevovany Wayland, tak chci aby takova prkotina sla nastavit i v nem, takze jeste pockam, jestli nekdo neda nejakou jinou radu. Kazdopadne i tobe diky.

marp:
Nemas pravdu, tuhle prkotinu presne jak rikas (a je mi to taky zahadou) neumi ani Windows, musi se to tam nastavovat v registrech, az ve Windows 8 si maji pamatovat posledni stav numlocku pri vypnuti a nasledne spusteni pocitace uz se zapnutym numlockem, ale me to nefungovalo, takze jsem musel do registru a zase to tam zapsat rucne.
Jinak ja ted zkousim Fedoru kvuli nejakejm testovacim ucelum, jinak jsem uzivatel Ubuntu (dalsi linuxova distribuce) a zapinani numlocku tam mame podobne jako ve Windows, proste se to jednou bezproblemove nastavi a potom to uz funguje, ale fakt je, ze mame zatim X-ka, doufam, ze Mir tohle bude umet podobne jednoduse az vyjde finalni verze. Jinak pokud nejsi s Fedorou spokojen tak bych ti doporucil Mint, to je klon Ubuntu a ma ruzna graficka nastavovaci klikatka, temer vse je jednodusi nez v Ubuntu a i to je podle mych zatim ranych zkusenosti jednodusi nez ve Fedore, takze jde o to si jen vybrat pro tebe vhodnou distribuci, kde je vsechno stejne jednoduche jako na Windows. :slight_smile:


#5

V tom případě asi se musíte obrátit na jinou distribuci. Fedora je holt tahoun v zavádění neozkoušených řešení.
Nemyslím si, že je to obecně problém linuxu. Zkuste konzervativnější distro než se to odladí.


#6

V zsh mi to funguje, v bashi ne. Zkoumat to nebudu.

~ ❯❯❯ gsettings get org.gnome.settings-daemon.peripherals.keyboard numlock-state
'off'
~ ❯❯❯ gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state on
~ ❯❯❯ gsettings get org.gnome.settings-daemon.peripherals.keyboard numlock-state
'on'

Edit: Tak jo zkoumal… Přidejte v bashi jednoduché závorky.
gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state ‘on’


#7

creep73 napsal(a):

V tom případě asi se musíte obrátit na jinou
distribuci. Fedora je holt tahoun v zavádění
neozkoušených řešení.
Nemyslím si, že je to obecně problém linuxu.
Zkuste konzervativnější distro než se to
odladí.

V LinuxMintu stačí stáhnout numlockx a pak aktivovat spuštění NumLocku v nastavení přihlašovací obrazovky. V Debianu stačí stáhnout numlockx a editovat /etc/gdm3/Init/Default přidáním if [ -x /usr/bin/numlockx ]; then
exec /usr/bin/numlockx on
fi
Ve Windows vždy stačilo v BIOSu aktivovat zapnutí numerické klávesnice.
Moje připomínka se týká naprosté prkotiny a nemá to nic společného v zavádění neozkoušených řešení ve Fedoře.
:wink:


#8

Když myslíš. Proč tedy pracuješ s nefinální verzí a pak remcáš ?
GDM je nad Waylandem, smiř se s tím. Může to přinášet problémy.
Když v Mintu ani Debinau není, použij více konzervativní distribuci.


#9

creep73 napsal(a):

Když myslíš. Proč tedy pracuješ s nefinální
verzí a pak remcáš ?
GDM je nad Waylandem, smiř se s tím. Může to
přinášet problémy.
Když v Mintu ani Debinau není, použij více
konzervativní distribuci.
Znovu opakuji - tohle nemá nic společného s nefinální nebo finální verzi - protože ani ve finální verzi tohle nikdy nebylo bez problémů. Jen si myslím, že tahle doslova “prkotina” by měla být v základu - tohle není žádné remcání, ale fakt! Teď už nevím, ve které verzi Gnome 3 se to ztratilo, ale při prvním přihlašování, pokud člověk zmáčknul NumLock, tak si to systém už navždy pamatoval a spouštěl ho před přihlášením. A fungovalo to nezávisle na distribuci!!!


#10

Redmarx napsal(a):

creep73:
ten tvuj prikaz nepomuze, terminal napise:
Poskytnutá hodnota je mimo platný rozsah.
Tamto ten odkaz jsem nezkousel, ja jsem ted ve
Fedore novacek, ale jestli mi tam bezi ten novy
vsemi opevovany Wayland, tak chci aby takova
prkotina sla nastavit i v nem, takze jeste pockam,
jestli nekdo neda nejakou jinou radu. Kazdopadne i
tobe diky.

marp:
Nemas pravdu, tuhle prkotinu presne jak rikas (a
je mi to taky zahadou) neumi ani Windows, musi se
to tam nastavovat v registrech, az ve Windows 8 si
maji pamatovat posledni stav numlocku pri vypnuti
a nasledne spusteni pocitace uz se zapnutym
numlockem, ale me to nefungovalo, takze jsem musel
do registru a zase to tam zapsat rucne.
Jinak ja ted zkousim Fedoru kvuli nejakejm
testovacim ucelum, jinak jsem uzivatel Ubuntu
(dalsi linuxova distribuce) a zapinani numlocku
tam mame podobne jako ve Windows, proste se to
jednou bezproblemove nastavi a potom to uz
funguje, ale fakt je, ze mame zatim X-ka, doufam,
ze Mir tohle bude umet podobne jednoduse az vyjde
finalni verze. Jinak pokud nejsi s Fedorou
spokojen tak bych ti doporucil Mint, to je klon
Ubuntu a ma ruzna graficka nastavovaci klikatka,
temer vse je jednodusi nez v Ubuntu a i to je
podle mych zatim ranych zkusenosti jednodusi nez
ve Fedore, takze jde o to si jen vybrat pro tebe
vhodnou distribuci, kde je vsechno stejne
jednoduche jako na Windows. :slight_smile:

O LinuxuMint vím toho dost a o Ubuntu ještě více :wink: moderuji na fóru ubuntu.cz
Zde se bavíme o Fedoře a nikde jsem nenapsal, že s ní nejsem spokojen. Naopak. Jen mě nabaví při přihlašování mačkat NumLock, nic víc!


#11

Pánové, až už jste to někdo nahlásili v bugzille? Protože stěžováním na fórem se to nevyřeší. Nahlášení požadavku/problému vývojářům je prvním krokem k vyřešení.

Jinak česká příručka nemá patent na aktuálnost. Fedora je pohybující se cíl a ne vždy je všechno aktuální, proto se při její aktualizaci hodí každá ruka. Pokud najdete nějaké fungující řešení, tak to prosím do příručky rovnou dejte.


#12

Bohužel nelze toto hlásit na bugzille. Z jednoho jediného důvodu - nejde o žádný bug. Tato funkce není totiž implementována v Gnome3 a tak si nejde stěžovat na něco, co vlastně není :wink: Proto se funkce zapnutí NumLocku řeší na mnoha fórech nejen distribuce Fedory, kdy nějaké řešení funguje, jiné ne.
Od toho jsou zde fóra, aby se podobné problémy řešily, včetně tohoto. A z tohoto důvodu poukazuji na to, že jde o prkotinu z hlediska vývojářů a dodnes se divím, že se nenajde jediný, který by tu funkčnost vyřešil. Zatím jediné fungující řešení je u Cinnamonu (Linux Mint), proto je mi divné, že tuto funkcionalitu Gnome Shell nemá, byť ji jistou dobu měl…
Každopádně moralizování není na místě, pokud sám nemáš návod na řešení.


#13

No, ale do bugzilly se nehlásí jenom bugy, ale i věci, které nejsou chybami. Tzv. RFE (request for enhancement/požadavek na vylepšení) jsou běžné mezi hlášeními v bugzillách. Hledáním workaroundů na fórech se primární problém nikdy nevyřeší.


#14

Sešívaný napsal(a):

No, ale do bugzilly se nehlásí jenom bugy, ale i
věci, které nejsou chybami. Tzv. RFE (request
for enhancement/požadavek na vylepšení) jsou
běžné mezi hlášeními v bugzillách.
Hledáním workaroundů na fórech se primární
problém nikdy nevyřeší.
Tak v tom případě tam bude tento požadavek minimálně desettisíckrát a pár let myslím :slight_smile:


#15

Reseni se v case meni… navic neni reseni mit “vzdy numlock po startu zapnuty” protoze treba notebookove klavesnice bez numlocku pri zapnutem numlocku pisy na 20klavesach nesmysly…


#16

Ale zpět k problému: aby se to projevilo v GDM, tak je potřeba, aby to nebylo zapsané v účtu uživatele, ale v /etc/dconf.

Je potřeba vytvořit “system-wide” profil gdm. Popsané je to třeba tady: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Desktop_Migration_and_Administration_Guide/customizing-login-screen.html

Vytvořit soubor /etc/dconf/db/gdm.d/numlockon s obsahem:

dconf path

[org/gnome/settings-daemon/peripherals/keyboard]

numlock-state=‘on’

Uložit a provést ‘sudo dconf update’. Po restartu už by to mělo fungovat. Může to někdo, kdo má klávesnici s NumLockem vyzkoušet? Pokud to bude fungovat, tak to hodíme do příručky.


#17

No, já jsem postupoval podle tohoto:

Here’s what worked for me:
Ensure that numlockx is installed:
Edit the file /etc/lightdm/lightdm.conf
joe /etc/lightdm/lightdm.conf
Add the following line to the file:
greeter-setup-script=/usr/bin/numlockx on

Chodí to.
Ale to je pro XFCE a lightdm, takže to vám asi nepomůže.


#18

Numlockx nepomůže, protože GDM už běží ve Fedoře na Waylandu, ne na X. Dá se sice vynutit, aby GDM běželo na X, ale přijde mi jako perspektivnější najít řešení, které funguje i na Waylandu.


#19

“Je potřeba vytvořit “system-wide” profil gdm.”

Nevim, zda mam jeste neco delat, protoze te vete nerozumim.

Ale jinak ty prikazy z toho prispevku jsem pouzil a po restartu jsem zase bez spusteneho numlocku.

Ano, souhlasim, chtelo by to reseni, ktere funguje na Waylandu, neda se porad se vracet na X-ka.

creep73: jeste jsem zapomnel, i tvou radu jsem vyzkousel, nakonec ne prikazem, ale pres dconf-editor, to by melo byt stejne, ale nepomohlo.


#20

Kdyby se místo různého obkecávání radši ozvali lidé, kteří přímo Fedoru vyvíjejí (a není jich v ČR zrovna málo!!!) a navrhli nějaké schůdné řešení :wink: