[Vyřešeno] K3B a cdrecord


#1

Zdar, při vypalování obyčejného CDčka mi to po zahájení vypalování po chvíli vyhodí chybu a že “cdrecord nemá oprávnění k otevření tohoto zařízení” a že prý " tento problém vyřešíte změnou nastavení K3B". A teď babo raď.
Edit: Pak jsem si všimnul, že držkuje, že sebe-uživatele mám přidat do skupiny “cdrom”. Tak jsem to udělal, restartoval mašinu, už to v nastavení nedržkovalo, ale stejnou chybu to vyhazuje dál. Bych se picnul.
No a vzhledem k tomu, že jsem identický problém právě zaznamenal na PC (opět jsem sebe-uživatele přidal do skupiny “cdrom”), tak to patrně NEBUDE MECHANIKOU, souhlasí. Na tom PC jsem vzdal vypalování CDček už od okamžiku, kdy jsem tam dal Fedoru, což je asi pět let. Občas jsem něco vysmahnul na NB, ale tam jsem donedávna měl Mageiu a tam to bylo bez sebemenšího problému. Takže celou tu dobu mám na PC JÁ něco špatně? A od instalace Fedory i na NB? Nebo mám něco doinstalovat? Jsem jediný, komu to zlobí? Zkoušením jsem oddělal už asi deset CDček, a to mi přijde sakra neekologické.


#2

Těžko říct. Je fakt, že vypalování už je dnes hodně okrajová věc a asi to moc lidí netestuje. Můžeš zkusit nainstalovat Brasero, což je taky grafický program na vypalování, a zkusit, jestli to trpí stejnou chybou. Pokud ne, tak bude asi nějaký problém v K3b.


#3

Doufam ze to aspon nemrvi CDcka…:slight_smile: Pridani do skupin “cdrom” je “historicky” mechanismu, ktery uz davno prekonal mnohem lepsi, spatne debugovatelny a komplikovanejsi policykit, dbus, ACL a dalsi radovanky…

Proste se podivej co mas za prava na tom souboru kam k3b smeruje vypalovani

ls -la /dev/cdrom
nebo neco podobneho… ono je pravdepodobne ze to bude symlink na neco uplne ineho co te ve skutecnosti zajima.
Pripadne je na to jedno vypalovani zmen jako root na tu skupinu cdrom apod

Ja mam vypalovacku na poslednim pocitaci v okoli, volny HDD obrovskych kapacit se valej vsude okolo, nikdo uz to ani nechce a na zalohovani je to ± to samy.


#4

Pravda, že jsem sebe- uživatele přidal do skupiny “cdrom”. To nepomohlo. Přítel fedorák vypnul v etc/sysconfig/@selinux SELINUX=disabled a už to pálí o stošet. Na doma dobrý (:smiley:


#5

Jo selinux dokaze divy, ale tim padem to slo vyresit pres audit2allow…


#6

Pokud to není nijak zásadně složité, můžu poprosit o rozšíření obzorů o tom audit2allow ?
My, co jsme vyrostli na gramofonových deskách na 78ot/min a kotoučových magnetofonech typu SONET DUO, budeme asi ještě pár dní chtít v ruce třímat něco fyzického (i když se CD/DVD špendlíkem jako gramodeska přehrát už nedá) :wink:


#7

Pohledanim na netu jiste najde, pokud neprectes, nebo nerozumis, tak se tim nezabyvej. :slight_smile: