[vyřešeno] Jazyková verze Evolution


#1

Po upgrade na F28 se změnila jazyková verze Evolution na anglickou.
Přihlašovací obrazovka a horní řádek v desktopu Gnome je také anglicky.
V Nastavení je v “Region a jazyk” vybrána čeština, přesto se po restartu chtěly adresáře přejmenovat anglicky …
Co s tím?


#2

Co ti vypíše localectl status ?

Jinak systémová lokalizace na češtinu se dá nastavit také pomocí příkazu: localectl set-locale LANG=cs_CZ.UTF-8


#3

[root@localhost ~]# localectl status
System Locale: LANG=cs_CZ.UTF-8
VC Keymap: cz
X11 Layout: cz
[root@localhost ~]#

Jazyková verze Evolution se nezměnila, je stále anglická. Manuálové stránky konzolových příkazů jsou jen anglicky.


#4

Nemůže to být tento problém? https://bugzilla.redhat.com/show_bug.cgi?id=1574222


#5

Díky, Sešívaný.
Po instalaci langpacks-cs … je všechno v pořádku.


#6

Ano, podle popisu je to stejný problém.
Nicméně to nemohu opravit, protože po upgrade nejde nic nainstalovat. Yumex při pokusu o instalaci skončí takto:


11:15:57 : Spouštění procesu yum
11:16:04 : YUM: Failed to set locale, defaulting to C
11:16:04 : YUM: Yum Version : 3.4.3
11:16:04 : YUM: Neexistuje shoda modulu pro: refresh-packagekit
11:16:04 : Z?sk?v?n? seznamu dostupn?ch aktualizac?
11:16:07 : Sta?eno: adobe-linux-x86_64 ( 2.9 k )
11:16:07 : Sta?eno: google-chrome ( 951  )
11:16:07 : Sta?eno: opera ( 2.9 k )
11:16:08 : Sta?eno: rpmfusion-free-updates/28/x86_64/metalink ( 8.6 k )
11:16:09 : Sta?eno: rpmfusion-nonfree-updates/28/x86_64/metalink ( 8.7 k )
11:16:09 : Sta?eno: skype-stable ( 2.9 k )
11:16:09 : Sta?eno: updates/28/x86_64/metalink ( 16 k )
11:16:10 : 11 balíčků získáno
11:16:10 : Zji??ov?n? dostupn?ch zastaral?ch bal??k?
11:16:10 : 0 balíčků získáno
11:16:10 : Přidávání balíčků do zobrazení
11:16:10 : Přidáno 11 balíčků do zobrazení
11:16:31 : Nastavuje se volba Yumu skip_broken = False
11:16:31 : Nastavuje se volba Yumu clean_requirements_on_remove = False
11:16:31 : 11 balíčků získáno
11:16:31 : 0 balíčků získáno
11:16:32 : YUM: --> Kontrola transakce spu?t?na
11:16:32 : YUM: ---> Bal??ek fribidi.i686 0:0.19.7-7.fc28 bude aktualizov?n
11:16:32 : YUM: ---> Bal??ek fribidi.x86_64 0:0.19.7-7.fc28 bude aktualizov?n
11:16:32 : YUM: ---> Bal??ek fribidi.i686 0:1.0.2-1.fc28 bude novou aktualizac?
11:16:32 : YUM: ---> Bal??ek fribidi.x86_64 0:1.0.2-1.fc28 bude novou aktualizac?
11:16:32 : YUM: ---> Bal??ek google-chrome-stable.x86_64 0:66.0.3359.170-1 bude aktualizov?n
11:16:32 : YUM: ---> Bal??ek google-chrome-stable.x86_64 0:66.0.3359.181-1 bude novou aktualizac?
11:16:32 : YUM: ---> Bal??ek langpacks-cs.noarch 0:1.0-12.fc28 bude instalov?n
11:16:32 : YUM: ---> Bal??ek mozjs52.x86_64 0:52.7.3-1.fc28 bude aktualizov?n
11:16:32 : YUM: ---> Bal??ek mozjs52.x86_64 0:52.8.0-1.fc28 bude novou aktualizac?
11:16:32 : YUM: ---> Bal??ek ostree.x86_64 0:2018.3-2.fc28 bude aktualizov?n
11:16:32 : YUM: ---> Bal??ek ostree.x86_64 0:2018.5-1.fc28 bude novou aktualizac?
11:16:32 : YUM: ---> Bal??ek ostree-libs.x86_64 0:2018.3-2.fc28 bude aktualizov?n
11:16:32 : YUM: ---> Bal??ek ostree-libs.x86_64 0:2018.5-1.fc28 bude novou aktualizac?
11:16:32 : YUM: ---> Bal??ek pango.i686 0:1.42.1-1.fc28 bude aktualizov?n
11:16:32 : YUM: ---> Bal??ek pango.x86_64 0:1.42.1-1.fc28 bude aktualizov?n
11:16:32 : YUM: ---> Bal??ek pango.i686 0:1.42.1-2.fc28 bude novou aktualizac?
11:16:32 : YUM: ---> Bal??ek pango.x86_64 0:1.42.1-2.fc28 bude novou aktualizac?
11:16:32 : YUM: ---> Bal??ek python2-urllib3.noarch 0:1.22-8.fc28 bude aktualizov?n
11:16:32 : YUM: ---> Bal??ek python2-urllib3.noarch 0:1.22-9.fc28 bude novou aktualizac?
11:16:32 : YUM: ---> Bal??ek python3-urllib3.noarch 0:1.22-8.fc28 bude aktualizov?n
11:16:32 : YUM: ---> Bal??ek python3-urllib3.noarch 0:1.22-9.fc28 bude novou aktualizac?
11:16:32 : YUM: ---> Bal??ek vte.x86_64 0:0.28.2-23.fc28 bude aktualizov?n
11:16:32 : YUM: ---> Bal??ek vte.x86_64 0:0.28.2-24.fc28 bude novou aktualizac?
11:16:32 : YUM: --> ?e?en? z?vislost? dokon?eno
11:16:37 : Sta?eno: langpacks-cs-1.0-12.fc28.noarch.rpm ( 8.5 k )
11:16:37 : YUM: Spu?t?na kontrola transakce
11:16:37 : YUM: --> Do transakce jsou p?id?v?ny vybran? bal??ky. ?ekejte pros?m.
11:16:37 : YUM: ---> Bal??ek google-chrome-stable.x86_64 0:66.0.3359.181-1 bude novou aktualizac?
11:16:37 : YUM: ---> Bal??ek fribidi.x86_64 0:1.0.2-1.fc28 bude novou aktualizac?
11:16:37 : YUM: ---> Bal??ek mozjs52.x86_64 0:52.8.0-1.fc28 bude novou aktualizac?
11:16:37 : YUM: ---> Bal??ek python2-urllib3.noarch 0:1.22-9.fc28 bude novou aktualizac?
11:16:37 : YUM: ---> Bal??ek ostree-libs.x86_64 0:2018.5-1.fc28 bude novou aktualizac?
11:16:37 : YUM: ---> Bal??ek pango.x86_64 0:1.42.1-2.fc28 bude novou aktualizac?
11:16:37 : YUM: ---> Bal??ek fribidi.i686 0:1.0.2-1.fc28 bude novou aktualizac?
11:16:37 : YUM: ---> Bal??ek langpacks-cs.noarch 0:1.0-12.fc28 bude novou aktualizac?
11:16:37 : YUM: ---> Bal??ek pango.i686 0:1.42.1-2.fc28 bude novou aktualizac?
11:16:37 : YUM: ---> Bal??ek python3-urllib3.noarch 0:1.22-9.fc28 bude novou aktualizac?
11:16:37 : YUM: ---> Bal??ek ostree.x86_64 0:2018.5-1.fc28 bude novou aktualizac?
11:16:37 : YUM: ---> Bal??ek vte.x86_64 0:0.28.2-24.fc28 bude novou aktualizac?
11:16:38 : YUM: Varování: RPMDB byla změněna mimo yum.
11:16:39 : ERROR: Chyba v yum transakci: Invalid version flag: if


#7

A nechceš to udělat přes DNF? Yum je ve Fedoře dávno neudržovaný a nepodporovaný, to samé platí pro Yumex. Pokud chceš grafickou nadstavbu na správcem balíčků, tak doporučuji dnfdragora.


#8

udělal jsem to takhle:
dnf install langpacks-cs.noarch
Že je Yumex ve Fedoře neudržovaný mi je novinkou a dnfdragora skyším poprvé. Zkusím vygůglit.

Dík za spolupráci.
Upgrade ve Fedoře je vždycky menší katastrofa (například OpenVPN při přechodu na 27 :frowning: )


#9

Mě spíš udivuje, že ho tam pořád máš, protože v repozitářích už není hodně verzí:
https://apps.fedoraproject.org/packages/yumex

Yumex-dnf je ještě dostupný v F26, ale v novějších také ne:
https://apps.fedoraproject.org/packages/yumex-dnf

Tady je pak varování přímo na stránkách projektu, že se to už dál vyvíjí: https://github.com/timlau/yumex-dnf


#10

To je tak, když se dělá upgrade už několik let. Čistý systém se instaloval někde při verzi FC 18.
Tu dnfdragoru jsem našel a z terminálu přes dnf nainstaloval.