Thunderbird-60.5.0-4.fc29.x86_64 Theme parsing error


#1

Dnes ráno thunderbird-60.4.0-1.fc29.x86_64v pořádku fungoval. Odpoledne tento upgrade:

# dnf history info
Transaction ID : 177
Begin time     : Mon 11 Feb 2019 17:16:34 CET
Begin rpmdb    : 2933:cf632237d014e5601b84687c6a1729ec77d2a199
End time       : Mon 11 Feb 2019 17:21:23 CET (289 seconds)
End rpmdb      : 2934:c4bd43d70aebaafe6bca7eca8036a47f0365f989
User           : filja <filja>
Return-Code    : Success
Releasever     : 29
Command Line   : upgrade
Packages Altered:
    Install  python3-argcomplete-1.9.4-1.fc29.noarch                   @fedora
    Upgrade  Thunar-1.8.4-1.fc29.x86_64                                @updates
    Upgraded Thunar-1.8.2-1.fc29.x86_64                                @@System
    Upgrade  abrt-2.12.0-2.fc29.x86_64                                 @updates
    Upgraded abrt-2.11.1-3.fc29.x86_64                                 @@System
    Upgrade  abrt-addon-ccpp-2.12.0-2.fc29.x86_64                      @updates
    Upgraded abrt-addon-ccpp-2.11.1-3.fc29.x86_64                      @@System
    Upgrade  abrt-addon-coredump-helper-2.12.0-2.fc29.x86_64           @updates
    Upgraded abrt-addon-coredump-helper-2.11.1-3.fc29.x86_64           @@System
    Upgrade  abrt-addon-kerneloops-2.12.0-2.fc29.x86_64                @updates
    Upgraded abrt-addon-kerneloops-2.11.1-3.fc29.x86_64                @@System
    Upgrade  abrt-addon-pstoreoops-2.12.0-2.fc29.x86_64                @updates
    Upgraded abrt-addon-pstoreoops-2.11.1-3.fc29.x86_64                @@System
    Upgrade  abrt-addon-vmcore-2.12.0-2.fc29.x86_64                    @updates
    Upgraded abrt-addon-vmcore-2.11.1-3.fc29.x86_64                    @@System
    Upgrade  abrt-addon-xorg-2.12.0-2.fc29.x86_64                      @updates
    Upgraded abrt-addon-xorg-2.11.1-3.fc29.x86_64                      @@System
    Upgrade  abrt-cli-2.12.0-2.fc29.x86_64                             @updates
    Upgraded abrt-cli-2.11.1-3.fc29.x86_64                             @@System
    Upgrade  abrt-dbus-2.12.0-2.fc29.x86_64                            @updates
    Upgraded abrt-dbus-2.11.1-3.fc29.x86_64                            @@System
    Upgrade  abrt-desktop-2.12.0-2.fc29.x86_64                         @updates
    Upgraded abrt-desktop-2.11.1-3.fc29.x86_64                         @@System
    Upgrade  abrt-gui-2.12.0-2.fc29.x86_64                             @updates
    Upgraded abrt-gui-2.11.1-3.fc29.x86_64                             @@System
    Upgrade  abrt-gui-libs-2.12.0-2.fc29.x86_64                        @updates
    Upgraded abrt-gui-libs-2.11.1-3.fc29.x86_64                        @@System
    Upgrade  abrt-libs-2.12.0-2.fc29.x86_64                            @updates
    Upgraded abrt-libs-2.11.1-3.fc29.x86_64                            @@System
    Upgrade  abrt-plugin-bodhi-2.12.0-2.fc29.x86_64                    @updates
    Upgraded abrt-plugin-bodhi-2.11.1-3.fc29.x86_64                    @@System
    Upgrade  abrt-retrace-client-2.12.0-2.fc29.x86_64                  @updates
    Upgraded abrt-retrace-client-2.11.1-3.fc29.x86_64                  @@System
    Upgrade  abrt-tui-2.12.0-2.fc29.x86_64                             @updates
    Upgraded abrt-tui-2.11.1-3.fc29.x86_64                             @@System
    Upgrade  autocorr-cs-1:6.1.5.2-1.fc29.noarch                       @updates
    Upgraded autocorr-cs-1:6.1.4.2-2.fc29.noarch                       @@System
    Upgrade  autocorr-en-1:6.1.5.2-1.fc29.noarch                       @updates
    Upgraded autocorr-en-1:6.1.4.2-2.fc29.noarch                       @@System
    Upgrade  exo-0.12.4-1.fc29.x86_64                                  @updates
    Upgraded exo-0.12.2-20.fc29.x86_64                                 @@System
    Upgrade  firefox-65.0-4.fc29.x86_64                                @updates
    Upgraded firefox-65.0-2.fc29.x86_64                                @@System
    Upgrade  gnome-control-center-3.30.3-1.fc29.x86_64                 @updates
    Upgraded gnome-control-center-3.30.2-1.fc29.x86_64                 @@System
    Upgrade  gnome-control-center-filesystem-3.30.3-1.fc29.noarch      @updates
    Upgraded gnome-control-center-filesystem-3.30.2-1.fc29.noarch      @@System
    Upgrade  gtk-update-icon-cache-3.24.1-2.fc29.x86_64                @updates
    Upgraded gtk-update-icon-cache-3.24.1-1.fc29.x86_64                @@System
    Upgrade  gtk3-3.24.1-2.fc29.x86_64                                 @updates
    Upgraded gtk3-3.24.1-1.fc29.x86_64                                 @@System
    Upgrade  gtk3-immodule-xim-3.24.1-2.fc29.x86_64                    @updates
    Upgraded gtk3-immodule-xim-3.24.1-1.fc29.x86_64                    @@System
    Upgrade  hplip-3.18.12-4.fc29.x86_64                               @updates
    Upgraded hplip-3.18.12-3.fc29.x86_64                               @@System
    Upgrade  hplip-common-3.18.12-4.fc29.x86_64                        @updates
    Upgraded hplip-common-3.18.12-3.fc29.x86_64                        @@System
    Upgrade  hplip-gui-3.18.12-4.fc29.x86_64                           @updates
    Upgraded hplip-gui-3.18.12-3.fc29.x86_64                           @@System
    Upgrade  hplip-libs-3.18.12-4.fc29.x86_64                          @updates
    Upgraded hplip-libs-3.18.12-3.fc29.x86_64                          @@System
    Upgrade  hwdata-0.320-1.fc29.noarch                                @updates
    Upgraded hwdata-0.319-1.fc29.noarch                                @@System
    Upgrade  hwloc-libs-1.11.12-1.fc29.x86_64                          @updates
    Upgraded hwloc-libs-1.11.9-2.fc29.x86_64                           @@System
    Upgrade  inxi-3.0.31-1.fc29.noarch                                 @updates
    Upgraded inxi-3.0.29-1.fc29.noarch                                 @@System
    Upgrade  java-1.8.0-openjdk-1:1.8.0.201.b09-2.fc29.x86_64          @updates
    Upgraded java-1.8.0-openjdk-1:1.8.0.191.b13-0.fc29.x86_64          @@System
    Upgrade  java-1.8.0-openjdk-headless-1:1.8.0.201.b09-2.fc29.x86_64 @updates
    Upgraded java-1.8.0-openjdk-headless-1:1.8.0.191.b13-0.fc29.x86_64 @@System
    Upgrade  kf5-sonnet-core-5.54.0-2.fc29.x86_64                      @updates
    Upgraded kf5-sonnet-core-5.54.0-1.fc29.x86_64                      @@System
    Upgrade  kf5-sonnet-ui-5.54.0-2.fc29.x86_64                        @updates
    Upgraded kf5-sonnet-ui-5.54.0-1.fc29.x86_64                        @@System
    Upgrade  langtable-0.0.41-1.fc29.noarch                            @updates
    Upgraded langtable-0.0.40-1.fc29.noarch                            @@System
    Upgrade  langtable-data-0.0.41-1.fc29.noarch                       @updates
    Upgraded langtable-data-0.0.40-1.fc29.noarch                       @@System
    Upgrade  libreoffice-base-1:6.1.5.2-1.fc29.x86_64                  @updates
    Upgraded libreoffice-base-1:6.1.4.2-2.fc29.x86_64                  @@System
    Upgrade  libreoffice-calc-1:6.1.5.2-1.fc29.x86_64                  @updates
    Upgraded libreoffice-calc-1:6.1.4.2-2.fc29.x86_64                  @@System
    Upgrade  libreoffice-core-1:6.1.5.2-1.fc29.x86_64                  @updates
    Upgraded libreoffice-core-1:6.1.4.2-2.fc29.x86_64                  @@System
    Upgrade  libreoffice-data-1:6.1.5.2-1.fc29.noarch                  @updates
    Upgraded libreoffice-data-1:6.1.4.2-2.fc29.noarch                  @@System
    Upgrade  libreoffice-draw-1:6.1.5.2-1.fc29.x86_64                  @updates
    Upgraded libreoffice-draw-1:6.1.4.2-2.fc29.x86_64                  @@System
    Upgrade  libreoffice-emailmerge-1:6.1.5.2-1.fc29.x86_64            @updates
    Upgraded libreoffice-emailmerge-1:6.1.4.2-2.fc29.x86_64            @@System
    Upgrade  libreoffice-filters-1:6.1.5.2-1.fc29.x86_64               @updates
    Upgraded libreoffice-filters-1:6.1.4.2-2.fc29.x86_64               @@System
    Upgrade  libreoffice-graphicfilter-1:6.1.5.2-1.fc29.x86_64         @updates
    Upgraded libreoffice-graphicfilter-1:6.1.4.2-2.fc29.x86_64         @@System
    Upgrade  libreoffice-gtk2-1:6.1.5.2-1.fc29.x86_64                  @updates
    Upgraded libreoffice-gtk2-1:6.1.4.2-2.fc29.x86_64                  @@System
    Upgrade  libreoffice-gtk3-1:6.1.5.2-1.fc29.x86_64                  @updates
    Upgraded libreoffice-gtk3-1:6.1.4.2-2.fc29.x86_64                  @@System
    Upgrade  libreoffice-help-cs-1:6.1.5.2-1.fc29.x86_64               @updates
    Upgraded libreoffice-help-cs-1:6.1.4.2-2.fc29.x86_64               @@System
    Upgrade  libreoffice-help-en-1:6.1.5.2-1.fc29.x86_64               @updates
    Upgraded libreoffice-help-en-1:6.1.4.2-2.fc29.x86_64               @@System
    Upgrade  libreoffice-impress-1:6.1.5.2-1.fc29.x86_64               @updates
    Upgraded libreoffice-impress-1:6.1.4.2-2.fc29.x86_64               @@System
    Upgrade  libreoffice-langpack-cs-1:6.1.5.2-1.fc29.x86_64           @updates
    Upgraded libreoffice-langpack-cs-1:6.1.4.2-2.fc29.x86_64           @@System
    Upgrade  libreoffice-langpack-en-1:6.1.5.2-1.fc29.x86_64           @updates
    Upgraded libreoffice-langpack-en-1:6.1.4.2-2.fc29.x86_64           @@System
    Upgrade  libreoffice-math-1:6.1.5.2-1.fc29.x86_64                  @updates
    Upgraded libreoffice-math-1:6.1.4.2-2.fc29.x86_64                  @@System
    Upgrade  libreoffice-opensymbol-fonts-1:6.1.5.2-1.fc29.noarch      @updates
    Upgraded libreoffice-opensymbol-fonts-1:6.1.4.2-2.fc29.noarch      @@System
    Upgrade  libreoffice-pdfimport-1:6.1.5.2-1.fc29.x86_64             @updates
    Upgraded libreoffice-pdfimport-1:6.1.4.2-2.fc29.x86_64             @@System
    Upgrade  libreoffice-pyuno-1:6.1.5.2-1.fc29.x86_64                 @updates
    Upgraded libreoffice-pyuno-1:6.1.4.2-2.fc29.x86_64                 @@System
    Upgrade  libreoffice-ure-1:6.1.5.2-1.fc29.x86_64                   @updates
    Upgraded libreoffice-ure-1:6.1.4.2-2.fc29.x86_64                   @@System
    Upgrade  libreoffice-ure-common-1:6.1.5.2-1.fc29.noarch            @updates
    Upgraded libreoffice-ure-common-1:6.1.4.2-2.fc29.noarch            @@System
    Upgrade  libreoffice-writer-1:6.1.5.2-1.fc29.x86_64                @updates
    Upgraded libreoffice-writer-1:6.1.4.2-2.fc29.x86_64                @@System
    Upgrade  libreoffice-x11-1:6.1.5.2-1.fc29.x86_64                   @updates
    Upgraded libreoffice-x11-1:6.1.4.2-2.fc29.x86_64                   @@System
    Upgrade  libreoffice-xsltfilter-1:6.1.5.2-1.fc29.x86_64            @updates
    Upgraded libreoffice-xsltfilter-1:6.1.4.2-2.fc29.x86_64            @@System
    Upgrade  libreofficekit-1:6.1.5.2-1.fc29.x86_64                    @updates
    Upgraded libreofficekit-1:6.1.4.2-2.fc29.x86_64                    @@System
    Upgrade  libreport-2.10.0-1.fc29.x86_64                            @updates
    Upgraded libreport-2.9.7-2.fc29.x86_64                             @@System
    Upgrade  libreport-anaconda-2.10.0-1.fc29.x86_64                   @updates
    Upgraded libreport-anaconda-2.9.7-2.fc29.x86_64                    @@System
    Upgrade  libreport-cli-2.10.0-1.fc29.x86_64                        @updates
    Upgraded libreport-cli-2.9.7-2.fc29.x86_64                         @@System
    Upgrade  libreport-fedora-2.10.0-1.fc29.x86_64                     @updates
    Upgraded libreport-fedora-2.9.7-2.fc29.x86_64                      @@System
    Upgrade  libreport-filesystem-2.10.0-1.fc29.noarch                 @updates
    Upgraded libreport-filesystem-2.9.7-2.fc29.noarch                  @@System
    Upgrade  libreport-gtk-2.10.0-1.fc29.x86_64                        @updates
    Upgraded libreport-gtk-2.9.7-2.fc29.x86_64                         @@System
    Upgrade  libreport-plugin-bugzilla-2.10.0-1.fc29.x86_64            @updates
    Upgraded libreport-plugin-bugzilla-2.9.7-2.fc29.x86_64             @@System
    Upgrade  libreport-plugin-kerneloops-2.10.0-1.fc29.x86_64          @updates
    Upgraded libreport-plugin-kerneloops-2.9.7-2.fc29.x86_64           @@System
    Upgrade  libreport-plugin-logger-2.10.0-1.fc29.x86_64              @updates
    Upgraded libreport-plugin-logger-2.9.7-2.fc29.x86_64               @@System
    Upgrade  libreport-plugin-reportuploader-2.10.0-1.fc29.x86_64      @updates
    Upgraded libreport-plugin-reportuploader-2.9.7-2.fc29.x86_64       @@System
    Upgrade  libreport-plugin-systemd-journal-2.10.0-1.fc29.x86_64     @updates
    Upgraded libreport-plugin-systemd-journal-2.9.7-2.fc29.x86_64      @@System
    Upgrade  libreport-plugin-ureport-2.10.0-1.fc29.x86_64             @updates
    Upgraded libreport-plugin-ureport-2.9.7-2.fc29.x86_64              @@System
    Upgrade  libreport-web-2.10.0-1.fc29.x86_64                        @updates
    Upgraded libreport-web-2.9.7-2.fc29.x86_64                         @@System
    Upgrade  libsane-hpaio-3.18.12-4.fc29.x86_64                       @updates
    Upgraded libsane-hpaio-3.18.12-3.fc29.x86_64                       @@System
    Upgrade  libtiff-4.0.10-2.fc29.i686                                @updates
    Upgraded libtiff-4.0.10-1.fc29.i686                                @@System
    Upgrade  libtiff-4.0.10-2.fc29.x86_64                              @updates
    Upgraded libtiff-4.0.10-1.fc29.x86_64                              @@System
    Upgrade  libwmf-0.2.12-1.fc29.x86_64                               @updates
    Upgraded libwmf-0.2.10-1.fc29.x86_64                               @@System
    Upgrade  libwmf-lite-0.2.12-1.fc29.x86_64                          @updates
    Upgraded libwmf-lite-0.2.10-1.fc29.x86_64                          @@System
    Upgrade  polkit-0.115-4.3.fc29.x86_64                              @updates
    Upgraded polkit-0.115-4.2.fc29.x86_64                              @@System
    Upgrade  polkit-libs-0.115-4.3.fc29.x86_64                         @updates
    Upgraded polkit-libs-0.115-4.2.fc29.x86_64                         @@System
    Upgrade  python2-scour-0.37-1.fc29.noarch                          @updates
    Upgraded python2-scour-0.35-9.fc29.noarch                          @@System
    Upgrade  python3-abrt-2.12.0-2.fc29.x86_64                         @updates
    Upgraded python3-abrt-2.11.1-3.fc29.x86_64                         @@System
    Upgrade  python3-abrt-addon-2.12.0-2.fc29.x86_64                   @updates
    Upgraded python3-abrt-addon-2.11.1-3.fc29.x86_64                   @@System
    Upgrade  python3-langtable-0.0.41-1.fc29.noarch                    @updates
    Upgraded python3-langtable-0.0.40-1.fc29.noarch                    @@System
    Upgrade  python3-libreport-2.10.0-1.fc29.x86_64                    @updates
    Upgraded python3-libreport-2.9.7-2.fc29.x86_64                     @@System
    Upgrade  sane-backends-1.0.27-22.fc29.x86_64                       @updates
    Upgraded sane-backends-1.0.27-18.fc29.x86_64                       @@System
    Upgrade  sane-backends-drivers-cameras-1.0.27-22.fc29.i686         @updates
    Upgraded sane-backends-drivers-cameras-1.0.27-18.fc29.i686         @@System
    Upgrade  sane-backends-drivers-cameras-1.0.27-22.fc29.x86_64       @updates
    Upgraded sane-backends-drivers-cameras-1.0.27-18.fc29.x86_64       @@System
    Upgrade  sane-backends-drivers-scanners-1.0.27-22.fc29.i686        @updates
    Upgraded sane-backends-drivers-scanners-1.0.27-18.fc29.i686        @@System
    Upgrade  sane-backends-drivers-scanners-1.0.27-22.fc29.x86_64      @updates
    Upgraded sane-backends-drivers-scanners-1.0.27-18.fc29.x86_64      @@System
    Upgrade  sane-backends-libs-1.0.27-22.fc29.i686                    @updates
    Upgraded sane-backends-libs-1.0.27-18.fc29.i686                    @@System
    Upgrade  sane-backends-libs-1.0.27-22.fc29.x86_64                  @updates
    Upgraded sane-backends-libs-1.0.27-18.fc29.x86_64                  @@System
    Upgrade  selinux-policy-3.14.2-48.fc29.noarch                      @updates
    Upgraded selinux-policy-3.14.2-47.fc29.noarch                      @@System
    Upgrade  selinux-policy-targeted-3.14.2-48.fc29.noarch             @updates
    Upgraded selinux-policy-targeted-3.14.2-47.fc29.noarch             @@System
    Upgrade  spice-server-0.14.1-2.fc29.x86_64                         @updates
    Upgraded spice-server-0.14.0-5.fc29.x86_64                         @@System
    Upgrade  systemd-239-11.git4dc7dce.fc29.x86_64                     @updates
    Upgraded systemd-239-9.gite339eae.fc29.x86_64                      @@System
    Upgrade  systemd-container-239-11.git4dc7dce.fc29.x86_64           @updates
    Upgraded systemd-container-239-9.gite339eae.fc29.x86_64            @@System
    Upgrade  systemd-libs-239-11.git4dc7dce.fc29.i686                  @updates
    Upgraded systemd-libs-239-9.gite339eae.fc29.i686                   @@System
    Upgrade  systemd-libs-239-11.git4dc7dce.fc29.x86_64                @updates
    Upgraded systemd-libs-239-9.gite339eae.fc29.x86_64                 @@System
    Upgrade  systemd-pam-239-11.git4dc7dce.fc29.x86_64                 @updates
    Upgraded systemd-pam-239-9.gite339eae.fc29.x86_64                  @@System
    Upgrade  systemd-udev-239-11.git4dc7dce.fc29.x86_64                @updates
    Upgraded systemd-udev-239-9.gite339eae.fc29.x86_64                 @@System
    Upgrade  thunderbird-60.5.0-4.fc29.x86_64                          @updates
    Upgraded thunderbird-60.4.0-1.fc29.x86_64                          @@System
    Upgrade  virt-manager-2.1.0-1.fc29.noarch                          @updates
    Upgraded virt-manager-1.6.0-1.3.git3bc7ff24c.fc29.noarch           @@System
    Upgrade  virt-manager-common-2.1.0-1.fc29.noarch                   @updates
    Upgraded virt-manager-common-1.6.0-1.3.git3bc7ff24c.fc29.noarch    @@System
Scriptlet output:
   1 warning: /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.201.b09-2.fc29.x86_64/jre/lib/security/java.security created as /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.201.b09-2.fc29.x86_64/jre/lib/security/java.security.rpmnew
   2 restored /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.201.b09-2.fc29.x86_64/jre/lib/security/java.security.rpmnew to /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.201.b09-2.fc29.x86_64/jre/lib/security/java.security

Pak už TB nelze spustit:
$ thunderbird

        (thunderbird:2807): Gtk-WARNING **: 17:41:25.109: Theme parsing error: <data>:1:34: Expected ')' in color definition

        (thunderbird:2807): Gtk-WARNING **: 17:41:25.109: Theme parsing error: <data>:1:77: Expected ')' in color definition
        Segmentation fault (core dumped)

Prozatím pomohlo tohle:
# dnf downgrade thunderbird
Last metadata expiration check: 0:24:39 ago on Mon 11 Feb 2019 17:40:57 CET.
Dependencies resolved.
================================================================================
Package Arch Version Repository Size
================================================================================
Downgrading:
thunderbird x86_64 52.8.0-1.fc29 fedora 76 M

Transaction Summary
================================================================================
Downgrade  1 Package

Total download size: 76 M
Is this ok [y/N]: y
Downloading Packages:
thunderbird-52.8.0-1.fc29.x86_64.rpm            5.4 MB/s |  76 MB     00:13    
--------------------------------------------------------------------------------
Total                                           5.0 MB/s |  76 MB     00:15     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Downgrading      : thunderbird-52.8.0-1.fc29.x86_64                       1/2 
  Running scriptlet: thunderbird-52.8.0-1.fc29.x86_64                       1/2 
  Cleanup          : thunderbird-60.5.0-4.fc29.x86_64                       2/2 
  Running scriptlet: thunderbird-60.5.0-4.fc29.x86_64                       2/2 
  Running scriptlet: thunderbird-52.8.0-1.fc29.x86_64                       2/2 
  Running scriptlet: thunderbird-60.5.0-4.fc29.x86_64                       2/2 
  Verifying        : thunderbird-52.8.0-1.fc29.x86_64                       1/2 
  Verifying        : thunderbird-60.5.0-4.fc29.x86_64                       2/2 

Downgraded:
  thunderbird-52.8.0-1.fc29.x86_64                                              

Complete!

Ale že bych měl pocit, že jde o nějak zvlášť elegantní řešení… Co s tím?


#2

Ještě taková zajímavá věc. Při pokusu o replikaci po upgradu na jiném stroji vyskočí ta chybová hláška Gtk-Warning a Theme parsing error a tak dál jakbysmet, ale bez dodatku

Segmentation fault (core dumped)

Čili TB naběhne…
To už je na mě opravdu moc velká magie…


#3

To je spíš na nahlášení bugu. V bugzille jsem našel k TB 60.5 jenom tento pád.