Statické nastavení IP adresy


#1

Dobrý den,
nedaří se mi staticky nastavit IP adresu. Mám nainstalovanou Fedoru 20

Můj postup je následující:

otevřu si soubor /etc/sysconfig/network-scripts/ifcfg-p2p1

Vypadal takto:

TYPE=ETHERNET
BOOTPROTO=dhcp
DEFAULTPROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFPROUTE=yes
IPV6_PEERDNS=yes
IPV6_FAILURE_FATAL=no
NAME=p2p1
UUID=xxxx-xxx-xxx-xxx-xxx
ONBOOT=no
HWADDR=A1:B2:C3:D4:E5:F6
PEERDNS=yes
PEERROUTES=yes

Upravil jsem jej následovně, uložil a restartoval:

TYPE=ETHERNET
BOOTPROTO=static
DEFAULTPROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFPROUTE=yes
IPV6_PEERDNS=yes
IPV6_FAILURE_FATAL=no
NAME=p2p1
UUID=xxxx-xxx-xxx-xxx-xxx
ONBOOT=yes
HWADDR=A1:B2:C3:D4:E5:F6
PEERDNS=yes
PEERROUTES=yes
IPADDR=192.168.1.9
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
DNS1=192.168.1.9


#2

Nějak mi tu chybí otazník, tak nevím na co odpovídat… Tak to zkusíme rozvést:

  • v čem je problém - nejde se připojit k síti nebo konfigurace nefunguje a neaplikuje se?
  • je statické přiřazování v síti povolené?
  • co vypíše ifconfig?
  • co vypíše systemctl status NetworkManager.service (jestli používáš network manager)

#3

stderr: omlouvám se za špatnou formulaci dotazu.

Problém je v tom, že jsem po přepsání výše uvedeného souboru očekával, že po zadání příkazu ifconfig dostanu u zařízení p2p1 výstup "inet 192.168.1.9 síťová_maska 255.255.255.0, to se ovšem nestane.

  • k síti jsem připojený přes wi-fi

  • jestli je statické přiřazování v síti povolené nevím, ale asi ano, protože IP jsem vždy nastavoval "ip a a 192.168.1.9/24 dev p2p1 - nepřežije to restart. Chci aby tato adresa zůstala i po restartu.

  • ifconfig vypisuje u zařízení, které potřebuji nastavit toto
    ¨
    p2p1: flags=4099<AKTIVOVÁNO, VŠESMĚR, MULTICAST> mtu 1500
    ether 04:7d:7b:99:7a:c0 délka_odchozí_fronty 1000 (Ethernet)
    RX packetů 0 bajtů 0 (0,0 b)
    RX chyb 0 zahozeno 0 přečetní 0 rámců 0
    TX packetů 548 bajtů 45768 (44,6 KiB)
    TX chyb 0 zahozeno 0 přečtení 0 přenos 0 kolizí 0

  • network manager nepoužívám, ale asi bych měl?


#4

V domácí síti je jednodušší prostudovat si příručku nastavení Vašeho routeru. Jistě umožní rezervovat pevnou ip-adresu k MAC adrese přípojeného zařízení.


#5

IPI: dobrý den, děkuji za Váš příspěvek, nicméně nemá pro mě žádnou relevantní hodnotu - nikterak neřeší můj problém.

  1. Moje potřeba nastavit pevnou IP adresu konkrétnímu síťovému rozhraní, je studijního charakteru.
  2. Chci doma testovat funkčnost DHCP serveru a chci (zřejmě to není naprosto nutné, nicméně CHCI), aby tento server měl statickou IP adresu.

Napadlo mě, jestli problém nemůže být v “názvu” zařízení p2p1 - myslel jsem, že dle “zavedených konvencí” by se toto zařízení mělo jmenovat eth0. Takže jsem trošku pátral:

dmesg | grep eth0
system-udevd: renamed network interface eth0 to p2p1

I když výše uvedený obsah, je ze souboru /etc/sysconfig/network-scripts/ifcfg-p2p1, takže by mělo být vše teoreticky v pořádku?

I přesto by mě zajímalo, která část systému má zapotřebí přejměnovat eth0 na p2p1 a z jakého důvodu??


#6

A logy po restartu sítě neříkají nic? A co systemctl status network.service, když už to jde mimo NM? IPv6 používáš? Zkus to vypnout.

Jinak mixovat DHCP se statickou IP asi není úplně nejlepší nápad - na routeru si zkus aspoň ohlídat, abys neměl statickou IP z rozsahu, který dohazuje DHCP server.

Jména zařízení se měnila, proto p2p1. Žádnou velkou alchymii za tím nemusíš hledat. http://fedoraproject.org/wiki/Features/ConsistentNetworkDeviceNaming


#7

stderr: Omlouvám se za předešlý příspěvek, kdy jsem napsal, že NM nepoužívám. Jsem začátečník a měl jsem za to, že pokud nic nespouštím, tak to nepoužívám, nicméně:

service NetworkManager status
active: active (running)

service network status
Nastavená zařízení:
lo example p2p1
Právě aktivní zařízení:
lo p2p1 wlp2s0

Provedl jsem:
systemctl disable NetworkManager service
chkconfig network on

Možná ještě nějaké obdobné manipulace, restart a funguje to.

Jen si teď říkám, jestli jsem na to nešel nějak špatně. Podle všeho mi příjde, že by bylo možná snažší nastavit tu IP přímo přes NM, než jej vypínat?

Taky bych se chtěl ještě zeptat, jestli velký rozdíl když použiji např.

service postfix start
míto
systemctl start postfix service

Používám kratší zápis a během hledání na netu jsem zjistil, že spousta lidí používá zápis delší.


#8

Nijak zvlášť špatně jsi na to nešel, ale ano, mohlo se to udělat přes NetworkManager.

Od dob, co je ve Fedoře systemd se přešlo z init skriptů na systemctl, možnost používat příkaz service zůstává spíš z kompatibilních důvodů a beztak se volá nakonec stejně systemctl. Do budoucna doporučuji se seznámit raději s “dlouhým” zápisem, tedy systemctl > https://fedoraproject.org/wiki/Systemd


#9

Pouhou editaci souboru ifcfg-xyz se nastaveni nezmeni. Musi se restartovat sluzba network. Sluzby network a NetworkManager jsou disjunktni nemeli by bezet najednou.
Aktualni nastaveni rozhrani se da zmenit primo prikazem ifconfig nebo ip, nesmi ale bezet NetworkManager, ktery zarizen prenastavi zpet.
Zakazat NM lze v GUI jeho vypnutim, stejne tak se ale v NM da pokud je zapnuty nastavit pevna IP - NM->Edit connections -> IPv4 settings -> Method: manual
Nevim zda lze toho sameho jiz dosahnout z prikazove radky pres nmcli.


#10

covex: díky za vyčerpávající odpověď :slight_smile: super