sp5100_tco: I/O address 0x0cd6 already in use


#1

Zdravím,
před několika dny jsem si nainstaloval Fedoru 25. Podle tohodle návodu jsem nainstaloval ovladač na GeForce GTX 260. Hnedka na začátku se píše která řada pracuje se kterým ovladačem. Pro moji řadu 200 se psalo že mám použít ovladač 340.101.
V části 2.1 se píše že kdo má kernel 4.9 má si stáhnout patchnutou vverzi. Já sem měl tehdy 4.8, ale hnedka pod tím se psalo že mám upgradovat na nejposlednější kernel … celej ten návod je trošku zmatenej, ale ok … podle návodu jsem upgradnul na kernel 4.9 a vrátil se o krok výš a stáhnul si jejich patchnutej ovladač … tady je další zmatení, protože se tam píše ješte o nějakým extra patchování, ale mluví jen o 304.134. Na moji 340.101 ten patch pochopitelně nefungoval a tak sem tenhle krok teda přeskočil a pokračoval s údajně patchnutou verzí …
V části 2.6 se mluvi zakázání nouveau echo “blacklist nouveau” >> /etc/modprobe.d/blacklist.conf Tady je možná další problém.
Dál se zákaz přidává do GRUB. Potom se bootuje do runlevel 3 (nevím co ty levely znamenají, ale vše bylo ok). Tam se instaluje ovladač a potom zpět do runlevel 5.
Do této doby bylo vše zdánlivě OK - mohl jsem nabootvat, ale přetrvaly drobnější problémy u kterých jsem doufal že “zmizí” s instalací driveru. Konkrétně se jednalo o malé rozlišení na 2. monitoru. Na GPU mám 2x DVI výstup, ale inkriminovaný monitor je připojen přes redukci a přes VGA.
Konkrétně:

  1. monitor (vše OK)
    LG FLATRON W2242T
    připojen přez DVI
  2. monitor (nechutně malé rozlišení 640x480)
    HP 2035
    připojen přez VGA
    dle výrobce rolišení 1600x1200

Řešením tohoto drobného problému teprve začaly velký problémy.
Po nějaké době googlení sem vykoušel řešní pomocí xrandr, ale bez úspěchu.
Tady bohužel přestává sloužit moje pamět - historie googlení zůstala na nebootujícím počítači. Tzn že si nepamatuji detaily které jsem provedl před tím než to přestalo bootovat.

teď to vypadá tak že po dialogovém “okně” GRUB se začne bootvat, ale vyskočí hláška “sp5100_tco: I/O address 0x0cd6 already in use” a ta by tam zůstala asi až do konce světa.
Na netu jsem k tomuto našel jen velice málo, až úplné… proto zakládám toto vlákno.

Pokud budete potřebovat nějaké detaily které budu schopný vytáhnout pře bootováním, tak to budu řešit odpoledne, až se dostanu domů.

Předem děkuji :slight_smile:


#2

Osobně bych rozhodně doporučoval instalaci ovladačů z balíčků, které jsou určené pro Fedoru, ne přímo od Nvidie. Ty balíčky řeší celou řadu problémů za uživatele. Je možnost je nainstalovat z RPM Fusion (návod tady na wiki) nebo z Negativo17, což je dnes doporučovanější a brzo bude povolený i v GNOME Software, takže to bude oficiální cesta, jak ovladače od Nvidie na Fedoře instalovat: http://negativo17.org/nvidia-driver/


#3

Ok, tak vcera vecer sem si F25 (plasma) nainstaloval komplet znova a dneska jedu podle tohodle navodu byl tam (doufam drobnej) err pri vykonavani prikazu
dnf install akmod-nvidia-340xx “kernel-devel-uname-r == $(uname -r)”

No package kernel-devel-uname-r == 4.9.6-200.fc25.x86_64 available.
Error: Unable to find a match.

Vtipna je na tom poznamka v navodu: “Poznámka: Vzhledem k tomu, že výše uvedené balíčky mají formu rozšíření jádra, musí tyto balíčky odpovídat verzi Vašeho jádra. Je tak možné, že společně s ovladačem bude zapotřebí stáhnout také nové jádro.” tak nevim jestli mam downgradovat na 4.8…
Zbytek se provedl bez problemu, tak doufam ze tenhle zadrhel nebude na obtiz.

Hadam ze je potreba restartovat, tak jdu na to.


#4

Jupi, uplne stejnej error jako na zacatku!
Po restartu komplu mi nvidia napsala ze mam restartovat x server. Jediny co sem nasel bylo pomoci telinit 3 coz me hodi do konzole bez grafickyho prostredi a vratit me melo telinit 5, po tomhle prikazu ale jen parkrat probliknou artefakty a tim to skonci.


#5

No tak samozrejme ze pokud pri instalaci modulu do jadra, ve kterem je ten ovladac co potrebujes nastane error protoze ti nesedi verze jadra a modulu, tak to asi fungovat nebude…


#6

Zdravim, dlouho sem se k tomu nedostal, ale zkousim to znova. Prosim o pomoc pri reseni meho zahadneho problemu.

Nabootoval jsem do jadra 4.8 a dale postupoval podle navodu na negativo17. Konkretne:
pridani repozitare:
dnf config-manager --add-repo=http://negativo17.org/repos/fedora-nvidia.repo

BTW na strance se pise “Starting from Fedora 25, the Nvidia software packages are available for installation by default also in Gnome Software.” coz v mem pripade neplati ani po pridani repozitare - kde by mohla byt chyba??

potom instalace balicku:
dnf -y install nvidia-driver nvidia-settings kernel-devel

od tohoto momentu vidim v aplikacich naintalovany ovladac.
Po restartovani se zacinaji dit veci - a nevypadaji hezky:
Prvni vec kterou vidim je zprava z nadpisu: “sp5100_tco: I/O address 0x0cd6 already in use” tu to nastesi prejde a nezasekne se vse jako posledne. Po nekolika probliknutych obrazovkach s barevnymi fragmenty. Se mi zobrazi prihlasovaci okno s nizkym rozlisenim a po prihlaseni me nvidia driver pise nasledujici: “You do not appear to using the NVIDIA X driver. Please edit your X configuration file (just run ‘nvidia-xconfig’ as root), and restart the X server.”
Po instalaci a spusteni ‘nvidia-xconfig’ googlim jak restartovat X server. Nasel jsem posloupnost prikazu init 3 a init 5.
Po zadani init 3 se objevi obrazovka s blikajicim podtrzitem vlevo nahore. Chvili se nic nedeje, tak zkousim prepnout pomoci Ctrl + Alt + F2. Dostanu se na obrazovku s textovym loginem, ale zvlastne blika - jako by snad mela epileptickej zachvat. Dokonce se tak chova i vstup - chvilkama neprijima stiky klaves, takze je nemozny se prihlasit, kdyz nevim kterou cast hesla to prijmulo a kterou ne.
Ze zahadnyho duvodu po neuspesnem pokusu o prihlaseni blikani prestane a jsem schopny se prihlasit. sudo init 5 asi po 2 vterinach zobrazi sedou tmave obrazovku se 3 svetle sedejma obdelnickama zhruba uprostred.
A to je asi tak vsecko - dal to nic nedela.

Zduraznuju ze instalace probehla uspesne a BEZ erroru!

Napada vas prosim neco?


#7

V GNOME Software ještě nejdou vidět, protože ještě nejsou vyřešené všechny problémy (tak to nechtějí nabízet běžným uživatelům). Kolega zápasil s Nvidia ovladači nedávno. Ovladače od Nvidie se rozbily s updatem kernelu v F25, asi to na ně byla příliš nová verze. Zkusil bych tedy downgrade kernelu a nainstalovat to do něj a pak prostě nepoužívat nový kernel, dokud s ním nebudou ovladače kompatibilní.

Kolega to nakonec vyřešil tak, že kartu od Nvidie vyhodil z okna s tím, že už od nich nechce nikdy nic vidět, a koupil si kartu od AMD a je spokojený :slight_smile: