Nízké rozlišení s GF 1050 Ti


#1

Ahojky, dala jsem si do PC konečně GF 1050 Ti a i když plocha bez problémů naskočí, tak je v nízkém rozlišení 1024x768 a neumožní mi změnu. Ovladač grafiky to hlásí Gallium 0.4 on llvmpipe (LLVM 3.8, 128 bits).Při spuštění to napíše nouveau (nějaká čísla) unknown chipset (nějaká čísla).

Poradíte co s tím prosím? Ideální by asi byly přímo ovladače Nvidia, ale abych s tím už nemusela nic dělat. Celkově prostě něco, co funguje, umožní mi to nastavit 1920x1080 a bude to akcelerovat 3D. Děkuji.


#2

V příručce máš návod: https://wiki.mojefedora.cz/doku.php?id=navody:prirucka:hardware#instalace_ovladacu_pro_graficke_karty_nvidia_a_amd_ati

Je potřeba mít aktivovaný repozitář RPM Fusion.


#3

Hmmm, tak po provedení toho, co je ve wiki, zůstane po spuštění jen černá obrazovka a nic se neděje. Ale počítač se nekousl, na CTRL+ALT+DEL se restartoval. A když vyberu starší jádro, tak mi to píše “Jejda! Něco se pokazilo.”


#4

Zajímavé…
Už je mi jasné, proč se open source ovladače vůbec nechytají, je to totiž úplně nejnovější generace karet (NV130), kterou ty ovladače zatím vůbec neznají. Tam je podpora zatím u NV110: https://nouveau.freedesktop.org/wiki/FeatureMatrix/

Předpokládám, že jsi provedla příkaz: dnf install akmod-nvidia “kernel-devel-uname-r == $(uname -r)”, přičemž za to v “” dosadíš verzi kernelu, kterou aktuálně používáš (zjistíš třeba tím příkazem uname -r). V mém případě to je 4.9.9, takže celý příkaz je: dnf install akmod-nvidia kernel-devel-4.9.9


#5

Jinak pokud chceš poslední operaci vrátit, tak je potřeba vrátit poslední operaci s balíčky. Můžeš nabootovat do záchranného režimu a dát “dnf history undo last”.


#6

Ano, udělala jsem to tak, jak píšeš. Vrátit to chci, protože to nefunguje :frowning: Děkuji za příkaz.

edit: tak ani po tom příkazu to už nenaběhne a ani po odinstalaci dotyčných ovladačů. Prostě to nefunguje… Musím říct, že mě to už přestává bavit.


#7

Ahoj,
zkus použít repozitář negativo17. Tenhle postup by měl fungovat:


sudo dnf config-manager --add-repo=http://negativo17.org/repos/fedora-nvidia.repo
sudo dnf remove "nvidia" && sudo dnf install nvidia-driver dkms-nvidia nvidia-driver-libs.i686

a potom restart.


#8

Zkusím, děkuji a dám vědět.

edit: tak Bohužel žádná změna :frowning: A to jsem vyzkoušela všechna tři jádra, která tu mám a vždycky ta hláška “Jejda, něco se pokazilo”.


#9

Je tedy nějaká šance mít vyšší rozlišení a alespoň mít akcelerovaná videa nebo prostě musím počkat, až někdy bude vydána podpora té mé karty? Na 1024x768 se nedá dívat a často se ani ovládací prvky nevejdou na obrazovku a nedá se to používat…

Jinak bych tedy samozřejmě nejradši měla ovladače přímo od Nvidie, ve Windows fungují bezvadně, ale tady jsem zkusila dva postupy a ani jeden nefungoval :frowning: Bude to někdy fungovat prosím? Už jsem to i nainstalovala znova načisto, protože ta chyba se mi nepovedla odstranit a prostě to nefungovalo :frowning:


#10

No, to je bohužel riziko uzavřených ovladačů. Fedora nemůže zajistit 100% kompatibilitu s něčím, co je uzavřené a co si distribuuje někdo jiný… Proto jsme tě tenkrát tak tlačili do AMD.
Bez ovladačů od Nvidie to nepůjde. Open source nouveau tuto generaci ještě vůbec neznají, proto se zapne fallback llvmpipe, který to celé vykresluje přes procesor a to je prostě mizerný výkon s mizerným rozlišením.

Můžeš ještě zkusit nainstalovat ovladače přímo ze stránek Nvidie: http://www.nvidia.com/object/unix.html
Zdá se, že ta poslední verze, která vyšla před třemi dny, přidává podporu pro Xorg 1.19, který je ve Fedoře 25: http://www.nvidia.com/Download/driverResults.aspx/115031/en-us
To by mohlo pomoci a je možné, že tato verze v Negativno17 a RPM Fusion repozitářích ještě není.


#11

Zasadni nerozum je kupovat si k Linuxu HW bez toho aby si clovek predem overil, ze je v Linuxu dane verze podporovan. Jeste vetsi nerozum je pak kupovat nej-verze daneho HW, ktere navic ma jeste jen mizive procento lidi. Pokud chci funkcni HW v Linuxu, musim vybirat mainstream, idealne uvedeny na trha tak aspon pred rokem.


#12

Sešívaný: já vím, že jste mi radili s ohledem na Linux, ale já jsem od začátku říkala, že primárně to PC bude pro hry ve Windows a že Linux na něm bude jen proto, že mě zajímá, ale že s ním nedokážu plnohodnotně fungovat, protože spoustu věcí neumí a pro spoustu věcí nemá SW. Pro skutečnou práci mám Mac (a k tomu iPhone, ten s Linuxem snad ani spojit nejde, maximálně tak přes iTunes přes wine) a na hraní PC s Windows 10 (defacto je to na úrovní herní konzole, třeba jako PS4). AMD jsem nezvolila proto, že primární je pro mě výkon a stabilita ve Windows, navíc ta 1050 Ti má dostatečný výkon pro všechno ve fullHD (Zaklínač 3 jakožto moje aktuálně nejnáročnější hra má stabilně 49 fps), má maximálně TDP 70 W a stála mě pár korun přes 4.000 Kč. AMD s tímto výkonem by byla RX 480, která je cenově úplně jinde a spotřebou je cca na dvojnásobku nebo RX 470, která je pomalejší, dražší a také má vyšší spotřebu. Proto jsem zvolila lepší Nvidii než horší AMD.
Ty ovladače přímo od Nvidie zkusím, děkuji.

covex: já jsem to ale nekupovala k Linuxu, já jsem to kupovala k Windows 10 pro hraní her. Linux je prostě jedna z her, protože na něm zatím nedokážu plnohodnotně fungovat. Další věc je, že jsem sice mohla koupit starou desku se starým procesorem a starou grafickou kartou a navíc i se starou RAM, ale radši jsem zvolila nové a výkonnější za stejnou cenu a ve vyšší kvalitě. Jestli je Linux tak nekvalitní OS jak tvrdíš, že nezvládne nový HW (což chápu u uzavřeného macOS, kde si koupím HW a jemu na míru šitý 100% stabilní a dokonalý OS a proto hackintosh nemůže plnohodnotně fungovat, ale nejsem ochotna to akceptovat u otevřeného Linuxu). Prostě nechci zastaralý a drahý HW, chci rozumný poměr cena/výkon, což mi dala deska B250, procesor Kaby Lake a již zmíněná Nvidia 1050 Ti, protože za danou cenu nic lepšího není. A navíc přijde mi jako hloupost dnes investovat do PC s DDR3, když každý nový PC používá DDR4 a já jsem si to koupila i s ohledem na budoucnost a případný upgrade.

Mimochodem, mám teď nainstalovaný také OpenSUSE Leap 42.2 a tam rozlišení funguje. Sice mi to také tvrdí že nouveau unknown nebo jak to je, ale aspoň to běží ve fullHD a vytížení procesoru při přehrávání fullHD videa je podle sledování prostředků do 10%, takže to podle všeho akceleruje přes grafickou kartu (vytížení GPU nevím jak zjistit, GPU-Z resp. jeho obdobu jsem nenašla a to sledování prostředků mi ukazuje jen vytížení VRAM a teplotu na čipu GPU). Proč to ve Fedoře (která je tak pokroková a používá jen to nejmodernější) nejde a v OpenSUSE (které si podle vývojářů zakládá na stabilitě a spolehlivosti a proto tam mají relativně staré verze - tak jsem to pochopila podle jejich wiki) to funguje? Jádro tam je 4.4 zatímco ve Fedoře mám 4.9 a něco… Já bych prostě ráda měla Linux jako alternativu k macOS, ale takhle to Bohužel nejde :frowning:


#13

Fedora není pokroková, jen jsou v ní některé “žhavé novinky”, které si RedHat testuje na lidech, protože na zvířatech nesmí. Fedora je plná zahnívajícího software a je těžké do ní dostat nové verze softu, pokud nejde zrovna o něco, o co mají zájem vyvolení. SUSE bude pro vás asi lepší volba.


#14

Neni nahodou OpenSuse Leap jaksi hybrid - kdyby se pouzilo normalni OpenSuse tak bude problem stejny. Mozna v Rawhide by to bylo podobne, ale to se opet nehodi pro cloveka, ktery s tim nema zkusenosti.

Osobne nechapu, proc na pocitaci tohoto vykonu delat na vyzkouseni Linuxu dualboot a nepoustet Linux ve Virtualboxu. Odpadnou tim podobne problemy s ovladaci grafiky - samozrejme, hrat hry na Linuxu ve virtualboxu je nesmysl, ale na zkouseni to staci…

Ono proste herni Windows PC neni dobre pro Linux. Ja pouzivam PC na praci a potrebuju aby fungovalo, ne abych honil MHz u procesoru, DDR a grafiky nebo se musel klanet nakousnutemu jabku, jestli zrovna nepotrebuju extra redukci abych mohl pripojit ethernetovy kabel - navic jsem vdecny za kazdou hodinu kdy u PC sedet nemusim, ale to prijde az pozdeji, ted si jeste hrajte a zkousejte ruzne distribuce…


#15

covex: to nevím, přiznám se, že to ani neřeším, důležitá je funkčnost.

Jinak od začátku říkám, že to PC je primárně na hry, protože mě konzole příliš nevyhovují (na PS4 si nezahraji třeba Morrowind, protože je už moc starý), mám místo ní PC. Nehoním MHz ani nic jiného, ale samozřejmě si nekoupím něco zastaralého, když můžu mít za stejnou cenu moderní. Nakousnutému jablíčku se také neklaním, pouze ho používám a i když se asi budeš divit a nebudeš mi věřit, tak žádné redukce neřeším. Koupila jsem si redukci z USB-C na staré USB (mimochodem, základní desku pro herní PC jsem vybírala také tak, aby měla USB-C, protože v tom je budoucnost) a připojím všechno od iPhonu přes flash disk, externí disk až po čtečku paměťových karet. Tato redukce mě stála 99 Kč a je to miniaturní kostička. Pokud potřebuji z MacBooku obraz na TV, použiju AirPlay a neřeším nějaké trapné kabely. Síť mi jede přes wifi ac, tedy o cca 400 Mbps rychleji než po kabelu a záloha na Time Capsule je hotová rychleji než z Miniho, který je připojený kabelem (holt 1 Gbps kabel vs 1.4 Gbps wifi). Ono než začneš něco hanět, měl by sis o tom zjistit informace, protože vlastně haníš něco, o čem vůbec nic nevíš.

Jinak na práci mám samozřejmě Mac, jiná možnost není, na hraní her mám Windows 10 a místo psa mám Linux :smiley: Ale už máme v plánu si hafíka pořídit a bude to ještě letos.


#16

covex napsal(a):

Neni nahodou OpenSuse Leap jaksi hybrid - kdyby se
pouzilo normalni OpenSuse tak bude problem stejny.
Mozna v Rawhide by to bylo podobne, ale to se opet
nehodi pro cloveka, ktery s tim nema zkusenosti.

openSUSE Leap je stabilné vydanie so základom SUSE, preto to jadro 4.4.
Niečo ako ekvivalentom pre Fedora Rawhide je openSUSE Tumbleweed, čo je rolling distro s najnovšími, niekedy nie celkom vyladenými verziami balíkov a softvérov.


#17

mosaic napsal(a):

Fedora není pokroková, jen jsou v ní některé
“žhavé novinky”, které si RedHat testuje na
lidech, protože na zvířatech nesmí. Fedora je plná
zahnívajícího software a je těžké do ní dostat
nové verze softu, pokud nejde zrovna o něco, o co
mají zájem vyvolení. SUSE bude pro vás asi lepší
volba.

Co to je za nemysl? Fedora má docela jasnou aktualizační politiku. Pokud je nějaký balíček starý, tak to není tím, že “je těžké do ní dostat nové verze softu”, ale protože na to daný maintainer kašle.

openSUSE Leap je distro, které je výrazně konzervativnější než Fedora, takže rozhodně “pokrokovější” není. openSUSE Tumbleweed je rolling release, takže má zpravidla novější verze než Fedora, ale za cenu stability a uhlazenosti. Ještě jsem nepoznal rolling release distro, které by šlo jen prostě používat a kde by se občas něco nerozbilo. Pokud bych chtěl to vždy nejnovější, tak popravdě bych asi spíš šel do Archu, který má oproti Tumbleweedu výrazně více balíčků.


#18

Pokud je nějaký balíček starý … (je to tím) … protože na to daný maintainer kašle.

Samozřejmě. To se nevylučuje s tím, co jsem psal. Příklad: v jednom konkrétním případě jsem upozornil, že na “na to maintainer kašle” a nabídl jsem rpm, které si stejně tvořím pro vlastní potřebu. Byl jsem odkázan na šílenou proceduru, která kromě tří různých registrací znamenala instalaci nějakého softwaru, který bych se musel učit používat a spoustu nesmyslné prudy s tím, že za rok se to možná dostane do distribuce. Tak jsem je poslal do háje, jsem zaměstnaný člověk. Nedivím se maintainerům, že na to kašlou a noví se nehlásí. Takže výsledek je ten, který jsem popsal. Fedora je plná zahnívajícího softu. Nové jsou věci, které dělají lidé, co na to mají čas a dostanou za to zaplaceno. Normální uživatel se za daných podmínek na to může akorát tak vykašlat. Takže jsou ve zběsilém tempu vyvíjeny jen ty věci, o které má zájem komerce nebo deep state.

K SUSE - nepsal jsem, že je Leap pokrokovější, psal jsem, že je pro Abby vhodnější volbou. Problém s psaným textem?


#19

Takovou šílenou proceduru má každá větší distribuce včetně SUSE. Každý package maintainer dostává prakticky root access ke stovkám tisích instalací (instalační skripty můžou dělat prakticky cokoliv a běží pod rootem), takže distribuce nemůže dělat balíčkáře jen tak z někoho, kdo se objeví na Internetu.

Z pohledu člověka, který chce jenom něco opravit a nabízí funkční a bezproblémové řešení, to možná vypadá neflexibilně, ale je to jediné dlouhodobě udržitelné řešení.


#20

Argument vypadá rozumně, ale výsledkem je současný, IMHO neuspokojivý, stav. Určitě by se to dalo řešit lépe a pružněji - když má “komunita” zdroje na najímaní genderových poradců, určitě by našla zdroje i na seriózní věci. Jen pro ilustraci - když jsem potřeboval procpat kousek kódu do jádra, tak stačily dva e-maily Kroag-Hartmanovi a vyplnit jeden formulář. A ohaduji, že bezpečnost jádra je minimálně stejně důležitá, jako bezpečnost instalačního skriptu rpm.
Omlouvám se za off-topic.