(ne)vypínání síťové karty


#1

Zdravím všechny,
prosím o pomoc s nastavením síťové karty ve Fedoře 21. Používám na jiných PC Ubuntu a Mint, takže jsem lehce mimo.
Jde mi o to aby Fedora nevypínala síťovou kartu při vypnutí PC a já mohl počítač vzbudit po síti (WOL). V Ubuntu nastavím v init.d NETDOWN=no a mám vyřešeno. Tady ve fóru se mi nepodařilo odpověď najít. Prosím o nasměrování či radu.
Nemyslím že na tom záleží, ale pro jistotu:
Ethernet controller: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet (rev b0)


#2

Na wiki Archu to mají pěkně popsané: https://wiki.archlinux.org/index.php/Wake-on-LAN
Od Fedory by se to nemělo výrazněji lišit, doporučuji to řešení přes udev, případně systemd.


#3

Dlouho jsem pouzival skript ktery to nastavil v rc.local nebo halt… se systemd se to zmenilo ale melo by to fungovat - proste nastavit flag.

ethtool -s eth0 wol g


#4

Děkuji za pomoc,
podle wiki.archlinux.org a vyhledání nějakých dalších informací k systemd se mi vše podařilo. Díky i covexovi, napomohl mi jeden z jeho starších příspěvků. Jsem linuxový a zvláště Fedorový BFU, takže ještě jednou díky.