Internet přes wifi

Zdravím, nedávno jsem si stáhl Fedoru 7 (KDE, CD-verze), líbí se mi a chtěl bych ji provozovat :),ale mám problém: K internetu jsem připojen přes wifi, bohužel wifi karta mi ve Fedoře nejde… (Teď jsem v mdv 2007 - karta se mi hlásí jako Atheros Communications INC. AR5213 802.11a/b/g Wireless Adapter). Našel sem, že potřebuji ovladače madwifi ty jsem se snažil nainstallovat, ale kvůli závislostem na jiných balíčckých nešli. Chtěl bych poradit, jestli nevíte někdo, jak na to, popřípadě jestli se to nezlepší ve verzi 8. (V jiných distribucích ani v DesktopBSD jsem tenhle problém neměl).

PS: Fórum jsem prohledal, ale nic o tom jsem nenašel, pokud tu něco je stačí přesměrovat odkazem.

Ano, atheros v teto verzi bezproblemove podporuje ovladac madwifi. Tyto baliky lze normalne nainstalovat z repozitare livna. Protoze zrejme nemas sit, potrebujes balik

kmod-madwifi - musis stahnout verzi odpovidajici tvemu kernelu. (uname -r)
a
madwifi - napr. http://livna-dl.reloumirrors.net/fedora/7/i386/madwifi-0.9.3.1-1.lvn7.i386.rpm

Díky, jen bych se chtěl ještě zeptat než se do toho pustím, jak je to s konfigurací?

Ja konfiguruju vzdy pres iwconfig - commandline utilita, ale vy asi budete chtit neco pohodlnejsiho jako wifiradar nebo jak se to jmenuje. Mozna to zvladne i networkmanager, ale jiste to rici nemuzu.

Zdravim,
instaloval jsem kmod-madwifi pro svuj kernel i madwifi. Vse probehlo OK. Restartoval jsem, (doufam, ze neni ovladac nutno do jadra zavadet extra) ale iwconfig porad tvrdi, ze tam karta neni. Vypis z lspci je pritom jasny -
05:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g Wireless PCI Express Adapter (rev 01)
Takze tam asi je. Nemam s tim absolutne zadnou zkusenost a vubec netusim jak madwifi, resp. wifi rozjed, ale hodilo by se bezdrat pripojeni, kdyz je AP na strese.

Jedna se o notebook, vypinac jsem zkousel, a jedu na fc8/64. Jadro je 2.6.23.14-107.fc8

Mam taktez atheros karty a priznam se, ze nevim jak se to nastavuje automaticky.
Ve F8 jsou dva ovladace ath5k - open source ovladac - ktery s nekterymi kartami funguje, ja ho ovsem nepouzivam, a madwifi, ktery jste instaloval. Kdyz se instaluje kmod-madwifi, tak se prida ath5k do blacklistu aby se nepouzival.
lspci jste pouzil spravne, system kartu zna, ted je potreba zjistit zda ve vypisu prikazu dmesg je inicializace karty po startu systemu. Zda se madwifi automaticky zavedl zjistite prikazem lsmod. Pokud ne, zkuste rucne “modprobe ath_pci”, pote prohlednete vypis dmesg. Atheros karty je potreba pred tim nez jdou pouzivat “zapnout” prikazem “ifconfig ath0 up”.

Tak jsem postupoval dle navodu a nejsem z toho moc moudry. Ocekavam, ze instalace kmod-madwifi a madwifi pro dany kernel dostacuje a nic jine jsem neinstaloval. Omlouvam se za dlouhe vypisy, ale nerad bych aby neco uniklo. Tak pro poradek
[root@localhost ~]# lspci
00:00.0 RAM memory: nVidia Corporation MCP67 Memory Controller (rev a2)
00:01.0 ISA bridge: nVidia Corporation MCP67 ISA Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP67 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation Unknown device 0541 (rev a2)
00:01.3 Co-processor: nVidia Corporation Unknown device 0543 (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
00:04.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
00:04.1 USB Controller: nVidia Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP67 IDE Controller (rev a1)
00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)
00:08.0 PCI bridge: nVidia Corporation Unknown device 0561 (rev a2)
00:09.0 IDE interface: nVidia Corporation MCP67 AHCI Controller (rev a2)
00:0a.0 Ethernet controller: nVidia Corporation MCP67 Ethernet (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
00:0d.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:04.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
01:04.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
01:04.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
01:04.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
01:04.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
02:00.0 VGA compatible controller: nVidia Corporation GeForce 8400M G (rev a1)
05:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g Wireless PCI Express Adapter (rev 01)

Kartu tedy system zna.
vypis z dmesg
Bootmem setup node 0 0000000000000000-000000007ff50000
Zone PFN ranges:
DMA 0 -> 4096
DMA32 4096 -> 1048576
Normal 1048576 -> 1048576
Movable zone start PFN for each node
early_node_map[2] active PFN ranges
0: 0 -> 158
0: 256 -> 524112
On node 0 totalpages: 524014
DMA zone: 56 pages used for memmap
DMA zone: 1317 pages reserved
DMA zone: 2625 pages, LIFO batch:0
DMA32 zone: 7109 pages used for memmap
DMA32 zone: 512907 pages, LIFO batch:31
Normal zone: 0 pages used for memmap
Movable zone: 0 pages used for memmap
ACPI: PM-Timer IO Port: 0x1008
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 (Bootup-CPU)
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
Processor #1
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 2, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 low level)
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: IRQ0 used by override.
ACPI: IRQ2 used by override.
ACPI: IRQ9 used by override.
Setting APIC routing to flat
ACPI: HPET id: 0x10de8201 base: 0xfed00000
Using ACPI (MADT) for SMP configuration information
swsusp: Registered nosave memory region: 000000000009e000 - 00000000000a0000
swsusp: Registered nosave memory region: 00000000000a0000 - 00000000000d0000
swsusp: Registered nosave memory region: 00000000000d0000 - 0000000000100000
Allocating PCI resources starting at 88000000 (gap: 80000000:60000000)
SMP: Allowing 2 CPUs, 0 hotplug CPUs
PERCPU: Allocating 41688 bytes of per cpu data
Built 1 zonelists in Node order. Total pages: 515532
Policy zone: DMA32
Kernel command line: ro root=LABEL=/ rhgb quiet
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 32768 bytes)
Extended CMOS year: 2000
hpet clockevent registered
TSC calibrated against HPET
Marking TSC unstable due to TSCs unsynchronized
time.c: Detected 1800.237 MHz processor.
Console: colour VGA+ 80x25
console [tty0] enabled
Checking aperture…
CPU 0: aperture @ 3090000000 size 32 MB
Aperture too small (32 MB)
No AGP bridge found
Memory: 2058628k/2096448k available (2443k kernel code, 37428k reserved, 1380k data, 324k init)
SLUB: Genslabs=23, HWalign=64, Order=0-1, MinObjects=4, CPUs=2, Nodes=1
Calibrating delay using timer specific routine… 3603.27 BogoMIPS (lpj=1801637)
Security Framework v1.0.0 initialized
SELinux: Initializing.
SELinux: Starting in permissive mode
selinux_register_security: Registering secondary module capability
Capability LSM initialized as secondary
Dentry cache hash table entries: 262144 (order: 9, 2097152 bytes)
Inode-cache hash table entries: 131072 (order: 8, 1048576 bytes)
Mount-cache hash table entries: 256
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU 0/0 -> Node 0
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 0
SMP alternatives: switching to UP code
ACPI: Core revision 20070126
Using local APIC timer interrupts.
APIC timer calibration result 12501654
Detected 12.501 MHz APIC timer.
SMP alternatives: switching to SMP code
Booting processor 1/2 APIC 0x1
Initializing CPU#1
Calibrating delay using timer specific routine… 3600.35 BogoMIPS (lpj=1800179)
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU 1/1 -> Node 0
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 1
AMD Athlon™ 64 X2 Dual-Core Processor TK-55 stepping 01
AMD C1E detected late. Force timer broadcast.
Brought up 2 CPUs
sizeof(vma)=176 bytes
sizeof(page)=56 bytes
sizeof(inode)=560 bytes
sizeof(dentry)=208 bytes
sizeof(ext3inode)=760 bytes
sizeof(buffer_head)=104 bytes
sizeof(skbuff)=232 bytes
sizeof(task_struct)=2080 bytes
Time: 19:09:12 Date: 02/07/08
NET: Registered protocol family 16
No dock devices found.
ACPI: bus type pci registered
PCI: Using configuration type 1
ACPI: EC: Look up EC in DSDT
ACPI: Interpreter enabled
ACPI: (supports S0 S3 S4 S5)
ACPI: Using IOAPIC for interrupt routing
ACPI: EC: GPE = 0x10, I/O: command/status = 0x66, data = 0x62
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Transparent bridge - 0000:00:08.0
ACPI: PCI Interrupt Routing Table [_SB_.PCI0.PRT]
ACPI: PCI Interrupt Routing Table [_SB
.PCI0.P2P0.PRT]
ACPI: PCI Interrupt Routing Table [_SB
.PCI0.XVR0.PRT]
ACPI: PCI Interrupt Routing Table [_SB
.PCI0.XVR1.PRT]
ACPI: PCI Interrupt Routing Table [_SB
.PCI0.XVR2._PRT]
ACPI: PCI Interrupt Link [LNK1] (IRQs 5 7 11) *10
ACPI: PCI Interrupt Link [LNK2] (IRQs 5 7 *11)
ACPI: PCI Interrupt Link [LNK3] (IRQs 5 7 11) *0, disabled.
ACPI: PCI Interrupt Link [LNK4] (IRQs 5 7 11) *0, disabled.
ACPI: PCI Interrupt Link [LK1E] (IRQs 16) *0, disabled.
ACPI: PCI Interrupt Link [LK2E] (IRQs 17) *10
ACPI: PCI Interrupt Link [LK3E] (IRQs 18) *0, disabled.
ACPI: PCI Interrupt Link [LK4E] (IRQs 19) *10
ACPI: PCI Interrupt Link [LSMB] (IRQs 20 21 22 23) *10
ACPI: PCI Interrupt Link [LUS0] (IRQs 20 21 22 23) *11
ACPI: PCI Interrupt Link [LUS2] (IRQs 20 21 22 23) *7
ACPI: PCI Interrupt Link [LMAC] (IRQs 20 21 22 23) *11
ACPI: PCI Interrupt Link [LAZA] (IRQs 20 21 22 23) *10
ACPI: PCI Interrupt Link [LGPU] (IRQs 17) *0, disabled.
ACPI: PCI Interrupt Link [LPID] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [LSI0] (IRQs 20 21 22 23) *5
ACPI: PCI Interrupt Link [Z00N] (IRQs 20 21 22 23) *10
ACPI: PCI Interrupt Link [Z00O] (IRQs 20 21 22 23) *11
ACPI: PCI Interrupt Link [LPMU] (IRQs 18) *11
Linux Plug and Play Support v0.97 © Adam Belay
pnp: PnP ACPI init
ACPI: bus type pnp registered
pnp: PnP ACPI: found 13 devices
ACPI: ACPI bus type pnp unregistered
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
PCI: Using ACPI for IRQ routing
PCI: If a device doesn’t work, try “pci=routeirq”. If it helps, post a report
NetLabel: Initializing
NetLabel: domain hash size = 128
NetLabel: protocols = UNLABELED CIPSOv4
NetLabel: unlabeled traffic allowed by default
hpet0: at MMIO 0xfed00000, IRQs 2, 8, 31
hpet0: 3 32-bit timers, 25000000 Hz
Time: hpet clocksource has been installed.
Clockevents: could not switch to one-shot mode: lapic is not functional.
Could not switch to high resolution mode on CPU 0
Clockevents: could not switch to one-shot mode: lapic is not functional.
Could not switch to high resolution mode on CPU 1
pnp: 00:07: iomem range 0xe0000000-0xefffffff could not be reserved
pnp: 00:0a: ioport range 0x1000-0x107f has been reserved
pnp: 00:0a: ioport range 0x1080-0x10ff has been reserved
pnp: 00:0a: ioport range 0x1400-0x147f has been reserved
pnp: 00:0a: ioport range 0x1480-0x14ff has been reserved
pnp: 00:0a: ioport range 0x1800-0x187f has been reserved
pnp: 00:0a: ioport range 0x1880-0x18ff has been reserved
pnp: 00:0c: iomem range 0xffc00000-0xffffffff could not be reserved
pnp: 00:0c: iomem range 0xfec00000-0xfec00fff could not be reserved
pnp: 00:0c: iomem range 0xfee00000-0xfeefffff could not be reserved
pnp: 00:0c: iomem range 0xfed00000-0xfed00fff has been reserved
PCI: Bridge: 0000:00:08.0
IO window: disabled.
MEM window: f0500000-f05fffff
PREFETCH window: disabled.
PCI: Failed to allocate mem resource #6:20000@e0000000 for 0000:02:00.0
PCI: Bridge: 0000:00:0b.0
IO window: 4000-4fff
MEM window: cc000000-ceffffff
PREFETCH window: d0000000-dfffffff
PCI: Bridge: 0000:00:0c.0
IO window: 5000-5fff
MEM window: f0200000-f03fffff
PREFETCH window: f0000000-f01fffff
PCI: Bridge: 0000:00:0d.0
IO window: disabled.
MEM window: f0400000-f04fffff
PREFETCH window: disabled.
PCI: Setting latency timer of device 0000:00:08.0 to 64
PCI: Setting latency timer of device 0000:00:0b.0 to 64
PCI: Setting latency timer of device 0000:00:0c.0 to 64
PCI: Setting latency timer of device 0000:00:0d.0 to 64
NET: Registered protocol family 2
IP route cache hash table entries: 65536 (order: 7, 524288 bytes)
TCP established hash table entries: 262144 (order: 10, 6291456 bytes)
TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
TCP: Hash tables configured (established 262144 bind 65536)
TCP reno registered
checking if image is initramfs… it is
Clockevents: could not switch to one-shot mode: lapic is not functional.
Could not switch to high resolution mode on CPU 1
Clockevents: could not switch to one-shot mode: lapic is not functional.
Could not switch to high resolution mode on CPU 0
Freeing initrd memory: 3218k freed
Simple Boot Flag at 0x36 set to 0x1
audit: initializing netlink socket (disabled)
audit(1202411352.594:1): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
SELinux: Registering netfilter hooks
ksign: Installing public key data
Loading keyring

  • Added public key 9D330118D0496200
  • User ID: Red Hat, Inc. (Kernel Module GPG key)
    Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
    io scheduler noop registered
    io scheduler anticipatory registered
    io scheduler deadline registered
    io scheduler cfq registered (default)
    Boot video device is 0000:02:00.0
    PCI: Setting latency timer of device 0000:00:0b.0 to 64
    assign_interrupt_mode Found MSI capability
    Allocate Port Service[0000:00:0b.0:pcie00]
    PCI: Setting latency timer of device 0000:00:0c.0 to 64
    assign_interrupt_mode Found MSI capability
    Allocate Port Service[0000:00:0c.0:pcie00]
    PCI: Setting latency timer of device 0000:00:0d.0 to 64
    assign_interrupt_mode Found MSI capability
    Allocate Port Service[0000:00:0d.0:pcie00]
    pci_hotplug: PCI Hot Plug PCI Core version: 0.5
    ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
    ACPI: Processor [CPU0] (supports 8 throttling states)
    ACPI Exception (processor_core-0819): AE_NOT_FOUND, Processor Device is not present [20070126]
    ACPI Exception (processor_core-0819): AE_NOT_FOUND, Processor Device is not present [20070126]
    ACPI Exception (thermal-0470): AE_NOT_FOUND, Invalid active threshold [0] [20070126]
    ACPI: Thermal Zone [THRM] (37 C)
    Real Time Clock Driver v1.12ac
    hpet_resources: 0xfed00000 is busy
    Non-volatile memory driver v1.2
    Linux agpgart interface v0.102
    Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
    RAMDISK driver initialized: 16 RAM disks of 16384K size 4096 blocksize
    input: Macintosh mouse button emulation as /class/input/input0
    PNP: PS/2 Controller [PNP0303:KBC0,PNP0f13:MSE0] at 0x60,0x64 irq 1,12
    serio: i8042 KBD port at 0x60,0x64 irq 1
    serio: i8042 AUX port at 0x60,0x64 irq 12
    mice: PS/2 mouse device common for all mice
    input: AT Translated Set 2 keyboard as /class/input/input1
    cpuidle: using governor menu
    usbcore: registered new interface driver hiddev
    usbcore: registered new interface driver usbhid
    drivers/hid/usbhid/hid-core.c: v2.6:USB HID core driver
    TCP cubic registered
    Initializing XFRM netlink socket
    NET: Registered protocol family 1
    NET: Registered protocol family 17
    powernow-k8: Found 1 AMD Athlon™ 64 X2 Dual-Core Processor TK-55 processors (2 cpu cores) (version 2.00.00)
    powernow-k8: 0 : fid 0xa (1800 MHz), vid 0x12
    powernow-k8: 1 : fid 0x8 (1600 MHz), vid 0x13
    powernow-k8: 2 : fid 0x0 (800 MHz), vid 0x1a
    Magic number: 12:132:192
    hash matches device device:1e
    Freeing unused kernel memory: 324k freed
    Write protecting the kernel read-only data: 1020k
    ACPI: PCI Interrupt Link [LUS2] enabled at IRQ 23
    ACPI: PCI Interrupt 0000:00:02.1[B] -> Link [LUS2] -> GSI 23 (level, low) -> IRQ 23
    PCI: Setting latency timer of device 0000:00:02.1 to 64
    ehci_hcd 0000:00:02.1: EHCI Host Controller
    ehci_hcd 0000:00:02.1: new USB bus registered, assigned bus number 1
    ehci_hcd 0000:00:02.1: debug port 1
    PCI: cache line size of 64 is not supported by device 0000:00:02.1
    ehci_hcd 0000:00:02.1: irq 23, io mem 0xf0889000
    ehci_hcd 0000:00:02.1: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
    usb usb1: configuration #1 chosen from 1 choice
    hub 1-0:1.0: USB hub found
    hub 1-0:1.0: 5 ports detected
    ACPI: PCI Interrupt Link [Z00O] enabled at IRQ 22
    ACPI: PCI Interrupt 0000:00:04.1[B] -> Link [Z00O] -> GSI 22 (level, low) -> IRQ 22
    PCI: Setting latency timer of device 0000:00:04.1 to 64
    ehci_hcd 0000:00:04.1: EHCI Host Controller
    ehci_hcd 0000:00:04.1: new USB bus registered, assigned bus number 2
    ehci_hcd 0000:00:04.1: debug port 1
    PCI: cache line size of 64 is not supported by device 0000:00:04.1
    ehci_hcd 0000:00:04.1: irq 22, io mem 0xf0889400
    ehci_hcd 0000:00:04.1: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
    usb usb2: configuration #1 chosen from 1 choice
    hub 2-0:1.0: USB hub found
    hub 2-0:1.0: 5 ports detected
    ohci_hcd: 2006 August 04 USB 1.1 ‘Open’ Host Controller (OHCI) Driver
    ACPI: PCI Interrupt Link [LUS0] enabled at IRQ 21
    ACPI: PCI Interrupt 0000:00:02.0[A] -> Link [LUS0] -> GSI 21 (level, low) -> IRQ 21
    PCI: Setting latency timer of device 0000:00:02.0 to 64
    ohci_hcd 0000:00:02.0: OHCI Host Controller
    ohci_hcd 0000:00:02.0: new USB bus registered, assigned bus number 3
    ohci_hcd 0000:00:02.0: irq 21, io mem 0xf0886000
    usb usb3: configuration #1 chosen from 1 choice
    hub 3-0:1.0: USB hub found
    hub 3-0:1.0: 5 ports detected
    input: PS/2 Mouse as /class/input/input2
    usb 1-3: new high speed USB device using ehci_hcd and address 2
    input: AlpsPS/2 ALPS GlidePoint as /class/input/input3
    ACPI: PCI Interrupt Link [Z00N] enabled at IRQ 20
    ACPI: PCI Interrupt 0000:00:04.0[A] -> Link [Z00N] -> GSI 20 (level, low) -> IRQ 20
    PCI: Setting latency timer of device 0000:00:04.0 to 64
    ohci_hcd 0000:00:04.0: OHCI Host Controller
    ohci_hcd 0000:00:04.0: new USB bus registered, assigned bus number 4
    ohci_hcd 0000:00:04.0: irq 20, io mem 0xf0887000
    usb usb4: configuration #1 chosen from 1 choice
    hub 4-0:1.0: USB hub found
    hub 4-0:1.0: 5 ports detected
    usb 1-3: configuration #1 chosen from 1 choice
    USB Universal Host Controller Interface driver v3.0
    SCSI subsystem initialized
    libata version 2.21 loaded.
    ahci 0000:00:09.0: version 2.3
    ACPI: PCI Interrupt Link [LSI0] enabled at IRQ 23
    ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LSI0] -> GSI 23 (level, low) -> IRQ 23
    ahci 0000:00:09.0: AHCI 0001.0100 32 slots 4 ports 3 Gbps 0xf impl IDE mode
    ahci 0000:00:09.0: flags: 64bit sntf led clo pmp pio slum part
    PCI: Setting latency timer of device 0000:00:09.0 to 64
    scsi0 : ahci
    scsi1 : ahci
    scsi2 : ahci
    scsi3 : ahci
    ata1: SATA max UDMA/133 cmd 0xffffc20000abc100 ctl 0x0000000000000000 bmdma 0x0000000000000000 irq 2300
    ata2: SATA max UDMA/133 cmd 0xffffc20000abc180 ctl 0x0000000000000000 bmdma 0x0000000000000000 irq 2300
    ata3: SATA max UDMA/133 cmd 0xffffc20000abc200 ctl 0x0000000000000000 bmdma 0x0000000000000000 irq 2300
    ata4: SATA max UDMA/133 cmd 0xffffc20000abc280 ctl 0x0000000000000000 bmdma 0x0000000000000000 irq 2300
    ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
    ata1.00: ATA-8: WDC WD1200BEVS-22UST0, 01.01A01, max UDMA/133
    ata1.00: 234441648 sectors, multi 16: LBA48 NCQ (depth 0/32)
    ata1.00: configured for UDMA/133
    ata2: SATA link down (SStatus 0 SControl 300)
    ata3: SATA link down (SStatus 0 SControl 300)
    ata4: SATA link down (SStatus 0 SControl 300)
    scsi 0:0:0:0: Direct-Access ATA WDC WD1200BEVS-2 01.0 PQ: 0 ANSI: 5
    sd 0:0:0:0: [sda] 234441648 512-byte hardware sectors (120034 MB)
    sd 0:0:0:0: [sda] Write Protect is off
    sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
    sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn’t support DPO or FUA
    sd 0:0:0:0: [sda] 234441648 512-byte hardware sectors (120034 MB)
    sd 0:0:0:0: [sda] Write Protect is off
    sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
    sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn’t support DPO or FUA
    sda: sda1 sda2 sda3 sda4 < sda5 sda6 sda7 sda8 >
    sd 0:0:0:0: [sda] Attached SCSI disk
    pata_amd 0000:00:06.0: version 0.3.9
    PCI: Setting latency timer of device 0000:00:06.0 to 64
    scsi4 : pata_amd
    scsi5 : pata_amd
    ata5: PATA max UDMA/133 cmd 0x00000000000101f0 ctl 0x00000000000103f6 bmdma 0x00000000000130c0 irq 14
    ata6: PATA max UDMA/133 cmd 0x0000000000010170 ctl 0x0000000000010376 bmdma 0x00000000000130c8 irq 15
    ata5.00: ATAPI: Optiarc DVD RW AD-7560A, DX06, max UDMA/33
    ata5.00: configured for UDMA/33
    ata6: port disabled. ignoring.
    scsi 4:0:0:0: CD-ROM Optiarc DVD RW AD-7560A DX06 PQ: 0 ANSI: 5
    kjournald starting. Commit interval 5 seconds
    EXT3-fs: mounted filesystem with ordered data mode.
    audit(1202411362.386:2): enforcing=1 old_enforcing=0 auid=4294967295
    security: 8 users, 12 roles, 2346 types, 114 bools, 1 sens, 1024 cats
    security: 67 classes, 215034 rules
    SELinux: Completing initialization.
    SELinux: Setting up existing superblocks.
    SELinux: initialized (dev sda5, type ext3), uses xattr
    SELinux: initialized (dev usbfs, type usbfs), uses genfs_contexts
    SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs
    SELinux: initialized (dev debugfs, type debugfs), uses genfs_contexts
    SELinux: initialized (dev selinuxfs, type selinuxfs), uses genfs_contexts
    SELinux: initialized (dev mqueue, type mqueue), uses transition SIDs
    SELinux: initialized (dev hugetlbfs, type hugetlbfs), uses genfs_contexts
    SELinux: initialized (dev devpts, type devpts), uses transition SIDs
    SELinux: initialized (dev inotifyfs, type inotifyfs), uses genfs_contexts
    SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs
    SELinux: initialized (dev futexfs, type futexfs), uses genfs_contexts
    SELinux: initialized (dev anon_inodefs, type anon_inodefs), uses genfs_contexts
    SELinux: initialized (dev pipefs, type pipefs), uses task SIDs
    SELinux: initialized (dev sockfs, type sockfs), uses task SIDs
    SELinux: initialized (dev cpuset, type cpuset), uses genfs_contexts
    SELinux: initialized (dev proc, type proc), uses genfs_contexts
    SELinux: initialized (dev bdev, type bdev), uses genfs_contexts
    SELinux: initialized (dev rootfs, type rootfs), uses genfs_contexts
    SELinux: initialized (dev sysfs, type sysfs), uses genfs_contexts
    audit(1202411362.779:3): policy loaded auid=4294967295
    sd 0:0:0:0: Attached scsi generic sg0 type 0
    scsi 4:0:0:0: Attached scsi generic sg1 type 5
    sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
    Uniform CD-ROM driver Revision: 3.20
    sr 4:0:0:0: Attached scsi CD-ROM sr0
    input: Power Button (FF) as /class/input/input4
    ACPI: Power Button (FF) [PWRF]
    input: Lid Switch as /class/input/input5
    ACPI: Lid Switch [LID]
    input: Sleep Button (CM) as /class/input/input6
    ACPI: Sleep Button (CM) [SLPB]
    input: Power Button (CM) as /class/input/input7
    ACPI: Power Button (CM) [PWRB]
    ACPI: Battery Slot [BAT1] (battery present)
    ACPI: AC Adapter [ACAD] (off-line)
    input: PC Speaker as /class/input/input8
    sdhci: Secure Digital Host Controller Interface driver
    sdhci: Copyright© Pierre Ossman
    sdhci: SDHCI controller found at 0000:01:04.1 [1180:0822] (rev 22)
    ACPI: PCI Interrupt Link [LNK2] enabled at IRQ 11
    ACPI: PCI Interrupt 0000:01:04.1[B] -> Link [LNK2] -> GSI 11 (level, low) -> IRQ 11
    mmc0: SDHCI at 0xf0500800 irq 11 DMA
    ath_hal: module license ‘Proprietary’ taints kernel.
    ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    forcedeth.c: Reverse Engineered nForce ethernet driver. Version 0.60.
    ACPI: PCI Interrupt Link [LMAC] enabled at IRQ 22
    ACPI: PCI Interrupt 0000:00:0a.0[A] -> Link [LMAC] -> GSI 22 (level, low) -> IRQ 22
    PCI: Setting latency timer of device 0000:00:0a.0 to 64
    forcedeth: using HIGHDMA
    wlan: 0.8.4.2 (0.9.3.3)
    ath_pci: 0.9.4.5 (0.9.3.3)
    eth0: forcedeth.c: subsystem: 01025:0126 bound to 0000:00:0a.0
    ACPI: PCI Interrupt Link [LK4E] enabled at IRQ 19
    ACPI: PCI Interrupt 0000:05:00.0[A] -> Link [LK4E] -> GSI 19 (level, low) -> IRQ 19
    PCI: Setting latency timer of device 0000:05:00.0 to 64
    wifi%d: unable to attach hardware: ‘Hardware revision not supported’ (HAL status 13)
    ACPI: PCI interrupt for device 0000:05:00.0 disabled
    ACPI: PCI Interrupt Link [LNK1] enabled at IRQ 11
    ACPI: PCI Interrupt 0000:01:04.0[A] -> Link [LNK1] -> GSI 11 (level, low) -> IRQ 11
    firewire_ohci: Added fw-ohci device 0000:01:04.0, OHCI version 1.0
    ACPI: PCI Interrupt Link [LK2E] enabled at IRQ 17
    ACPI: PCI Interrupt 0000:02:00.0[A] -> Link [LK2E] -> GSI 17 (level, low) -> IRQ 17
    PCI: Setting latency timer of device 0000:02:00.0 to 64
    NVRM: loading NVIDIA UNIX x86_64 Kernel Module 169.07 Thu Dec 13 18:34:01 PST 2007
    ACPI: PCI Interrupt Link [LAZA] enabled at IRQ 21
    ACPI: PCI Interrupt 0000:00:07.0[A] -> Link [LAZA] -> GSI 21 (level, low) -> IRQ 21
    PCI: Setting latency timer of device 0000:00:07.0 to 64
    firewire_core: created new fw device fw0 (0 config rom retries, S400)
    device-mapper: ioctl: 4.11.0-ioctl (2006-10-12) initialised: dm-devel@redhat.com
    device-mapper: multipath: version 1.0.5 loaded
    EXT3 FS on sda5, internal journal
    SELinux: initialized (dev sda8, type ext2), uses xattr
    SELinux: initialized (dev sda6, type ext2), uses xattr
    kjournald starting. Commit interval 5 seconds
    EXT3 FS on sda3, internal journal
    EXT3-fs: mounted filesystem with ordered data mode.
    SELinux: initialized (dev sda3, type ext3), uses xattr
    SELinux: initialized (dev sda2, type ext2), uses xattr
    SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs
    fuse init (API version 7.8)
    SELinux: initialized (dev sda1, type fuseblk), uses genfs_contexts
    SELinux: initialized (dev ramfs, type ramfs), uses genfs_contexts
    NET: Registered protocol family 10
    lo: Disabled Privacy Extensions
    Adding 1020088k swap on /dev/sda7. Priority:-1 extents:1 across:1020088k
    SELinux: initialized (dev binfmt_misc, type binfmt_misc), uses genfs_contexts
    Clocksource tsc unstable (delta = -186570790 ns)
    eth0: no link during initialization.
    ADDRCONF(NETDEV_UP): eth0: link is not ready
    SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts
    audit(1202407795.198:4): audit_pid=2037 old=0 by auid=4294967295 subj=system_u:system_r:auditd_t:s0
    SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
    SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
    SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
    Bluetooth: Core ver 2.11
    NET: Registered protocol family 31
    Bluetooth: HCI device and connection manager initialized
    Bluetooth: HCI socket layer initialized
    Bluetooth: L2CAP ver 2.8
    Bluetooth: L2CAP socket layer initialized
    Bluetooth: RFCOMM socket layer initialized
    Bluetooth: RFCOMM TTY layer initialized
    Bluetooth: RFCOMM ver 1.8
    usb 4-2: new low speed USB device using ohci_hcd and address 2
    usb 4-2: configuration #1 chosen from 1 choice
    input: KEYBOARD as /class/input/input9
    input: USB HID v1.10 Keyboard [KEYBOARD] on usb-0000:00:04.0-2
    input: KEYBOARD as /class/input/input10
    input: USB HID v1.10 Device [KEYBOARD] on usb-0000:00:04.0-2
    usb 3-2: new low speed USB device using ohci_hcd and address 2
    usb 3-2: configuration #1 chosen from 1 choice
    input: Logitech USB Mouse as /class/input/input11
    input: USB HID v1.10 Mouse [Logitech USB Mouse] on usb-0000:00:02.0-2
    usb 4-1: new full speed USB device using ohci_hcd and address 3
    usb 4-1: configuration #1 chosen from 1 choice
    usb 4-1: reset full speed USB device using ohci_hcd and address 3
    usb 4-1: reset full speed USB device using ohci_hcd and address 3
    usb 4-1: USB disconnect, address 3
    usb 2-1: new high speed USB device using ehci_hcd and address 4
    usb 2-1: configuration #1 chosen from 1 choice
    Initializing USB Mass Storage driver…
    scsi6 : SCSI emulation for USB Mass Storage devices
    usb-storage: device found at 4
    usb-storage: waiting for device to settle before scanning
    usbcore: registered new interface driver usb-storage
    USB Mass Storage support registered.
    usb-storage: device scan complete
    scsi 6:0:0:0: Direct-Access USB FLASH DRIVE 34CD PQ: 0 ANSI: 0 CCS
    sd 6:0:0:0: [sdb] 4014080 512-byte hardware sectors (2055 MB)
    sd 6:0:0:0: [sdb] Write Protect is off
    sd 6:0:0:0: [sdb] Mode Sense: 23 00 00 00
    sd 6:0:0:0: [sdb] Assuming drive cache: write through
    sd 6:0:0:0: [sdb] 4014080 512-byte hardware sectors (2055 MB)
    sd 6:0:0:0: [sdb] Write Protect is off
    sd 6:0:0:0: [sdb] Mode Sense: 23 00 00 00
    sd 6:0:0:0: [sdb] Assuming drive cache: write through
    sdb: sdb1
    sd 6:0:0:0: [sdb] Attached SCSI removable disk
    sd 6:0:0:0: Attached scsi generic sg2 type 0
    SELinux: initialized (dev sdb1, type vfat), uses genfs_contexts

To je divne, proc ctu :wifi%d: unable to attach hardware: ‘Hardware revision not supported’ (HAL status 13)
A z vypisu lspci jsem si myslel, ze je to ar50006eg a tady se pise toto :ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)

lsmod pise : wlan 193352 1 ath_pci
Tak snad slava, modul je v jadre - nepouzil jsem tedy modprobe.

Tak co je sakra spatne ?? A aby toho nebylo malo tak :
vystup prikazu
[root@localhost ~]# ifconfig ath0 up
ath0: rozhraní Takové zařízení neexistuje není známo. Zkusil jsem i wlan0 a podobne a nic.

Jedine co me napada, tak ze mam spatnou verzi madwifi a to si neumim predstavit proc - cislo kernelu sedi

Neni mozne ze v tom ma prsty 64bit ? Klidne to preinstaluju na 32bit, tech problemu mam oproti starsim instalacim vicero.

To bohuzel ctete spravne, predim jsem si nevsiml ze to je 5006, ta zrejme neni v madwifi jeste podporovana. Juknete sem: http://home.nyc.rr.com/computertaijutsu/rhwireless.html - dole je sekce o tom jak pouzit vyvojovou/opravenou verzi madwifi.

Tak kdyby snad nekdo utrpel stejnou wifi kartu a potreboval ji rozejit pod Fedorou 8, mam pro neho cerstve zkusenosti : Atheros ar5006eg, wokna ji hlasi jako 5007 a je v notebooku ACER ASPIRE 5520 a mozna jeste v dalsich.

  1. Nutno rici, ze se mi nepodarilo rozejit kartu v Fc8/64bit !!! Nevim proc, ale proste to neslo - na nize uvedene strance je navic napsano, ze dany patch funguje jen na 32bitovych systemech.
  2. Takze jsem preinstaloval Fedoru na 32bit, provedl vsechny aktualizace, ktere byli k dispozici a pak pokracoval dle navodu : http://home.nyc.rr.com/computertaijutsu/rhwireless.html

Je tam i pro laika celkem slusne popsano jak postupovat od pridani puvodniho ovladace ath5k do black listu az po kompilaci a zavedeni patchovanych ovladacu madwifi. Pak jsou popsane dalsi mozne problemy po instalaci - ja musel provest avizovany restart a pak uz to jelo jak ma.
Hodne stesti vsem.

A dekuji covexovi za dalsi a opet spravny tip.

Mam podobny byt trochu jiny problem. Mam fedoru 8. Byl jsem schopen si nastavit i wifi pripojeni ovladac/atd nicmene toto pripojeni mi funguje jen pokud mam z routeru nezakodovany signal. Jelikoz mam standarne signal pod WEP encrypci musim neco podobneho nastavit i zde. Pouzivam 64bit kodovani ASCII znaky (napr. slovo kamil). Ikdyz to takto nastavim pro wifi v linuxu, tak se zkratka nepripojim. V cem by mohl byt problem ? Existuje nekde “nejaka” utilitka, kde se daji podrobneji nastavovat WEP,WPA,WPA-PSK atd.?

jinak vypis z iwconfigu mi rika

wlan0 IEEE 802.11g ESSID:"-jmeno site-" Nickname:"-jmeno pc-"
Mode:Managed Frequency:2.427 GHz Access Point: 00:19:5B:2B:F4:24
Bit Rate=5 Mb/s Tx-Power:17 dBm Sensitivity=1/1
Retry:off RTS thr:off Fragment thr:off
Encryption key:6B61-6D69-6C Security mode:restricted
Power Management:off
Link Quality=48/70 Signal level=-50 dBm Noise level=-98 dBm
Rx invalid nwid:194 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pri zadani klice “kamil”
sit je nastavena jinak na managed/kanal 4/rychlost manualne snizena na 5/klic kamil

problem je urcite v klici ale jak z toho ven ?

Diky
Tom

je potreba zadat “s” takze:
iwconfig wlan0 key s:kamil