Dnešní upgrade [vyřešeno]


#1

Dobrý den,
dnes jsem zkusil aktualizovat (dnf -y upgrade)
A toto se pak na ně vyvalilo:

Chyba: Kontrola transakce selhala:
soubor /usr/bin/debuginfo-install z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/find-repos-of-install z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/needs-restarting z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/package-cleanup z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/repo-graph z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/repoclosure z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/repodiff z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/repomanage z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/repoquery z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/reposync z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/repotrack z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/yum-builddep z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/yum-config-manager z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/yum-debug-dump z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/yum-debug-restore z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/bin/yumdownloader z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/debuginfo-install.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/find-repos-of-install.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/needs-restarting.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/package-cleanup.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/repo-graph.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/repoclosure.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/repodiff.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/repomanage.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/repoquery.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/reposync.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/repotrack.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/yum-builddep.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/yum-config-manager.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/yum-debug-dump.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/yum-debug-restore.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/yum-utils.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch
soubor /usr/share/man/man1/yumdownloader.1.gz z instalace dnf-utils-4.0.4-1.fc29.noarch koliduje se souborem z balíčku yum-utils-1.1.31-518.fc29.noarch

Co s tím?


#2

Je to už nahlášené – https://bugzilla.redhat.com/show_bug.cgi?id=1680221

Před upgradem ručně odinstalujte balíček yum-utils (‘sudo dnf remove yum-utils’).

Zjednodušené vysvětlení: dnf-utils nahrazuje yum-utils, akorát někdo špatně vytvořil balíček, takže se yum-utils neodinstaluje automaticky, když se instaluje dnf-utils (který dotáhl nějaký jiný balíček jako závislost).


#3

Ó děkuji. Už to chodí.