3D akcelerace GeForce6600

Dobry den, prochazim tu forum, ale nemohu nalest odpoved jak rozchodit 3D akceleraci u me gr. karty (01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600/GeForce 6600 GT] (rev a2) ). Podle navodu jsem naistaloval ovladace :
yum -y install kmod-nvidia xorg-x11-drv-nvidia , instalace probehla v poradku. glxinfo mi vsak stale hlasi “direct rendering: No”. Co mam udelat?. Predem dekuji za odpovedi.

Pri procitani fora jste doufam narazil i na zpusob jak zjistit ze dany ovladac se pouziva/nepouziva.

Prikaz “lsmod” musi vypsat po startu systemu ze je zaveden modul “nvidia”. Pokud tomu tak je prvni balik se nainstaloval a zda se funguje.

Pohledem do /etc/X11/xorg.conf na radek “Driver “nvidia”” se ujistim, ze se skutecne ma pouzivat jako ovladac nvidia a X by ho tedy mel pri startu spustit (melo by se vam pri startu Xek zobrazit logo Nvidia pres celou obrazovku). Pokud i xorg.conf je spravne, pak zrejme dojde k nejake chybe pri startu X serveru. A to se zase podivam do /var/log/Xorg.0.log a hledam EE a WW.

Ano, lsmod mi ukazuje toto:
[root@fedora ~]# lsmod |grep nvidia
nvidia 6842164 0
i2c_core 24897 3 i2c_ec,nvidia,i2c_i801

Pokud, ale pomoci nvidia-xconf prepisu xorg.conf, tak potom po restartu, kdyz chci spustit startx , tak zustane cerna obrazuvka, nikam nejde prepnout a ani to killnout.
Zde chybove hlasky z Xorg.0.log:
(EE) AIGLX: Screen 0 is not DRI capable
Jenze tohle je ted kdyz jedu na nv driver, nevim jestli jsem nemel vypsat spis chyby z Xorg.1.log. Pri tom zamrznuti jsem presmeroval err vysrup, psalo to toto.:
xauth: creating new authority file /home/roman/.serverauth.2973

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.9-34.ELsmp i686 Red Hat, Inc.
Current Operating System: Linux fedora 2.6.20-1.2933.fc6 #1 SMP Mon Mar 19 11:38:26 EDT 2007 i686
Build Date: 04 October 2006
Build ID: xorg-x11-server 1.1.1-47.fc6
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Tue Apr 3 14:40:07 2007
(==) Using config file: “/etc/X11/xorg.conf”
dlopen: libGLcore.so.1: cannot open shared object file: No such file or directory
(EE) Failed to load /usr/lib/xorg/modules/extensions/nvidia/libglx.so
(EE) Failed to load module “glx” (loader failed, 7)
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) NVIDIA(0): you continue to encounter problems, Please try
(EE) NVIDIA(0): reinstalling the NVIDIA driver.

zdravim, dej sem k dispozici celej xorg.conf…

Myslim ze problem je v logu dobre popsany. Nemuze najit libGLcore.so.1. Jesli me pamet neklame tento by se mel nainstalovat s xorg-x11-drv-nvidia (rpm -ql xorg-x11-drv-nvidia). Pote z duvodu chybejiciho libGLcore nemuze nahrat libglx a nakonec radi zkusit preinstalovat nvidia driver - tedy xorg-x11-drv-nvidia.

Takze bych zkusil :

  • podivat se do /usr/lib/nvidia mel by tam byl
    libGLcore.so.1 -> libGLcore.so.1.0.9755
    atd. pokud neni, muzu zkusit vytvorit rucne
    nebo:
  • preinstalovat xorg-x11-drv-nvidia jak radi.

tady je ten Xorg.conf

Section “ServerLayout”
Identifier “X.org Configured”
Screen 0 “Screen0” 0 0
InputDevice “Mouse0” “CorePointer”
InputDevice “Keyboard0” “CoreKeyboard”
EndSection

Section “Files”
RgbPath “/usr/share/X11/rgb”
ModulePath “/usr/lib/xorg/modules/extensions/nvidia”
ModulePath “/usr/lib/xorg/modules”
FontPath “unix/:7100”
FontPath “built-ins”
EndSection

Section “Module”
Load “record”
Load “vnc”
Load “xtrap”
Load “glx”
Load “dbe”
Load “extmod”
EndSection

Section “InputDevice”
Identifier “Keyboard0”
Driver “kbd”
EndSection

Section “InputDevice”
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/input/mice”
Option “ZAxisMapping” “4 5 6 7”
EndSection

Section “Monitor”

    #DisplaySize      340   270     # mm

Comment all HorizSync and VertSync values to use DDC:

Comment all HorizSync and VertSync values to use DDC:

    Identifier   "Monitor0"
    VendorName   "PHL"
    ModelName    "Philips 170S"

Comment all HorizSync and VertSync values to use DDC:

    HorizSync    30.0 - 82.0
    VertRefresh  56.0 - 76.0
    Option      "DPMS"

EndSection

Section “Device”

    ### Available Driver options are:-
    ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
    ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
    ### [arg]: arg optional
    #Option     "SWcursor"                  # [<bool>]
    #Option     "HWcursor"                  # [<bool>]
    #Option     "NoAccel"                   # [<bool>]
    #Option     "ShadowFB"                  # [<bool>]
    #Option     "UseFBDev"                  # [<bool>]
    #Option     "Rotate"                    # [<str>]
    #Option     "VideoKey"                  # <i>
    #Option     "FlatPanel"                 # [<bool>]
    #Option     "FPDither"                  # [<bool>]
    #Option     "CrtcNumber"                # <i>
    #Option     "FPScale"                   # [<bool>]
    #Option     "FPTweak"                   # <i>
    Identifier  "Card0"
    Driver      "nvidia"
    VendorName  "nVidia Corporation"
    BoardName   "NV43 [GeForce 6600/GeForce 6600 GT]"
    Option      "AddARGBGLXVisuals" "True"
    BusID       "PCI:1:0:0"

EndSection

Section “Screen”
Identifier “Screen0”
Device “Card0”
Monitor “Monitor0”
SubSection “Display”
Viewport 0 0
Depth 1
EndSubSection
SubSection “Display”
Viewport 0 0
Depth 4
EndSubSection
SubSection “Display”
Viewport 0 0
Depth 8
EndSubSection
SubSection “Display”
Viewport 0 0
Depth 15
EndSubSection
SubSection “Display”
Viewport 0 0
Depth 16
EndSubSection
SubSection “Display”
Viewport 0 0
Depth 24
EndSubSection
EndSection

ty knihovny uz tam jsou:

lrwxrwxrwx 1 root root 21 dub 4 08:35 libGLcore.so.1 -> libGLcore.so.1.0.9755
-rwxr-xr-x 1 root root 9878480 bře 8 13:19 libGLcore.so.1.0.9755
lrwxrwxrwx 1 root root 17 dub 4 08:35 libGL.so.1 -> libGL.so.1.0.9755

V tom pripade zrejme nemuze najit nejakou komponentu sama knihovna libGLcore (z chyby to neni zrejme). Zkusil jste tu reinstalaci tech balicku? (Pokud mozno v textovem rezimu.)

Nevim co myslite tim (Pokud mozno v textovem rezimu.), vzdy instaluji z konzole pomoci yum, zadne chyby to nehlasi.Cele jsem to preinstaloval, ale po nahrani modulu nvidia a spusteni Xsek, zustyane obrazovka cerna a nejde nic delat. Dokonce nejdou ty Xsa schodit ani z jineho pc prez ssh. Nevite co zkusit dal?

Pokud to delas z konzole pres yum je to to co jsem myslel (nemel by bezet Xserver).
Puvodne jste psal ze se vam “akorat” glxinfo pise ze direct rendering No, ted ze se seka Xserver… takze co se vlastne a kdy deje a co je u prislusneho deje zapsano v log?