zpetna kompatibilita s MATLAB ve fedora 14 a 15

Vypocetni system MATLAB vyzaduje pro urcite ucely pritomnost nasledujicich knihoven:
gcc-4.3-multilib, libstdc++6-4.3-dev (nazev podle debian konvence).

Existuje nejaky user-friendly postup, jak tyto dve knihovny nainstalovat ve Fedora 14 resp. 15 bez nutnosti kompilace a reseni toho, cemu se tak pekne rika “dependency hell”?

Idealni by byl repozitar, ale ten se mi nedari najit …:frowning:

Edit: pro info
System Requirements - Release 2011a
Supported and Compatible Compilers – Release

Tak ja se zeptam jeste jednou a trochu jinak:

Existuje repozitar pro Fedora 14 resp. 15, ktery by obsahoval gcc-4.3 a libstdc++ 4.3 devel???

Budu vdecen za kladnou ale i zapornou odpoved (abych po tom nepatral dal).

Edit: nebo nizsi verze 4.x

Nedám odpověď, kde hledat nebo jestli existuje, ale … Zkoušel jsi to i s jinou verzí? Proč to musí být přesně 4.3.x? Mezi podporovanými systémy MATLABU je i RHEL 5, který aktuálně má 4.1…

MATLAB oficialne podporuje RHEL 5.x a 6.x, SLES resp SLED 11, Ubuntu 10.x a Debian 5.x.

Prvni dve varianty RHEL a SLES (SLED) jsou komercni … navic se SLED 11 mam zcela tragicke zkusenosti. RHEL vubec neznam, ale asi to bude dost podobne jako Fedora, ne?

Ubuntu prave opoustim, protoze jeho dalsi smerovani mi nevyhovuje (Unity?! a rada dalsich veci) a Debian 5.x v podstate nelze pouzivat jako plnohodnotny desktop a uz vubec ne na notebooku (problematicka podpora HW).

Takze mi z toho plyne, ze asi budu muset prejit na RHEL 6.x Desktop workstation (coz se mi moc nechce nejen kvuli penezum, ale i diky minimalni zkusenosti s touhle distribuci), nebo prejit na openSUSE 11.4, ktera ma verzi 4.3 v repozitarich dostupnou (coz prave testuji, ale jak GNOME tak KDE verze ma bohuzel jine neduhy, ktere mi dost vadi).

BTW: Je podle vas RHEL 6.x Desktop workstation opravdu vhodne reseni pro desktop? Daji se pouzivat repozitare pro Fedora? Jaka je podpora HW (specialne u notebooku)?

Nemyslel jsem jinou distribuci, ale verzi gcc. Je v gcc verze 4.3.x něco tak speciálního, že nejde použít jiná verze? Jak jsem psal, RHEL 5 je podporovaný systém a gcc je tam ve verzi 4.1.

Fedora je taková beta verze RHEL :slight_smile: Jinak můžeš zkusit i Centos 5 (6 ještě není a kdo ví kdy bude), jde o RHEL bez ochranných znaků… Jinak o podporu HW v redhadovských kernelech (RHEL, CentOS, Fedora) bych se nebál.

CentOS 6.0 pravděpodobně začátkem června http://qaweb.dev.centos.org/qa/calendar/view/2011-6

vain napsal(a):

CentOS 6.0 pravděpodobně začátkem června
http://qaweb.dev.centos.org/qa/calendar/view/2011-
6

Na to bych se nespoléhal. Ještě před týdnem bylo datum synchronizace s externími mirrory 1.6. Ale rád se nechám překvapit, že tato data už platí :slight_smile:

stderr:

Nemyslel jsem jinou distribuci, ale verzi gcc. Je v gcc verze 4.3.x něco tak speciálního, že nejde použít jiná verze? Jak jsem psal, RHEL 5 je podporovaný systém a gcc je tam ve verzi 4.1.

Na tohle se presne ptam: jak do fedora 14 nebo radeji uz 15 (!), pokud mozno jednoduse, doinstalovat gcc a libstdc++6-devel 4.x. Klidne i tu 4.1 ktera je v RedHat-u??? Resp., kde sehnat potrebne rpm balicky???

Pokud to chápu dobře, tak stderr myslí vyzkoušet matlab s knihovnami, které jsou ve Fedoře aktuálně - pokud jsi tedy ještě nezkoušel a nefungovalo to.

Aha … no to jsem samozrejmne otestoval jako prvni, jinak bych tady neotravoval. Nechodi to …

Pro aplikace vyzadujici starsi verze knihovem nez je aktualni verze v systemu ma fedora tzv. compat knihovny
yum search compat | grep ^compat

Bohuzel tam jsou ale pouze knihovny o radu nizsi. Nevidim duvod proc by aktualni verze libstdc++ 4.5 nemela fungovat s aplikaci ktera vyzaduje verzi 4.3. Pokud ma matlab napevno pozadavek primo na 4.3 pak bych zkusil bych pomoci ldd zjistit pozdavky binarky na verzi knihoven a pak pripadne dodelal symbolicke odkazy. (Nepises bohuzel co presne matlab dela kdyz nema knihovny potrebnych verzi.)