Zen-Install

Ahoj,

trošku jsem se nudil a tak jsem vytvořil script pro nováčky ve fedoře. Pomocí scriptu snadno nainstalujete: Adobe flash, Adobe AIR, Adobe acrobat reader, multimedia, libreoffice, skype, javu(jdk,jre), virtualbox, operu, google-chrome, chromium a aktualizace… Script sám pozná verzi systému(32/64bit) a zda se jedná o rawhide nebo stable verzi.

Stahovat můžete zde: http://josef-nemec.bluefile.cz <---- Aktualizován odkaz

----- Po otestování scriptu uživatelem a jeho konstruktivními komentáři, jsem se rozhodl, že ze scriptu odeberu instalaci pro 64bit architekturu, protože nemám jak 64bit verzi otestovat. -----

J.Němec

Zajimave, neco takoveho tusim delala easyfedora, jen to asi nikdo neudrzuje. Mozna existuji i jine. Chapu to dobre, ze to je pro F16 verne?

O easyfedoře jsem neslyšel :slight_smile: Jinak, je to pro fedoru 15 i pro fedoru 16 :slight_smile: - script podle jména rawhide pozná, jaké repo z fusion stáhnout.

Jak to prosím nainstaluji? V tom to jsem nezkušený

už jsem na to jak balíček nainstalovat přišel.
Do terminálu se přihlásím jako root následně zadám sh a cestu kde je mabíček stáhlej a pak se jen instaluje

Spustit jej můžete buď takto:

  1. script stáhnete (většinou se potom nachází v ~/Stažené)
  2. spustíte terminál a přihlásíte se jako root (su -)
  3. spustíte script zadáním (sh /home/uživatel/Stažené/zen-install.sh)

nebo:
2. spustíte terminál a přesunete se ke scriptu (cd ~/Stažené)
3. přidáte scriptu práva spouštění (chmod +x zen-install.sh)
4. přihlásíte se jako root (su) a script spustíte (./zen-install.sh)

Snažím se jej pravidelně aktualizovat od doby, kdy jsem to tu postnul už jsem přidal pár věcí navíc, jen jsem neaktualizoval odkaz zde :slight_smile:
Takže ještě jednou - http://josef-nemec.bluefile.cz/files/zen-install.sh

Tak jsem si s tim trochu pohraval a nejak slavne to teda nefunguje … spis bych rekl, ze to nefunguje skoro vubec.

Pro ty kteri hledaji neco co funguje, doporucuji toto: http://fedorautils.sourceforge.net/

EDIT: tak se omlouvam, po prvotnim nadseni prislo zklamani. Rada veci nefunguje ani ve “fedorautils” … NEDOPORUCUJI!!!

Mohu vědět, co konkrétně vám nefunguje?
Je to otestováno u několika uživatelů a zatím nebyl zaznamenán problém…

Poslal jsem vam strucne reporty na vase stranky: http://www.josef-nemec.bluefile.cz/2012/02/23/aktualizace-a-oprava-zen-install-sh/

Edit: Testovano na ciste instalaci Fedora 16 gnome 64bit.

Ou… to je samozřejmě moje chyba, kdy jsem předpokládal, že uživatel ví, co dělá :wink: takže - pokud instalujete vidalia, potom je instalace prováděna buildem ze zdrojových kódů… čili jak vám to píše v chybách - je třeba doinstalovat Balíčky pro vývoj systému (stačí zatrhnout)…
Na další chyby se podívám, problém je v 64bit… tam jsem to dostatečně neotestoval… :confused:
Script samozřejmě funguje ovšem 100% zatím pouze pro architekturu 32bitů… tedy i686…

Jinak děkuji za odezvu :wink:

Jaky je vas nazor na fedorautils (http://fedorautils.sourceforge.net/)? Je to podobne tomu co jste vytvoril vy? Ja bych podobne nastroje velice uvital, ale jejich spolehlivost musi byt mnohem vyssi nez dosud. Pokud instalace jednoho balicku ma zavislosti na jine balicky je nutno je automaticky instalovat take. Jinak to cele nema vyznam, protoze tyhle utilitky jsou urceny uzivatelum, kteri se v linuxu nevyznaji!!!

Pokud by to fungovalo, byla by to moc pekna vec… popracujte na tom jeste.

Tak jsem se pokusil něco opravit, máte-li možnost, vyzkoušejte a dejte mi echo - josef.nemec(zavináč)gmx.com

K fedora-utils kdysi jsem to zkoušel používat, není to špatné a na i686 to fungovalo také bez problémů, jen mi tam chybělo pár věcí - script zen-install se snaží pouze věci doinstalovat a něják systém nenastavuje - sudo, selinux, colors to terminal, autologin atd.

Tak jsem se pokusil nainstalovat skype… pridalo to repozitar se skype a skype to nainstalovalo, ale nenaistalovalo to potrebne zavislosti!!! :frowning:

Po te co jsem si je doinstaloval:
sudo yum -y install libXv.i686 libXScrnSaver.i686 qt.i686 qt-x11.i686 pulseaudio-libs.i686 pulseaudio-libs-glib2.i686 alsa-plugins-pulseaudio.i686

vse chodi.

Jen je mi zahadou pro to instaluje skype 2.1 beta misto aktualniho 2.2 beta???

Neco tam stale hapruje … uz to nehodlam dale zkouset, protoze mi to zasekalo instalaci OS radou balicku, ktere ani nechci pouzivat. Proste je to jeste dosti nezrale.

No je to smutné, nemám přístup k 64bit architektuře, takže není jak to otestovat… jsem odkázán v tomto případě na echo ostatních… čili odeberu ze scriptu 64bit podporu do doby než budu moci sám toto vyzkoušet. Jak je vidět - máte 64bit systém, ale pro vyřešení problémů s instalací do 64bitů je potřeba instalovat 32bitové aplikace - což také považuji za docela zvláštní věc. Každopádně děkuji za váš čas :wink:

No, ono neni divu, ze musim doinstalovat 32bit balicky ke skype, protoze i samotny skype je pouze 32bit (coz poznate uz z jeho nazvu: skype-2.2.0.35-fedora.i586.rpm, kdyby byl 64bit, bylo by tam amd64 misto i586). Na tohle vsechno ale musite myslet vy jako vyvojar a nenechavat to na uzivatelich!

nebo x86_64 :wink:
Chápu a proto jsem podporu 64bitů odebral, do doby než budu mít na čem instalaci pro tuto architekturu otestovat. Čili nyní script pro 64bit architekturu nefunguje…
BTW - ten komenář o tom, že instalujete balíčky i686 jsem nepsal proto, že bych nevěděl, jaký je mezi nimi rozdíl, ale proto, že právě nutnost instalace i686 balíčků, kvůli vyřešení problémů s 64bit a následná nestabilita… byly u drtivé většiny mojich kamarádů důvodem k přesunu zpět na 32bitů :slight_smile:

Jinak očividně víte, co je třeba nainstalovat k správné podpoře, máte volnou ruku a můžete pro uživatele něco udělat a script upravit je pod GPL :wink:

K tomu zanesení systému nepotřebnými balíčky, doporučuji využít možnosti yumu příkazu history. Potom si můžeš v systému zkoušet instalovat jak chceš a vrátit se historií zpět.

Skype je neštěstí samo o sobě. Ty závislosti by si měl taky dotáhnout balíček, respektive uvědomit, co vše potřebuje. To nevidím jako chybu nějakého skriptu. Navíc nechápu, proč pro Fedoru není 64bit verze, když, pokud se nepletu, pro Ubuntu 64bit verze je.