Žádný zvuk (Vaio VPCEA1S1E na Fed13)

Ahoj…
mám nový notebook Sony Vaio VPCEA1S1E s natočenou Fedorou 13. Pokouším se ji odladit tak, abych ji mohl používat, ale jsem laik a narážím na problémy, které se mi daří jen obtížně odstraňovat. Nejnověji jsem zjistil, že mi vůbec nefunguje zvuk. Nejde dokonce ani při při flash videii na webu (YouTube etc) natož při přehrávání videa či muziky. Problém se týká jak vestavěných repro tak sluchátek. Omlouvám se, ale nevím jak postupovat. Našel jsem nejaký script (ALSA information), který poskytuje podrobnější informace o mém compu, třeba to pomůže k nalezení problému: http://www.alsa-project.org/db/?f=1b94cedb23d8117be82f27b557f9db13afdde417

Za případnou pomoc samozřejmě moc děkuji!

Dobre popsano!

Jedna se nejspis o problem se zvukovymi kartami zalozenymi na ALC269 (viz. http://www.kerneltrap.com/mailarchive/git-commits-head/2010/4/17/31956)

Resenim by melo byt nastaveni jednoho portu karty do stavu vysoke impedance. Coz zni dost hrozne, ale neni to nemozne.


wget 'ftp://ftp.kernel.org/pub/linux/kernel/people/tiwai/misc/hda-verb/hda-verb-0.3.tar.gz'
tar xf hda-verb-0.3.tar.gz
cd hda-verb-0.3
make
cp hda-verb /usr/bin

gedit /etc/rc.local
a pridej radek exit 0 :
/usr/bin/hda-verb /dev/snd/hwC0D0 0x19 SET_PIN_WIDGET_CONTROL 0x22

Pro provedeni prikazu make (tedy kompilaci) budes muset nainstalovat skupiny “Vyvojove nastroje”.
Proji at se podari.

Hmm… tak bohužel nic, přesto děkuji za radu. Postup se zřejme zadařil, tím myslím, že každý krok měl nějakou odezvu, nakonec jsem přidal řadek “exit 0 :” do rc.local a spustil ten posledni přikaz. Přesto zvuk stále nikde (restart included). Škoda. Pokud by byl nějaký jiný tip, co bych mohl ještě zkusit, tak jsem jedno velké ucho :slight_smile: Díky všem.

Tak jsem věnoval celý den hledání problému a jediné co jsem našel bylo, že podobnou záhadou trpí mnoho uživatelů stejných notebooků, respektive stejné zvukové karty. Deprimující je, že většina vláken končí větou “I am going back to Windows…” :frowning: Upřímně řečeno - toto jsem nečekal. Mám na Linuxu pár sekundárních problémů s nemožností copy&paste, chaotického chování Compiz či samovolného přidávání klávesnic do předvoleb atd. Většinu problémů se mi daří řešit (často díky tomuto fóru) nebo jsem ochoten se s nimi smířit. Ale mít notebook bez zvuku? To je dost krutý :frowning: Navíc nemám ona zadní vrátka do woken. Špatný špatný špatný. Pokud by někomu pomohlo, tak přidávám na konec své litanie výstup z amixeru, ale vše se zdá v pořádku. Což je asi ten největší problém… nikde žádná chybová hláška, nějaký konflikt, něco čeho bych se mohl chytit. Prostě všecho se tváří OK, ale notebook zatvrzele mlčí.

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 45731 [70%] [on]
  Front Right: Playback 45731 [70%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 65536 [100%] [on]
  Front Right: Capture 65536 [100%] [on]

Chyba je to, ze si sem nezkopiroval vystup toho co si delal a predevsim obsah rc.local - protoze podle toho co pises si udelal nejaky nesmysl - ten prikaz se musi pridat pred (omlouvam se v tom mem popisku vypadlo slovo “pred” ) exit 0 - prikazem exit se ten skript ukonci a pridany prikaz se neprovede.

Co mas za problem s copy&paste? To se v linuxu provadi pouhym oznacenim mysi (copy) a stiskem prostredniho mysitka (paste). Nemusis sahnout na klavesnici.

Moc děkuji za pomoc, nyní už zvučím zcela bez problému. Problém byl v tom, že jsem si myslel, že do rc.local mám přidat řádek “exit 0 :” a pak provést v terminalu příkaz “/usr/bin/hda-verb /dev/snd/hwC0D0 0x19 SET_PIN_WIDGET_CONTROL 0x22” Prostě jsem to nepochopil správně, jinak byl návod zcela korektní a plně funkční. Kdybych nebyl lama, tak mi to už od včera funguje.

Problém s copy&paste je v tom, že se mi třeba nedaři pomocí ctrl+c a ctrl+v překopírovat text z firefoxu do terminálu. Ale přes druhé tlačíko myši a příkazy kopírovat, vložit to šlo. Zdržovalo mně to a trochu rozčilovalo. O Tebou popisované fičuře jsem neměl ani potuchy, díky za tip - hodně to usnadní práci. Vše ostatní se mi pomalu daří odbourávat (třeba to přepínání klávesnic už jsem dal do kupy).

Hlavně ale že mi jede zvuk, už jsem začínal propadat trudomyslnosti :slight_smile:

Jenom poznamka gnome-terminal ma stadardne nastavene ctrl+shift+v© pro copy/paste. Pouzivat v terminalu ctr+c na vkladani neni moc dobry napad :).