yum update - prechod z jadra 2.6.18 > 2.6.20

Zdravim,
upgradoval jsem uspesne FC5 na FC6 a rozhodl se updatovat system, mym cilem je prejit na jadro 2.6.20, ktere udajne obsahuje modul pro ovladani proklate sitovky rtl8168.

pro uplnost dodavam svoji verzi jadra a dalsi informace:
[root@none 3xtr4ct]# dmesg | head
Bootdata ok (command line is ro root=LABEL=/ rhgb quiet noapic)
Linux version 2.6.18-1.2798.fc6 (brewbuilder@hs20-bc1-6.build.redhat.com) (gcc version 4.1.1 20061011 (Red Hat 4.1.1-30)) #1 SMP Mon Oct 16 14:39:22 EDT 2006

zde je cast vypisu yum update:

—> Package hal.x86_64 0:0.5.8.1-6.fc6 set to be updated
—> Package readahead.x86_64 1:1.3-7.fc6 set to be updated
–> Running transaction check
–> Processing Dependency: elfutils-libelf = 0.119-1.2.1 for package: elfutils
–> Processing Dependency: cyrus-sasl-md5 for package: gaim
–> Processing Conflict: elfutils-libs conflicts elfutils < 0.126-1.fc6
–> Processing Dependency: systemtap-runtime = 0.5.12-1.fc6 for package: systemtap
–> Processing Dependency: libparted-1.8.so.2 for package: mkinitrd
–> Processing Conflict: elfutils-libelf conflicts elfutils < 0.126-1.fc6
–> Processing Dependency: elfutils-libs = 0.119-1.2.1 for package: elfutils
–> Restarting Dependency Resolution with new changes.
–> Populating transaction set with selected packages. Please wait.
—> Package parted.i386 0:1.8.2-1.fc6 set to be updated
—> Package cyrus-sasl-md5.x86_64 0:2.1.22-4 set to be updated
—> Package systemtap-runtime.x86_64 0:0.5.12-1.fc6 set to be updated
–> Running transaction check
–> Processing Conflict: elfutils-libs conflicts elfutils < 0.126-1.fc6
–> Processing Dependency: elfutils-libelf = 0.119-1.2.1 for package: elfutils
–> Processing Conflict: elfutils-libelf conflicts elfutils < 0.126-1.fc6
–> Processing Dependency: elfutils-libs = 0.119-1.2.1 for package: elfutils
–> Restarting Dependency Resolution with new changes.
–> Populating transaction set with selected packages. Please wait.
–> Running transaction check
–> Processing Conflict: elfutils-libs conflicts elfutils < 0.126-1.fc6
–> Processing Dependency: elfutils-libelf = 0.119-1.2.1 for package: elfutils
–> Processing Conflict: elfutils-libelf conflicts elfutils < 0.126-1.fc6
–> Processing Dependency: elfutils-libs = 0.119-1.2.1 for package: elfutils
–> Restarting Dependency Resolution with new changes.
–> Populating transaction set with selected packages. Please wait.
–> Running transaction check
Error: Unable to satisfy dependencies
Error: Package elfutils-libs conflicts with elfutils < 0.126-1.fc6.
Error: Package elfutils needs elfutils-libelf = 0.119-1.2.1, this is not available.
Error: Package elfutils-libelf conflicts with elfutils < 0.126-1.fc6.
Error: Package elfutils needs elfutils-libs = 0.119-1.2.1, this is not available.

nevim jak si ted pocit, jestli je moji jedinou spasou pustit se do rpm pekla a snazit se nainstalovat rucne vsechny balicky o kterych pise ze chybi, nebo ze sjou chybne. Za tipy, triky a rady dekuji

Zkuste nejprve “natvrdo” odinstalovat vsechno co ma v nazvu elfutils

Seznam balicku ziskate pomoci

rpm -qa | grep elfutils

Odinstalovani provedete pomoci

rpm -e --force nazev_balicku

Po te zkuste balicky opetovne doinstalovat.

Macky

PS: Predpokladam, ze mate povoleny pouze standardni repozitare + livna.

Tenhle problem jsem mel taky a je zpusoben zrejme prave tim ze mate system aktualizovany. V FC6 jsou baliky prebalene jinak. To co pise macky by melo pomoci, ale s tim --force zachazejte opatrne.