yum update 12

Dobry den,
zdravim vsechny linuxaky, mam maly problem s update v yumu na fedore 12 (Opet :slight_smile: )
Nevim, asi to bude mnou, ale posledni dobou se me nejak s fedorou nedari v dobrem vychazet…
Takze pri predvcerejsi denni upgradu systemu ( yum update) me yum vyhleda aktualizovane baliky,
tj. problem s nvidiou jsem preskocil, uz je ve stromu zverejene nove ovladace do noveho jadra, ale
vypise me problem se zavislostmi.
#yum update

Loaded plugins: presto, refresh-packagekit, security
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
–> Running transaction check
—> Package PyKDE4.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdeaccessibility.i686 1:4.4.4-1.fc12 set to be updated
—> Package kdeaccessibility-libs.i686 1:4.4.4-1.fc12 set to be updated
—> Package kdeartwork-kxs.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdeartwork-screensavers.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdebase.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdebase-libs.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdebase-runtime.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdebase-runtime-libs.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdebase-workspace.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdebase-workspace-devel.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdebase-workspace-libs.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdebase-workspace-python-applet.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdeedu-marble.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdeedu-marble-libs.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdegames.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdegames-libs.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdegames-minimal.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdegraphics.i686 7:4.4.4-1.fc12 set to be updated
—> Package kdegraphics-libs.i686 7:4.4.4-1.fc12 set to be updated
—> Package kdelibs.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdelibs-common.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdelibs-devel.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdemultimedia.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdemultimedia-devel.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdemultimedia-libs.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdenetwork.i686 7:4.4.4-1.fc12 set to be updated
—> Package kdenetwork-libs.i686 7:4.4.4-1.fc12 set to be updated
—> Package kdepim.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdepim-libs.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdepim-runtime.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdepim-runtime-libs.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdepimlibs.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdepimlibs-akonadi.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdepimlibs-devel.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdeplasma-addons.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdeplasma-addons-libs.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdesdk.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdesdk-libs.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdesdk-utils.i686 0:4.4.4-1.fc12 set to be updated
—> Package kdeutils.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdeutils-libs.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdeutils-printer-applet.i686 6:4.4.4-1.fc12 set to be updated
—> Package kdm.i686 0:4.4.4-1.fc12 set to be updated
—> Package kio_msits.i686 7:4.4.4-1.fc12 set to be updated
—> Package kmod-nvidia.i686 1:195.36.24-1.fc12.3 set to be updated
–> Processing Dependency: kmod-nvidia-2.6.32.14-127.fc12.i686 >= 1:195.36.24-1.fc12.3 for package: 1:kmod-nvidia-195.36.24-1.fc12.3.i686
—> Package kmod-nvidia-PAE.i686 1:195.36.24-1.fc12.3 set to be updated
–> Processing Dependency: kmod-nvidia-2.6.32.14-127.fc12.i686.PAE >= 1:195.36.24-1.fc12.3 for package: 1:kmod-nvidia-PAE-195.36.24-1.fc12.3.i686
—> Package kross-python.i686 0:4.4.4-1.fc12 set to be updated
—> Package ksysguardd.i686 0:4.4.4-1.fc12 set to be updated
—> Package libexif.i686 0:0.6.19-1.fc12 set to be updated
—> Package openssl.i686 0:1.0.0a-1.fc12 set to be updated
—> Package openssl-devel.i686 0:1.0.0a-1.fc12 set to be updated
—> Package oxygen-icon-theme.noarch 0:4.4.4-1.fc12 set to be updated
—> Package pcsc-lite.i686 0:1.5.2-4.fc12 set to be updated
—> Package pcsc-lite-devel.i686 0:1.5.2-4.fc12 set to be updated
—> Package pcsc-lite-libs.i686 0:1.5.2-4.fc12 set to be updated
—> Package qt.i686 1:4.6.2-20.fc12 set to be updated
—> Package qt-devel.i686 1:4.6.2-20.fc12 set to be updated
—> Package qt-mysql.i686 1:4.6.2-20.fc12 set to be updated
—> Package qt-sqlite.i686 1:4.6.2-20.fc12 set to be updated
—> Package qt-x11.i686 1:4.6.2-20.fc12 set to be updated
—> Package system-config-printer-kde.i686 7:4.4.4-1.fc12 set to be updated
—> Package system-config-users.noarch 0:1.2.99-1.fc12 set to be updated
–> Running transaction check
—> Package kmod-nvidia-2.6.32.14-127.fc12.i686.i686 1:195.36.24-1.fc12.3 set to be updated
—> Package kmod-nvidia-2.6.32.14-127.fc12.i686.PAE.i686 1:195.36.24-1.fc12.3 set to be updated
–> Processing Dependency: /usr/lib/.libssl.so.1.0.0.hmac for package: 1:libguestfs-1.0.85-1.fc12.3.i686
–> Processing Dependency: /usr/lib/.libcrypto.so.1.0.0.hmac for package: 1:libguestfs-1.0.85-1.fc12.3.i686
–> Finished Dependency Resolution
Error: Package: 1:libguestfs-1.0.85-1.fc12.3.i686 (@updates)
Requires: /usr/lib/.libcrypto.so.1.0.0.hmac
Removing: openssl-1.0.0-4.fc12.i686 (@updates)
Available: openssl-1.0.0-0.10.beta3.fc12.i686 (fedora)
Error: Package: 1:libguestfs-1.0.85-1.fc12.3.i686 (@updates)
Requires: /usr/lib/.libssl.so.1.0.0.hmac
Removing: openssl-1.0.0-4.fc12.i686 (@updates)
Available: openssl-1.0.0-0.10.beta3.fc12.i686 (fedora)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

a ze zavislosti na libguestfs-1.0.85-1.fc12.3.i686 se nemuzu dostat…
Pokud by mel nekdo napomocnou radu, sem s ni…
Diky Jura

Zkus docasne odstranit balik libguestfs a jeho zavislosti (yum remove libguestfs). Nevim zda guestfs vubec pouzivas. Je to nastroj na prohlizeni souborovych systemu virtualizovanych stroju.

Diky za odpoved,
balik libguestfs sice pouzivam, ale pro upgrade ho odinstaluji viz:

yum remove libguestfs
Loaded plugins: presto, refresh-packagekit, security
Setting up Remove Process
Resolving Dependencies
–> Running transaction check
—> Package libguestfs.i686 1:1.0.85-1.fc12.3 set to be erased
–> Processing Dependency: libguestfs.so.0 for package: 1:perl-libguestfs-1.0.85-1.fc12.3.i686
–> Processing Dependency: libguestfs = 1:1.0.85-1.fc12.3 for package: 1:perl-libguestfs-1.0.85-1.fc12.3.i686
–> Running transaction check
—> Package perl-libguestfs.i686 1:1.0.85-1.fc12.3 set to be erased
–> Processing Dependency: perl(Sys::Guestfs) for package: virt-v2v-0.2.0-1.fc12.noarch
–> Processing Dependency: perl(Sys::Guestfs) for package: virt-v2v-0.2.0-1.fc12.noarch
–> Processing Dependency: perl(Sys::Guestfs::Lib) for package: virt-v2v-0.2.0-1.fc12.noarch
–> Processing Dependency: perl(Sys::Guestfs::Lib) for package: virt-v2v-0.2.0-1.fc12.noarch
–> Processing Dependency: perl-libguestfs >= 1:1.0.68 for package: virt-v2v-0.2.0-1.fc12.noarch
–> Running transaction check
—> Package virt-v2v.noarch 0:0.2.0-1.fc12 set to be erased
–> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================
Package Arch Version Repository Size

Removing:
libguestfs i686 1:1.0.85-1.fc12.3 @updates 3.4 M
Removing for dependencies:
perl-libguestfs i686 1:1.0.85-1.fc12.3 @updates 605 k
virt-v2v noarch 0.2.0-1.fc12 @fedora 243 k

Transaction Summary

Remove 3 Package(s)
Reinstall 0 Package(s)
Downgrade 0 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : 1:libguestfs-1.0.85-1.fc12.3.i686 1/3
Erasing : virt-v2v-0.2.0-1.fc12.noarch 2/3
Erasing : 1:perl-libguestfs-1.0.85-1.fc12.3.i686 3/3

Removed:
libguestfs.i686 1:1.0.85-1.fc12.3

Dependency Removed:
perl-libguestfs.i686 1:1.0.85-1.fc12.3 virt-v2v.noarch 0:0.2.0-1.fc12

Complete!

Dale yum update prosel, takze dekuji za radu, problem ale je, ze znovu naistalovat dany balik kvuli zavislostem nelze…
viz:
yum install libguestfs
Loaded plugins: presto, refresh-packagekit, security
Setting up Install Process
Resolving Dependencies
–> Running transaction check
—> Package libguestfs.i686 1:1.0.85-1.fc12.3 set to be updated
–> Processing Dependency: /usr/lib/.libcrypto.so.1.0.0.hmac for package: 1:libguestfs-1.0.85-1.fc12.3.i686
–> Processing Dependency: /usr/lib/.libssl.so.1.0.0.hmac for package: 1:libguestfs-1.0.85-1.fc12.3.i686
–> Processing Dependency: /usr/lib/.libssl.so.1.0.0.hmac for package: 1:libguestfs-1.0.85-1.fc12.3.i686
–> Processing Dependency: /usr/lib/.libcrypto.so.1.0.0.hmac for package: 1:libguestfs-1.0.85-1.fc12.3.i686
–> Finished Dependency Resolution
Error: Package: 1:libguestfs-1.0.85-1.fc12.3.i686 (updates)
Requires: /usr/lib/.libssl.so.1.0.0.hmac
Available: openssl-1.0.0-0.10.beta3.fc12.i686 (fedora)
Error: Package: 1:libguestfs-1.0.85-1.fc12.3.i686 (updates)
Requires: /usr/lib/.libcrypto.so.1.0.0.hmac
Available: openssl-1.0.0-0.10.beta3.fc12.i686 (fedora)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

PS. doporuceni programu yumu jsem zkousel, ale nepomohly.

Priznam se ze nechapu kde si vzal openssl-1.0.0-0.10.beta3.fc12, protoze ja mam v f12 openssl-1.0.0-4.fc12. Zkousel si vycistit cache (yum clean all)? Nemas nejake externi repozitare, nebo nejake nestandardni nastaveni? Co pise “yum list openssl”?