Yum, missing dependency libc.so.6

Dobry den, mam problem pri instalovani nebo updatovani pres yum, velmi casto vypise error:
Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package …
glibc mam glibc.i686 2.3.5-10.3
Vyhledal jsem si libc.so.6:
/lib/i686/nosegneg/libc.so.6
/lib/libc.so.6
/lib/obsolete/linuxthreads/i686/libc.so.6
/lib/obsolete/linuxthreads/libc.so.6
a nechapu, proc ho yum nemuze najit, kdyz je na 4 mistech.

Osobne hadam ze pouzivat rpm z ruzny nestandardnich repozitaru. Doporuceno je pouzivat pouze ty z fedora, extras a livna a to pouze NEdevel verze. Pokud vam nektery balik z techto zdroju vypise takovouto hlasku, a nemate povoleno instalovat baliky z devel (rawhide) pak by me zajimalo ktere do delaji, protoze by se jednalo o chybu toho kdo balik vytvarel.

Zrejme to tim opradu bylo, protoze jsem ted vyhazel vsechny ostatni repozitare krome oficialnich a zatim je to bez problemu