yum-complete-transaction

Zdravím,
při pokusu o aktualizování nebo instalaci mě jsem se dozvěděl, že nemám kompletní transakce a mám použít následující příkaz. Ten mí při prvním pokusu ještě poradil volbu --skip-broken, ale i s ní skončil na chybě, když se pokouší smazat yum. Asi jsem dělal se systémem nějaké špatné věci, ale chtěl jsem se zeptat, jestli mám nějakou lepší možnost, než reinstal systému?
Díky

[slaweet@fedora html]$ sudo yum-complete-transaction --skip-broken
Loaded plugins: langpacks, presto, refresh-packagekit
There are 1 outstanding transactions to complete. Finishing the most recent one
The remaining transaction had 62 elements left to run
Removing systemtap.i686 0:1.5-8.fc15 - ud from the transaction
Removing systemtap.i686 0:1.6-1.fc15 - u from the transaction
Removing PackageKit-command-not-found.i686 0:0.6.16-1.fc15 - ud from the transaction
Removing PackageKit-command-not-found.i686 0:0.6.17-1.fc15 - u from the transaction
Removing PackageKit-gstreamer-plugin.i686 0:0.6.16-1.fc15 - ud from the transaction
Removing PackageKit-gstreamer-plugin.i686 0:0.6.17-1.fc15 - u from the transaction
Removing PackageKit-device-rebind.i686 0:0.6.16-1.fc15 - ud from the transaction
Removing PackageKit-device-rebind.i686 0:0.6.17-1.fc15 - u from the transaction
Removing PackageKit-gtk-module.i686 0:0.6.16-1.fc15 - ud from the transaction
Removing PackageKit-gtk-module.i686 0:0.6.17-1.fc15 - u from the transaction
Removing ibus-pinyin.i686 0:1.3.99.20110520-1.fc15 - ud from the transaction
Removing ibus-pinyin.i686 0:1.3.99.20110706-2.fc15 - u from the transaction
Removing grsync.i686 0:1.1.1-2.fc15 - ud from the transaction
Removing grsync.i686 0:1.2.0-1.fc15 - u from the transaction
Removing ibus-hangul.i686 0:1.3.1-3.fc15 - ud from the transaction
Removing ibus-hangul.i686 0:1.3.1-6.fc15 - u from the transaction
Removing logrotate.i686 0:3.7.9-13.fc15 - ud from the transaction
Removing logrotate.i686 0:3.7.9-14.fc15 - u from the transaction
Removing cifs-utils.i686 0:5.0-1.fc15 - ud from the transaction
Removing cifs-utils.i686 0:5.0-2.fc15 - u from the transaction
Removing lm_sensors-libs.i686 0:3.3.0-2.fc15 - ud from the transaction
Removing lm_sensors-libs.i686 0:3.3.1-1.fc15 - u from the transaction
–> Running transaction check
—> Package PackageKit.i686 0:0.6.16-1.fc15 will be erased
—> Package PackageKit-command-not-found.i686 0:0.6.16-1.fc15 will be erased
—> Package PackageKit-device-rebind.i686 0:0.6.16-1.fc15 will be erased
–> Processing Dependency: PackageKit-device-rebind >= 0.5.0 for package: gnome-packagekit-3.0.0-5.fc15.i686
—> Package PackageKit-glib.i686 0:0.6.16-1.fc15 will be erased
—> Package PackageKit-gstreamer-plugin.i686 0:0.6.16-1.fc15 will be erased
–> Processing Dependency: PackageKit-gstreamer-plugin for package: 2:phonon-backend-gstreamer-4.5.1-1.fc15.i686
—> Package PackageKit-gtk-module.i686 0:0.6.16-1.fc15 will be erased
—> Package PackageKit-yum.i686 0:0.6.16-1.fc15 will be erased
—> Package PackageKit-yum-plugin.i686 0:0.6.16-1.fc15 will be erased
—> Package cifs-utils.i686 0:5.0-1.fc15 will be erased
—> Package curl.i686 0:7.21.3-8.fc15 will be erased
–> Processing Dependency: curl for package: cairo-dock-core-2.3.0.3-2.fc15.i686
–> Processing Dependency: curl for package: fedora-packager-0.5.9.2-1.fc15.noarch
–> Processing Dependency: curl for package: abrt-addon-kerneloops-2.0.3-1.fc15.i686
–> Processing Dependency: curl for package: rpmdevtools-8.1-1.fc15.noarch
–> Processing Dependency: curl for package: rpm-4.9.0-9.fc15.i686
—> Package fbreader.i686 0:0.12.10-4.fc15 will be erased
—> Package fbreader-gtk.i686 0:0.12.10-4.fc15 will be erased
—> Package gedit-plugins.i686 0:3.0.5-1.fc15 will be erased
—> Package glibc.i686 0:2.14-4 will be erased
—> Package glibc-common.i686 0:2.14-4 will be erased
—> Package glibc-devel.i686 0:2.14-4 will be erased
—> Package glibc-headers.i686 0:2.14-4 will be erased
—> Package google-chrome-stable.i386 0:13.0.782.107-94237 will be erased
—> Package grsync.i686 0:1.1.1-2.fc15 will be erased
—> Package ibus-hangul.i686 0:1.3.1-3.fc15 will be erased
—> Package ibus-pinyin.i686 0:1.3.99.20110520-1.fc15 will be erased
—> Package ibus-pinyin-db-android.noarch 0:1.3.99.20110520-1.fc15 will be erased
—> Package kdelibs-common.i686 6:4.6.5-1.fc15 will be erased
—> Package libcurl.i686 0:7.21.3-8.fc15 will be erased
—> Package lm_sensors-libs.i686 0:3.3.0-2.fc15 will be erased
–> Processing Dependency: libsensors.so.4 for package: cairo-dock-plug-ins-2.3.0.3-2.fc15.i686
—> Package logrotate.i686 0:3.7.9-13.fc15 will be erased
–> Processing Dependency: logrotate for package: ppp-2.4.5-17.fc15.i686
–> Processing Dependency: logrotate >= 3.5.2 for package: rsyslog-5.8.2-1.fc15.i686
—> Package mesa-dri-drivers.i686 0:7.11-0.16.20110709.0.fc15 will be erased
—> Package mesa-dri-filesystem.i686 0:7.11-0.16.20110709.0.fc15 will be erased
—> Package mesa-libGL.i686 0:7.11-0.16.20110709.0.fc15 will be erased
—> Package mesa-libGLU.i686 0:7.11-0.16.20110709.0.fc15 will be erased
—> Package mock.noarch 0:1.1.11-1.fc15 will be erased
—> Package perl.i686 4:5.12.4-159.fc15 will be erased
—> Package perl-Module-Pluggable.noarch 1:3.90-159.fc15 will be erased
—> Package perl-Pod-Escapes.noarch 1:1.04-159.fc15 will be erased
—> Package perl-Pod-Simple.noarch 1:3.13-159.fc15 will be erased
—> Package perl-libs.i686 4:5.12.4-159.fc15 will be erased
—> Package qt.i686 1:4.7.3-6.fc15 will be erased
—> Package qt-webkit.i686 1:4.7.3-6.fc15 will be erased
—> Package qt-x11.i686 1:4.7.3-6.fc15 will be erased
—> Package shadow-utils.i686 2:4.1.4.2-12.fc15 will be erased
—> Package system-config-lvm.noarch 0:1.1.15-2.fc15 will be erased
—> Package systemtap.i686 0:1.5-8.fc15 will be erased
–> Processing Dependency: systemtap >= 1.2 for package: eclipse-callgraph-0.6.1-2.fc15.i686
—> Package systemtap-runtime.i686 0:1.5-8.fc15 will be erased
—> Package vlgothic-fonts.noarch 0:20110414-1.fc15 will be erased
—> Package vlgothic-fonts-common.noarch 0:20110414-1.fc15 will be erased
—> Package zeitgeist.noarch 0:0.8.0-1.fc15 will be erased
—> Package zlibrary.i686 0:0.12.10-4.fc15 will be erased
—> Package zlibrary-ui-gtk.i686 0:0.12.10-4.fc15 will be erased
–> Running transaction check
—> Package abrt-addon-kerneloops.i686 0:2.0.3-1.fc15 will be erased
–> Processing Dependency: abrt-addon-kerneloops for package: abrt-desktop-2.0.3-1.fc15.i686
—> Package cairo-dock-core.i686 0:2.3.0.3-2.fc15 will be erased
–> Processing Dependency: cairo-dock-core = 2.3.0.3-2.fc15 for package: cairo-dock-2.3.0.3-2.fc15.i686
—> Package cairo-dock-plug-ins.i686 0:2.3.0.3-2.fc15 will be erased
—> Package eclipse-callgraph.i686 0:0.6.1-2.fc15 will be erased
—> Package fedora-packager.noarch 0:0.5.9.2-1.fc15 will be erased
—> Package gnome-packagekit.i686 0:3.0.0-5.fc15 will be erased
—> Package phonon-backend-gstreamer.i686 2:4.5.1-1.fc15 will be erased
—> Package ppp.i686 0:2.4.5-17.fc15 will be erased
–> Processing Dependency: ppp for package: wvdial-1.61-4.fc15.i686
–> Processing Dependency: ppp = 2.4.5 for package: 1:NetworkManager-0.8.9997-6.git20110721.fc15.i686
–> Processing Dependency: ppp = 2.4.5 for package: 1:NetworkManager-pptp-0.8.999-2.git20110721.fc15.i686
–> Processing Dependency: ppp >= 2.4.2 for package: rp-pppoe-3.10-8.fc15.i686
–> Processing Dependency: ppp >= 2.4.2 for package: pptp-1.7.2-12.fc15.i686
—> Package rpm.i686 0:4.9.0-9.fc15 will be erased
–> Processing Dependency: rpm = 4.9.0-9.fc15 for package: rpm-libs-4.9.0-9.fc15.i686
–> Processing Dependency: rpm for package: color-filesystem-1-8.noarch
–> Processing Dependency: rpm for package: kde-filesystem-4-38.fc15.i686
–> Processing Dependency: rpm >= 4.6.0 for package: redhat-rpm-config-9.1.0-8.fc15.noarch
–> Processing Dependency: rpm for package: policycoreutils-2.0.86-7.fc15.i686
–> Processing Dependency: rpm = 4.9.0-9.fc15 for package: rpm-build-4.9.0-9.fc15.i686
–> Processing Dependency: rpm = 4.9.0-9.fc15 for package: rpm-python-4.9.0-9.fc15.i686
–> Processing Dependency: rpm >= 4.1.1 for package: createrepo-0.9.9-4.fc15.noarch
–> Processing Dependency: rpm >= 4.4.2 for package: yum-3.2.29-8.fc15.noarch
–> Processing Dependency: rpm >= 4.1.1 for package: preupgrade-1.1.9-1.fc15.noarch
–> Processing Dependency: rpm for package: python-meh-0.11-2.fc15.noarch
—> Package rpmdevtools.noarch 0:8.1-1.fc15 will be erased
–> Processing Dependency: rpmdevtools for package: eclipse-rpm-editor-0.6.0-2.fc15.i686
—> Package rsyslog.i686 0:5.8.2-1.fc15 will be erased
–> Processing Dependency: syslog for package: cronie-1.4.8-2.fc15.i686
–> Running transaction check
—> Package NetworkManager.i686 1:0.8.9997-6.git20110721.fc15 will be erased
–> Processing Dependency: NetworkManager >= 1:0.8.998 for package: NetworkManager-openconnect-0.8.999-1.fc15.i686
–> Processing Dependency: NetworkManager >= 1:0.7.1-3.git20090414 for package: anaconda-15.31-1.fc15.i686
–> Processing Dependency: NetworkManager = 1:0.8.9997-6.git20110721.fc15 for package: 1:NetworkManager-gnome-0.8.9997-6.git20110721.fc15.i686
–> Processing Dependency: NetworkManager >= 1:0.8.998 for package: 1:NetworkManager-vpnc-0.8.999-3.git20110721.fc15.i686
–> Processing Dependency: NetworkManager >= 1:0.8.998 for package: 1:NetworkManager-openvpn-0.8.9997-2.git20110721.fc15.i686
—> Package NetworkManager-pptp.i686 1:0.8.999-2.git20110721.fc15 will be erased
—> Package abrt-desktop.i686 0:2.0.3-1.fc15 will be erased
—> Package cairo-dock.i686 0:2.3.0.3-2.fc15 will be erased
—> Package color-filesystem.noarch 0:1-8 will be erased
–> Processing Dependency: color-filesystem >= 1-7 for package: gnome-color-manager-3.0.0-3.fc15.i686
–> Processing Dependency: color-filesystem for package: shared-color-profiles-0.1.4-1.fc15.noarch
—> Package createrepo.noarch 0:0.9.9-4.fc15 will be erased
–> Processing Dependency: createrepo for package: mock-1.1.12-1.fc15.noarch
—> Package cronie.i686 0:1.4.8-2.fc15 will be erased
–> Processing Dependency: cronie = 1.4.8-2.fc15 for package: cronie-anacron-1.4.8-2.fc15.i686
—> Package eclipse-rpm-editor.i686 0:0.6.0-2.fc15 will be erased
—> Package kde-filesystem.i686 0:4-38.fc15 will be erased
–> Processing Dependency: kde-filesystem for package: kdelibs3-3.5.10-25.fc15.i686
–> Processing Dependency: kde-filesystem for package: 1:kde-i18n-3.5.10-15.fc15.noarch
–> Processing Dependency: kde-filesystem for package: vlc-1.1.11-1.fc15.i686
–> Processing Dependency: kde-filesystem for package: phonon-4.5.0-2.fc15.i686
–> Processing Dependency: kde-filesystem for package: kde-settings-4.6-10.fc15.noarch
—> Package policycoreutils.i686 0:2.0.86-7.fc15 will be erased
–> Processing Dependency: policycoreutils = 2.0.86-7.fc15 for package: policycoreutils-python-2.0.86-7.fc15.i686
—> Package pptp.i686 0:1.7.2-12.fc15 will be erased
—> Package preupgrade.noarch 0:1.1.9-1.fc15 will be erased
—> Package python-meh.noarch 0:0.11-2.fc15 will be erased
–> Processing Dependency: python-meh for package: firstboot-1.119-1.fc15.i686
—> Package redhat-rpm-config.noarch 0:9.1.0-8.fc15 will be erased
—> Package rp-pppoe.i686 0:3.10-8.fc15 will be erased
—> Package rpm-build.i686 0:4.9.0-9.fc15 will be erased
–> Processing Dependency: rpm-build for package: fedpkg-0.5.9.2-1.fc15.noarch
–> Processing Dependency: rpm-build for package: akmods-0.3.6-3.fc12.noarch
—> Package rpm-libs.i686 0:4.9.0-9.fc15 will be erased
–> Processing Dependency: librpm.so.2 for package: deltarpm-3.6-0.6.20110223git.fc15.i686
–> Processing Dependency: librpm.so.2 for package: abrt-2.0.3-1.fc15.i686
–> Processing Dependency: librpm.so.2 for package: rpm-build-libs-4.9.0-9.fc15.i686
–> Processing Dependency: librpmio.so.2 for package: deltarpm-3.6-0.6.20110223git.fc15.i686
–> Processing Dependency: librpmio.so.2 for package: abrt-2.0.3-1.fc15.i686
–> Processing Dependency: librpmio.so.2 for package: rpm-build-libs-4.9.0-9.fc15.i686
–> Processing Dependency: rpm-libs(x86-32) = 4.9.0-9.fc15 for package: rpm-build-libs-4.9.0-9.fc15.i686
—> Package rpm-python.i686 0:4.9.0-9.fc15 will be erased
–> Processing Dependency: rpm-python for package: koji-1.6.0-2.fc15.noarch
–> Processing Dependency: rpm-python for package: system-config-users-1.2.107-2.fc15.noarch
–> Processing Dependency: rpm-python for package: system-config-network-tui-1.6.2-2.fc15.noarch
–> Processing Dependency: rpm-python for package: setroubleshoot-server-3.0.38-1.fc15.i686
–> Processing Dependency: rpm-python for package: report-plugin-bugzilla-0.22-0.fc15.i686
–> Processing Dependency: rpm-python >= 4.4.2.2 for package: rpmlint-1.2-1.fc15.noarch
—> Package wvdial.i686 0:1.61-4.fc15 will be erased
—> Package yum.noarch 0:3.2.29-8.fc15 will be erased
–> Processing Dependency: yum >= 3.2.19 for package: PackageKit-yum-0.6.17-1.fc15.i686
–> Processing Dependency: yum >= 3.0 for package: yum-langpacks-0.2.2-1.fc15.noarch
–> Processing Dependency: yum for package: bodhi-client-0.8.0-1.fc15.noarch
–> Processing Dependency: yum for package: system-config-language-1.3.5-8.fc15.noarch
–> Processing Dependency: yum >= 3.0 for package: yum-presto-0.6.2-3.fc15.noarch
–> Processing Dependency: yum >= 3.2.29 for package: yum-utils-1.1.30-3.fc15.noarch
–> Processing Dependency: yum for package: setroubleshoot-3.0.38-1.fc15.i686
–> Processing Dependency: yum for package: 1:anaconda-yum-plugins-1.0-6.fc15.noarch
–> Processing Dependency: yum >= 3.0 for package: PackageKit-yum-plugin-0.6.17-1.fc15.i686
–> Running transaction check
—> Package NetworkManager-gnome.i686 1:0.8.9997-6.git20110721.fc15 will be erased
—> Package NetworkManager-openconnect.i686 0:0.8.999-1.fc15 will be erased
—> Package NetworkManager-openvpn.i686 1:0.8.9997-2.git20110721.fc15 will be erased
—> Package NetworkManager-vpnc.i686 1:0.8.999-3.git20110721.fc15 will be erased
—> Package PackageKit-yum.i686 0:0.6.17-1.fc15 will be erased
–> Processing Dependency: PackageKit-backend for package: PackageKit-0.6.17-1.fc15.i686
—> Package PackageKit-yum-plugin.i686 0:0.6.17-1.fc15 will be erased
—> Package abrt.i686 0:2.0.3-1.fc15 will be erased
–> Processing Dependency: abrt = 2.0.3-1.fc15 for package: abrt-plugin-logger-2.0.3-1.fc15.i686
–> Processing Dependency: abrt = 2.0.3-1.fc15 for package: abrt-plugin-bugzilla-2.0.3-1.fc15.i686
–> Processing Dependency: abrt = 2.0.3-1.fc15 for package: abrt-addon-python-2.0.3-1.fc15.i686
–> Processing Dependency: abrt = 2.0.3-1.fc15 for package: abrt-gui-2.0.3-1.fc15.i686
–> Processing Dependency: abrt = 2.0.3-1.fc15 for package: abrt-addon-ccpp-2.0.3-1.fc15.i686
—> Package akmods.noarch 0:0.3.6-3.fc12 will be erased
–> Processing Dependency: akmods for package: 1:akmod-nvidia-280.13-2.fc15.i686
—> Package anaconda.i686 0:15.31-1.fc15 will be erased
—> Package anaconda-yum-plugins.noarch 1:1.0-6.fc15 will be erased
—> Package bodhi-client.noarch 0:0.8.0-1.fc15 will be erased
—> Package cronie-anacron.i686 0:1.4.8-2.fc15 will be erased
—> Package deltarpm.i686 0:3.6-0.6.20110223git.fc15 will be erased
–> Processing Dependency: deltarpm = 3.6-0.6.20110223git.fc15 for package: python-deltarpm-3.6-0.6.20110223git.fc15.i686
—> Package fedpkg.noarch 0:0.5.9.2-1.fc15 will be erased
—> Package firstboot.i686 0:1.119-1.fc15 will be erased
—> Package gnome-color-manager.i686 0:3.0.0-3.fc15 will be erased
—> Package kde-i18n.noarch 1:3.5.10-15.fc15 will be erased
–> Processing Dependency: kde-i18n = 1:3.5.10-15.fc15 for package: 1:kde-i18n-Czech-3.5.10-15.fc15.noarch
—> Package kde-settings.noarch 0:4.6-10.fc15 will be erased
—> Package kdelibs3.i686 0:3.5.10-25.fc15 will be erased
–> Processing Dependency: libkdecore.so.4 for package: kdissert-1.0.7-9.fc15.i686
–> Processing Dependency: libkdeprint.so.4 for package: kdissert-1.0.7-9.fc15.i686
–> Processing Dependency: libkdeui.so.4 for package: kdissert-1.0.7-9.fc15.i686
–> Processing Dependency: libkio.so.4 for package: kdissert-1.0.7-9.fc15.i686
–> Processing Dependency: libkmdi.so.1 for package: kdissert-1.0.7-9.fc15.i686
–> Processing Dependency: libkparts.so.2 for package: kdissert-1.0.7-9.fc15.i686
—> Package koji.noarch 0:1.6.0-2.fc15 will be erased
—> Package mock.noarch 0:1.1.12-1.fc15 will be erased
—> Package phonon.i686 0:4.5.0-2.fc15 will be erased
–> Processing Dependency: libphonon.so.4 for package: PyQt4-4.8.3-2.fc15.i686
–> Processing Dependency: libphonon.so.4 for package: phonon-backend-vlc-0.4.0-1.fc15.i686
–> Processing Dependency: libphonon.so.4 for package: 1:qt-webkit-4.7.3-8.fc15.i686
–> Processing Dependency: phonon(x86-32) >= 4.5.0 for package: phonon-backend-vlc-0.4.0-1.fc15.i686
—> Package policycoreutils-python.i686 0:2.0.86-7.fc15 will be erased
—> Package report-plugin-bugzilla.i686 0:0.22-0.fc15 will be erased
–> Processing Dependency: report-plugin-bugzilla = 0.22-0.fc15 for package: report-config-bugzilla-redhat-com-0.22-0.fc15.i686
—> Package rpm-build-libs.i686 0:4.9.0-9.fc15 will be erased
—> Package rpmlint.noarch 0:1.2-1.fc15 will be erased
—> Package setroubleshoot.i686 0:3.0.38-1.fc15 will be erased
—> Package setroubleshoot-server.i686 0:3.0.38-1.fc15 will be erased
–> Processing Dependency: setroubleshoot-server >= 3.0.23-1 for package: setroubleshoot-plugins-3.0.14-2.fc15.noarch
—> Package shared-color-profiles.noarch 0:0.1.4-1.fc15 will be erased
–> Processing Dependency: shared-color-profiles = 0.1.4-1.fc15 for package: shared-color-profiles-extra-0.1.4-1.fc15.noarch
—> Package system-config-language.noarch 0:1.3.5-8.fc15 will be erased
—> Package system-config-network-tui.noarch 0:1.6.2-2.fc15 will be erased
—> Package system-config-users.noarch 0:1.2.107-2.fc15 will be erased
—> Package vlc.i686 0:1.1.11-1.fc15 will be erased
—> Package yum-langpacks.noarch 0:0.2.2-1.fc15 will be erased
—> Package yum-presto.noarch 0:0.6.2-3.fc15 will be erased
—> Package yum-utils.noarch 0:1.1.30-3.fc15 will be erased
–> Running transaction check
—> Package PackageKit.i686 0:0.6.17-1.fc15 will be erased
–> Processing Dependency: PackageKit = 0.6.17-1.fc15 for package: PackageKit-glib-0.6.17-1.fc15.i686
—> Package PyQt4.i686 0:4.8.3-2.fc15 will be erased
–> Processing Dependency: PyQt4 for package: anki-1.2.8-1.fc15.noarch
—> Package abrt-addon-ccpp.i686 0:2.0.3-1.fc15 will be erased
—> Package abrt-addon-python.i686 0:2.0.3-1.fc15 will be erased
—> Package abrt-gui.i686 0:2.0.3-1.fc15 will be erased
—> Package abrt-plugin-bugzilla.i686 0:2.0.3-1.fc15 will be erased
—> Package abrt-plugin-logger.i686 0:2.0.3-1.fc15 will be erased
—> Package akmod-nvidia.i686 1:280.13-2.fc15 will be erased
—> Package kde-i18n-Czech.noarch 1:3.5.10-15.fc15 will be erased
—> Package kdissert.i686 0:1.0.7-9.fc15 will be erased
—> Package phonon-backend-vlc.i686 0:0.4.0-1.fc15 will be erased
—> Package python-deltarpm.i686 0:3.6-0.6.20110223git.fc15 will be erased
—> Package qt-webkit.i686 1:4.7.3-8.fc15 will be erased
—> Package report-config-bugzilla-redhat-com.i686 0:0.22-0.fc15 will be erased
–> Processing Dependency: report-config-default for package: report-0.22-0.fc15.i686
—> Package setroubleshoot-plugins.noarch 0:3.0.14-2.fc15 will be erased
—> Package shared-color-profiles-extra.noarch 0:0.1.4-1.fc15 will be erased
–> Running transaction check
—> Package PackageKit-glib.i686 0:0.6.17-1.fc15 will be erased
–> Processing Dependency: libpackagekit-glib2.so.14 for package: gnome-settings-daemon-3.0.1-6.fc15.i686
—> Package anki.noarch 0:1.2.8-1.fc15 will be erased
—> Package report.i686 0:0.22-0.fc15 will be erased
–> Processing Dependency: report = 0.22-0.fc15 for package: report-newt-0.22-0.fc15.i686
–> Processing Dependency: report = 0.22-0.fc15 for package: report-plugin-scp-0.22-0.fc15.i686
–> Processing Dependency: report = 0.22-0.fc15 for package: report-plugin-localsave-0.22-0.fc15.i686
–> Processing Dependency: report = 0.22-0.fc15 for package: report-plugin-ftp-0.22-0.fc15.i686
–> Processing Dependency: report = 0.22-0.fc15 for package: report-gtk-0.22-0.fc15.i686
–> Running transaction check
—> Package gnome-settings-daemon.i686 0:3.0.1-6.fc15 will be erased
–> Processing Dependency: gnome-settings-daemon >= 2.21.92 for package: 1:gdm-3.0.4-1.fc15.i686
–> Processing Dependency: gnome-settings-daemon >= 2.21.91-3 for package: 1:control-center-3.0.1.1-6.fc15.i686
—> Package report-gtk.i686 0:0.22-0.fc15 will be erased
—> Package report-newt.i686 0:0.22-0.fc15 will be erased
—> Package report-plugin-ftp.i686 0:0.22-0.fc15 will be erased
–> Processing Dependency: report-plugin-ftp = 0.22-0.fc15 for package: report-config-ftp-0.22-0.fc15.i686
—> Package report-plugin-localsave.i686 0:0.22-0.fc15 will be erased
–> Processing Dependency: report-plugin-localsave = 0.22-0.fc15 for package: report-config-localsave-0.22-0.fc15.i686
—> Package report-plugin-scp.i686 0:0.22-0.fc15 will be erased
–> Processing Dependency: report-plugin-scp = 0.22-0.fc15 for package: report-config-scp-0.22-0.fc15.i686
–> Running transaction check
—> Package control-center.i686 1:3.0.1.1-6.fc15 will be erased
–> Processing Dependency: libgnome-control-center.so.1 for package: empathy-3.0.2-3.fc15.i686
–> Processing Dependency: libgnome-control-center.so.1 for package: 1:gnome-bluetooth-3.0.1-1.fc15.i686
–> Processing Dependency: control-center for package: orca-3.0.1-1.fc15.i686
–> Processing Dependency: control-center for package: 1:gnome-bluetooth-3.0.1-1.fc15.i686
—> Package gdm.i686 1:3.0.4-1.fc15 will be erased
–> Processing Dependency: libgdmsimplegreeter.so.1 for package: 1:gdm-plugin-fingerprint-3.0.4-1.fc15.i686
–> Processing Dependency: gdm for package: pulseaudio-gdm-hooks-0.9.22-5.fc15.i686
–> Processing Dependency: gdm >= 1:2.22.0 for package: pulseaudio-gdm-hooks-0.9.22-5.fc15.i686
–> Processing Dependency: gdm = 1:3.0.4-1.fc15 for package: 1:gdm-plugin-fingerprint-3.0.4-1.fc15.i686
—> Package report-config-ftp.i686 0:0.22-0.fc15 will be erased
—> Package report-config-localsave.i686 0:0.22-0.fc15 will be erased
—> Package report-config-scp.i686 0:0.22-0.fc15 will be erased
–> Running transaction check
—> Package empathy.i686 0:3.0.2-3.fc15 will be erased
—> Package gdm-plugin-fingerprint.i686 1:3.0.4-1.fc15 will be erased
—> Package gnome-bluetooth.i686 1:3.0.1-1.fc15 will be erased
–> Processing Dependency: dbus-bluez-pin-helper for package: bluez-4.87-7.fc15.i686
–> Processing Dependency: libgnome-bluetooth-applet.so.0 for package: gnome-shell-3.0.2-4.fc15.i686
—> Package orca.i686 0:3.0.1-1.fc15 will be erased
—> Package pulseaudio-gdm-hooks.i686 0:0.9.22-5.fc15 will be erased
–> Running transaction check
—> Package bluez.i686 0:4.87-7.fc15 will be erased
–> Processing Dependency: bluez >= 4.34 for package: pulseaudio-module-bluetooth-0.9.22-5.fc15.i686
—> Package gnome-shell.i686 0:3.0.2-4.fc15 will be erased
–> Processing Dependency: gnome-shell for package: gnome-panel-3.0.0.1-4.fc15.i686
–> Running transaction check
—> Package gnome-panel.i686 0:3.0.0.1-4.fc15 will be erased
–> Processing Dependency: gnome-panel for package: compiz-gnome-0.9.4-2.fc15.i686
—> Package pulseaudio-module-bluetooth.i686 0:0.9.22-5.fc15 will be erased
–> Running transaction check
—> Package compiz-gnome.i686 0:0.9.4-2.fc15 will be erased
–> Processing Dependency: compiz-gnome >= 0.9.4 for package: compizconfig-backend-gconf-0.9.4-1.fc15.i686
–> Running transaction check
—> Package compizconfig-backend-gconf.i686 0:0.9.4-1.fc15 will be erased
–> Processing Dependency: /etc/cron.d for package: crontabs-1.11-2.20101115git.fc15.noarch
–> Processing Dependency: /usr/bin/crontab for package: redhat-lsb-4.0-6.fc15.i686
–> Restarting Dependency Resolution with new changes.
–> Running transaction check
—> Package crontabs.noarch 0:1.11-2.20101115git.fc15 will be erased
–> Processing Dependency: crontabs for package: man-db-2.5.9-5.fc15.i686
—> Package redhat-lsb.i686 0:4.0-6.fc15 will be erased
–> Processing Dependency: lsb >= 4.0 for package: google-chrome-stable-13.0.782.112-95650.i386
–> Running transaction check
—> Package google-chrome-stable.i386 0:13.0.782.112-95650 will be erased
—> Package man-db.i686 0:2.5.9-5.fc15 will be erased
–> Finished Dependency Resolution
Error: Trying to remove “yum”, which is protected
** Found 38 pre-existing rpmdb problem(s), ‘yum check’ output follows:
PackageKit-0.6.17-1.fc15.i686 is a duplicate with PackageKit-0.6.16-1.fc15.i686
PackageKit-glib-0.6.17-1.fc15.i686 is a duplicate with PackageKit-glib-0.6.16-1.fc15.i686
PackageKit-yum-0.6.17-1.fc15.i686 is a duplicate with PackageKit-yum-0.6.16-1.fc15.i686
PackageKit-yum-plugin-0.6.17-1.fc15.i686 is a duplicate with PackageKit-yum-plugin-0.6.16-1.fc15.i686
compiz-fusion-extras-gnome-0.8.6-1.fc14.i686 has missing requires of compiz-fusion-extras = (‘0’, ‘0.8.6’, None)
fbreader-0.12.10-5.fc15.i686 is a duplicate with fbreader-0.12.10-4.fc15.i686
fbreader-gtk-0.12.10-5.fc15.i686 is a duplicate with fbreader-gtk-0.12.10-4.fc15.i686
glibc-2.14-5.i686 is a duplicate with glibc-2.14-4.i686
glibc-common-2.14-5.i686 is a duplicate with glibc-common-2.14-4.i686
glibc-devel-2.14-5.i686 is a duplicate with glibc-devel-2.14-4.i686
glibc-headers-2.14-5.i686 is a duplicate with glibc-headers-2.14-4.i686
google-chrome-stable-13.0.782.112-95650.i386 is a duplicate with google-chrome-stable-13.0.782.107-94237.i386
ibus-pinyin-db-android-1.3.99.20110706-2.fc15.noarch is a duplicate with ibus-pinyin-db-android-1.3.99.20110520-1.fc15.noarch
jre-1.6.0_25-fcs.i586 is a duplicate with jre-1.6.0_22-fcs.i586
6:kdelibs-common-4.6.5-2.fc15.i686 is a duplicate with 6:kdelibs-common-4.6.5-1.fc15.i686
libcurl-7.21.3-9.fc15.i686 is a duplicate with libcurl-7.21.3-8.fc15.i686
libpanelappletmm-2.26.0-2.fc12.i686 has missing requires of libpanel-applet-2.so.0
mesa-dri-drivers-7.11-1.fc15.i686 is a duplicate with mesa-dri-drivers-7.11-0.16.20110709.0.fc15.i686
mesa-dri-filesystem-7.11-1.fc15.i686 is a duplicate with mesa-dri-filesystem-7.11-0.16.20110709.0.fc15.i686
mesa-libGL-7.11-1.fc15.i686 is a duplicate with mesa-libGL-7.11-0.16.20110709.0.fc15.i686
mesa-libGLU-7.11-1.fc15.i686 is a duplicate with mesa-libGLU-7.11-0.16.20110709.0.fc15.i686
mock-1.1.12-1.fc15.noarch is a duplicate with mock-1.1.11-1.fc15.noarch
4:perl-5.12.4-160.fc15.i686 is a duplicate with 4:perl-5.12.4-159.fc15.i686
1:perl-Module-Pluggable-3.90-160.fc15.noarch is a duplicate with 1:perl-Module-Pluggable-3.90-159.fc15.noarch
1:perl-Pod-Escapes-1.04-160.fc15.noarch is a duplicate with 1:perl-Pod-Escapes-1.04-159.fc15.noarch
1:perl-Pod-Simple-3.13-160.fc15.noarch is a duplicate with 1:perl-Pod-Simple-3.13-159.fc15.noarch
4:perl-libs-5.12.4-160.fc15.i686 is a duplicate with 4:perl-libs-5.12.4-159.fc15.i686
1:qt-4.7.3-8.fc15.i686 is a duplicate with 1:qt-4.7.3-6.fc15.i686
1:qt-webkit-4.7.3-8.fc15.i686 is a duplicate with 1:qt-webkit-4.7.3-6.fc15.i686
1:qt-x11-4.7.3-8.fc15.i686 is a duplicate with 1:qt-x11-4.7.3-6.fc15.i686
2:shadow-utils-4.1.4.2-13.fc15.i686 is a duplicate with 2:shadow-utils-4.1.4.2-12.fc15.i686
system-config-lvm-1.1.16-1.fc15.noarch is a duplicate with system-config-lvm-1.1.15-2.fc15.noarch
systemtap-runtime-1.6-1.fc15.i686 is a duplicate with systemtap-runtime-1.5-8.fc15.i686
vlgothic-fonts-20110722-1.fc15.noarch is a duplicate with vlgothic-fonts-20110414-1.fc15.noarch
vlgothic-fonts-common-20110722-1.fc15.noarch is a duplicate with vlgothic-fonts-common-20110414-1.fc15.noarch
zeitgeist-0.8.1-1.fc15.noarch is a duplicate with zeitgeist-0.8.0-1.fc15.noarch
zlibrary-0.12.10-5.fc15.i686 is a duplicate with zlibrary-0.12.10-4.fc15.i686
zlibrary-ui-gtk-0.12.10-5.fc15.i686 is a duplicate with zlibrary-ui-gtk-0.12.10-4.fc15.i686

Podle me si se z nejakeho duvodu pokousel ze systemu odstranit nejaky balik, ktery je pro nej ovsem pomerne dulezity. Podle vypisu to vypada na PackageKit nebo neco nevim a to s sebou vezme i yum. Yum je ovsem oznacen jako neodstranitelny prave proto, aby nedoslo k tomu ze si ho odstranis a pak jiz nenainstalujes vubec nic, protoze yum je spravce balicku.

Pokud chces a asi bys mel, transakce zrusit pouzij
yum-complete-transaction --cleanup-only