WIFI připojení

Neptal bych se, kdybych už s tím nestrávil den. Hledal jsem hodně, ale stále mi nefunguje připojení. Přez wifi.

iwconfig eth1
eth1 unassociated ESSID:“CDMA1” Nickname:“home”
Mode:Managed Channel=0 Access Point: Not-Associated
Bit Rate=0 kb/s Tx-Power=20 dBm
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX Security mode:open
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

  • X jsem nahradil WEPkey

ifconfig eth1
eth1 Link encap:Ethernet HWadr 00:15:00:2F:EB:E8
VŠESMĚROVÉ_VYSÍLÁNÍ MULTICAST MTU:1500 Metrika:1
RX packets:23 errors:0 dropped:0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:1
kolizí:0 délka odchozí fronty:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Přerušení:233 Vstupně/Výstupní port:0x8000 Paměť:fa9ff000-fa9fffff

iwlist scanning
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

sit0 Interface doesn’t support scanning.

eth1 Scan completed :
Cell 01 - Address: 00:13:D4:24:F8:0D
ESSID:“CDMA1”
Protocol:IEEE 802.11bg
Mode:Master
Channel:1
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=84/100 Signal level=-46 dBm
IE: WPA Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Extra: Last beacon: 12ms ago

a konečně…
ifup eth1
Error for wireless request “Set Bit Rate” (8B20) :
SET failed on device eth1 ; Invalid argument.

Zjišťuji IP informace pro eth1… selhalo; chybí spojení. Je kabel v pořádku?


znova podotýkám že jsem se opravdu snažil něco najít na googlu i tady, ale nic z toho my nepomohlo. Používám ovladač ipw2200, vše nainstalované podle návodu. Zdá se být funkční.

děkuji moc za pomoc.

to ifup mi taky pro wifi nejede, takze pouzivam:

dhclient eth1

adresu pak dostanu od DHCP serveru, jinak ji lze take zadat staticky pomoci ifconfig

Skutecne ifup bych nepouzival. Staci ifconfig eth1 up nebo jak pise rivierakid dhclient eth1 pro vyzadani a nastaveni interface od DHCP.

Trochu smutne je, ze by to pak ale vypadalo ze nemuzete takto wifi startovat standardne primo pri startu system. Jeste nez bych zacal resit nejake nahradni reseni, podival bych se do /etc/sysconfig/networking/devices nebo profiles na to co se ma nastavovat pro vasi kartu. Je mozne ze bude stacit vyhodit v ifcfg-eth1 nevhodny radek s bitrate. (nevim co tam je, wifi takto nepouzivam)

http://www.linuxquestions.org/questions/showthread.php?t=241289

dhclient eth1
se provede, nevyhodí žádnou chybu, ale provede se během vteřiny a nic se pozléze neděje, takže myslím že to IP nestihne přidělit.
ifconfig eth1 up
provede se opět bez žádné chybové hlášky, ale stále nejsem připojen k síti.
ifup eth1 - ten se snaží a čeká… a posléze vyhodí chybovou hlášku
ifup eth1
Zjišťuji IP informace pro eth1… selhalo; chybí spojení. Je kabel v pořádku?

[root@localhost ~]# ifconfig
eth1 Link encap:Ethernet HWadr 00:15:00:2F:EB:E8
AKTIVOVÁNO VŠESMĚROVÉ_VYSÍLÁNÍ MULTICAST MTU:1500 Metrika:1
RX packets:1851 errors:0 dropped:0 overruns:0 frame:0
TX packets:921 errors:0 dropped:0 overruns:0 carrier:1
kolizí:0 délka odchozí fronty:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Přerušení:233 Vstupně/Výstupní port:0x8000 Paměť:fa9ff000-fa9fffff

/etc/sysconfig/networking/devices a v profiles
jsem ze souboru ifcfg-eth1 vyhodil řádek s bitrate.

zkouším všechny možné postupy jak síť nastartovat… marné.
http://www.linuxquestions.org/questions/showthread.php?t=241289

  • tento odkaz jsem také našel a z něho jsem vyčetl to ifup eth1
  • v podstatě jsem postupoval při nastavení přesně podle toho
  • ještě jsem do souborů keys-eth1 (/etc/sysconfig/networking/devices a v profiles)
    přidal řádek key=XX:XX:XX:XX

zkouším opět, přeinstalovávám ovladače, nahrávám jiné verze firmwaru. NIC. Začínám být pomalu bezradný, ale bez wifi připojení se doma neobejdu a nechci mě to donutilo k návratu k win.

O teto karte se tu uz rozebiralo pomerne rozsahle vlakno. To ze dhclient probehne behem chvilky neni nic spatneho. Pokud vam pak ale prikaz ifconfig eth1 ukaze ze jste dostal pridelenou adresu. Pokud ne, proctete si to vlakno co tu je a zkuste provest nejakou diagnostiku a nastaveni pres iwconfig. Co vidim mate Link quality 0 coz je dost divne. Nektere karty potrebuji ifconfig up aby zapnuly vysilace…

Kazdopadne tyhle karty ve Fedore jinym funguji, takze bych to nevzdaval.

Příspěvek byl upraven (05-08-06 14:07)

Nevim jestli se mi to zdá ale podle výpisu v prvním příspěvku je wifi v PC nastavena na Channel 0 , zatímco AP jede na Channel 1.

Já tu řešil problémy s ipw2200 nedávno. Problém byl v tom, že wifi připojení (nikoli signál - ve win jsem ho chytal jako dříve) náhle nezvykle zesláblo, takže se ztrácelo mnoho paketů, dokonce tolik, že mi často dhcp server na routeru ani nepřidělil IP. Má hypotéza byla, že k tomu došlo po nějakém upgradu (pravděpodobně jádra, jak tvrdil covex). Problém jsem ale vyřešil nikoli “downgradem” jádra, ale změnou nástroje pro ovládání wifi rozhraní: začal jsem používat NetworkManager, který mi, právě počínaje kernelem 2.6.17, funguje zcela bezchybně.

Ten NetworkManager je tusim jen graficka nadstavba pro GNOME, vnitrne bude asi pouzivat wpa_supplicant, ktery urcite doporucuju nainstalovat - bez nej jsou moznosti pripojeni k wifi sitim velmi slabe (defakto pouze WEP-PSK a nezabezpecena).

Taky lze zkusit nainstalovat nejnovejsi verzi ipw2200 dle navodu:
http://www.ces.clemson.edu/linux/fc2-ipw2200.shtml