Thinkpad x41 - tři problémy

Ahoj, pořídil jsem si notebook (tablet) Thinkpad X41 a mám tyto tři problémy, které se mi zatím nedaří vyřešit:

1. nefunguje mikrofón - občas slyším pískání, ale pokud ho otestuje ve Skype, tak neslyším nic

2. nefunguje bluetooth - service běží, ale když zapnu bluetooth na telefonu, tak se nic nestane (ani vlastně nevím, co se má přesně stát)

Edit: tak bluetooth funguje, stačilo ho povolit:

echo enable > /proc/acpi/ibm/bluetooth

3. nefunguje IRDA - stejné jako bluetooth

Jedná se of Fedoru 8. Bližší informace rád poskytnu. Díky

Nejsem odbornik pres thinkpady ale existuje k nim velice dobra stranka http://thinkwiki.org/wiki/Category:X41
Zkuste zda tam najdete odpoved.

Thinkwiki jsem prochazel, ale reseni problemu s tim mikrofonem jsem tam nenasel, rekl bych, ze to nejak souvisi s PulseAudio.

Tak zkuste pulse audio “vypnout”. yum remove alsa-plugins-pulseaudio

Co se týče bluetooth, tak jsem před rokem zkoušel propojit mobil s počítačem. Rozhodně to nění nic a-la plug-and-play - sice jsem nakonec slavil úspěch, ale strávil jsem na tom celé jedno odpoledne. Zkuste např. tento link. Je to sice starší, ale na FC6 mi to fungovalo…

Macky

Tak jsem to zkusil a myslim, ze to trochu pomohlo. Porad to ale ukrutne vazbi :slight_smile:

navod z odkazu mohu potvrdit i na F7
v F8 s BT nemam zadny problem

macky: u me stacilo zapnout ten bluetooth pres /proc/acpi/ibm/bluetooth a pak pres bluetooth-applet > “Browse device…” a tam uz jsem videl svuj telefon, sparovani probiha celkem bez problemu.

Napsal jsem si jeste tenhle scriptik, kterej spoustim na Fn+F5:

#!/bin/bash

F=/proc/acpi/ibm/bluetooth

if cat $F | head -n 1 | grep -q enabled ; then
        echo 'Disabling bluetooth'
        ACTION=stop
        SET=disable
else
        echo 'Enabling bluetooth'
        ACTION=start
        SET=enable
fi

service bluetooth $ACTION
echo -n $SET > $F

Tak už i Ten mikrofón funguje tak, jak má. Stačilo si pohrát s mixérem. Díky