problem s nastavenim 5.1 zvuku

Dobry den,

chci se zeptat, jak mam nastavit, aby mi aplikace jako Mplayer, Xmms, VideoLan VLC, Xine a spol. prehravali zvuk v 5.1 formatu. Hraje jenom stereo.

Kdyz zkusim speaker test: speaker-test -D plug:surround51 -c6, tak vsechny reproduktory hraji.

Mam distribuci Fedora Core 5 i586, nejnovejsi verzi jadra, zvukovou kartu Creative Labs SB Audigy LS.

Pokud potrebujete dalsi vstupni informace, rad je sdelim, pripadne je muzete nalezt v mem starsim prispevku “problem s internetovymi prohlizeci”

Dekuji za radu.

Bohuzel budu odpovidat pouze v teoreticke rovine protoze 5.1 nemam. Napr. mplayer 5.1 urcite umi, musi se mu to ovsem bud dat jako parametr, nebo nastavit v konfiguracnim souboru (vysel o tom clanek tusim v Linux+). Ostatni netusim, pravdepodobne by to chtel onejakou kouzlo s alsa.conf.

No ja pro prehravani DVD 5.1 pouzivam VLC Media Player … v nastaveni zvuku pak po spusteni filmu staci zatrhnou 5.1 a melo by to jit…

Ja s tim mam jen malou potiz, pokud to takto zapnu mam vytizeni PC na max a nestaci mi to dekodovat, zatim jsem neprisel na to, kde je chyba… kompem to urcite nemude (64bit 3000+ :)) )
Ale to bude nejspise potiz pouze u mne, Vam by to bezet melo v poho.

Pokud chces jen rozdelit stavajici stereo signal na vsechny reproduktory, muzes k tomu pouzit nejaky ALSA plug-in (nastavis si default device a v tom potom routovani toho stereo signalu na jednotlive reproduktory). Ale nedelal jsem to tak nevim…

Nejake odkazy:
http://alsa-project.org/alsa-doc/alsa-lib/pcm_plugins.html#pcm_plugins
http://www.abclinuxu.cz/slovnik/alsa