problem s mplayerom - VYRIESENE

Zdravim,
nainstaloval som si mplayer z livna repozitaru, rovnako aj mplayer-gui
Ked chcem spustit GUI verziu, natahuje ju asi 30 sekund a potom ukonci.
Z terminalu je vypis tu:

[skoro@localhost ~]$ mplayer
mplayer: symbol lookup error: /usr/lib/libavcodec.so.51: undefined symbol: faacDecOpen
[skoro@localhost ~]$

Ak viete, poradte prosim.

To vypada ze tomu chybi. nebo je rozbita nejaka zavislost. Jak si to instaloval?

yum install mplayer
a potom yum install mplayer-gui

repozitár bol livna

Zkuste to odinstalovat a nainstalovat znovu

yum remove mplayer

yum install mplayer-gui

Macky

to som skusal taktiez, bohuzial bezuspesne…

rpm -qf /usr/lib/libavcodec.so.51

Nemate nahodou nejaky balik z atrpms?

cabas, kamosovi tp delalo upne to stejny, resili sme to nakou dobu, pomohl yum update a doistalovani vsech aktualizaci - resp. prave te, ktera mela s problemem primou souvislost …

covex: z atrpms nemam nic, pouzvam len standardne repozitare + livnu

[root@pc-VDG109-1-m0 matko]# rpm -qf /usr/lib/libavcodec.so.51
ffmpeg-libs-0.4.9-0.34.20070204.lvn6
[root@pc-VDG109-1-m0 matko]#

skusal som teda odstranit to ffmpeg cez yum, uspesne, potom cez yum nainstalovat mplayer-gui, bohuzial po instalaci som zase na zaciatku problemu… t.j. tu:

[root@pc-VDG109-1-m0 matko]# mplayer
mplayer: symbol lookup error: /usr/lib/libavcodec.so.51: undefined symbol: faacDecOpen
[root@pc-VDG109-1-m0 matko]#

Zkouste jeste:

faad2-2.0-19.20050131.lvn6

[root@pc-VDG109-1-m0 matko]# yum install faad2-2.0-19.20050131.lvn6
Loading “installonlyn” plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do
[root@pc-VDG109-1-m0 matko]#

takze opat nic…

este ma tak napadlo… nemalo by to byt yum install faac? lebo na faad nenaslo nic…

yum install faad2

Pokud to napise jen “nothing to do” pak to znamena ze balik existuje ale je nainstalovany takze neni co instalovat.

Tak nakoniec som to rozchodil takto:

  • yum remove faad2
    To odstranilo ale aj VLC a aj nainstalovany (ale nefunkcny) Mplayer

  • yum install mplayer-gui --disablerepo=freshrpms

  • yum install vlc

Teraz uz bezi vsetko ako ma… Problem bol v tom, ze ak mate v systeme aj repzitar freshrpms, tak ten nainstaluje verziu faad2 2.5 s ktorou su ale problemy (pozri vyssie ake…) Preto treba faad2 instalovat len z livna repozitaru. Vtedy ide vsetko tak, ako ma…