Problem s fstab

Ahoj,
mam problem s fstab - neustale mi hlasi [mntent]: line 7 in /etc/fstab is bad. Tady je obsah souboru fstab:

This file is edited by fstab-sync - see ‘man fstab-sync’ for details

LABEL=/ / ext3 defaults 1 1
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
LABEL=x }%‘v Uús-% swap swap defaults 0 0
/dev/sda1 /media/usbdisk ntfs pamconsole,exec,noauto,managed 0 0
/dev/hdc /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0

nevite kde by mohl byt problem?
jen mozna jeste vypis z fdisku:
[root@localhost ~]# fdisk -l

Disk /dev/hda: 163.9 GB, 163928604672 bytes
255 heads, 63 sectors/track, 19929 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 1657 13309821 83 Linux
/dev/hda2 1939 16709 118648057+ f W95 Ext’d (LBA)
/dev/hda3 1658 1938 2257132+ 82 Linux swap / Solaris
/dev/hda5 1939 16709 118648026 7 HPFS/NTFS

Partition table entries are not in disk order

Disk /dev/sda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Device Boot Start End Blocks Id System
/dev/sda1 1 4863 39062016 7 HPFS/NTFS

Pokud nemáte nainstalovaný modul do jádra pro souborový systém ntfs (http://linux-ntfs.sourceforge.net/rpm), tak redhatí kernel tento souborový systém neumí. Zkuste vfat.

modul uz jsem nainstaloval dokonce se dostanu i k tomu ntfs oddilu - jen pri startu a vypinani mi to hlasi tu hlasku. Takze ted fakt nevim.
Patrik

LABEL=x }%‘v Uús-% swap swap defaults 0 0 … ten LABEL je vazne hodne divnej :slight_smile:
Zkus nastavit novy label u swap partition (prikaz mkswap). Co vypisuje “swapon -s”

Partition table entries are not in disk order … hda2 a hda3 se zdaji byt prohozeny, nechapu jak je to mozny.

Ten label swap partition je nejaky pokazeny. Bud ho zruste uplne a napiste tam /dev/neco (podle toho kde mate swap) a nebo si zmente label prikazem “mkswap -L novy_label” a pak ho zmente v /etc/fstab

ja som ho jednoducho prepisal ako ma byt, teda len som na zaciatku zrusil tie blbe vypisy a fakci to v pohode