Problem pri instalacii ati ovladacov

Pri instalacii m ivzhodi chybu

(‘package kernel-2.6.19-1.2895.fc6 is already installed’, (2, None, 0L)), (‘file /boot/System.map-2.6.19-1.2895.fc6 from install of kernel-2.6.19-1.2895.fc6 conflicts with file from package kernel-2.6.19-1.2895.fc6’, (7, ‘/boot/System.map-2.6.19-1.2895.fc6’, 0L)), (‘file /boot/config-2.6.19-1.2895.fc6 from install of kernel-2.6.19-1.2895.fc6 conflicts with file from package kernel-2.6.19-1.2895.fc6’, (7, ‘/boot/config-2.6.19-1.2895.fc6’, 0L)), (‘file /boot/symvers-2.6.19-1.2895.fc6.gz from install of kernel-2.6.19-1.2895.fc6 conflicts with file from package kernel-2.6.19-1.2895.fc6’, (7, ‘/boot/symvers-2.6.19-1.2895.fc6.gz’, 0L)), (‘file /boot/vmlinuz-2.6.19-1.2895.fc6 from install of kernel-2.6.19-1.2895.fc6 conflicts with file from package kernel-2.6.19-1.2895.fc6’, (7, ‘/boot/vmlinuz-2.6.19-1.2895.fc6’, 0L))]

co s tyn mam robit?

Ahoj,

no vypada to vcelku zajimave.

Nejdrive. Instaloval jsi ovladace z binarky stazene z ati, nebo z repozitare fedory?

Ja osobne bych nejdrive vyzkousel ti od ati stranka na stazeni je ati.amd.com (ten novy design je dosti chaoticky), a pokud by to nepomohlo, vyzkousel bych stahnout novy kernel popripade zkusit zkompilovat vlastni.

Z vypysu je jasne ze se ti krizi balicek s kernelem, ale pokud se nepletu je to jako by tam byl onen balicek 2x, mozna bug pri instalaci.

Kazdopadne dodanim noveho jadra nic nepokazis, i kdyz to tvoje je aktualni az dost.

Toto vypisalo po pokuse nainstalovat ovladace z livny, skusil som aj tie od ati a stale tam vypisuje

Missing Dependency: libexpat.so.1 is needed by package fglrx_6_8_0

taze neviem, ktore je horsie :slight_smile:

Hmm a mas zdrojaky jadra? Pokud budes testovat binarky primo od ATI je nutné je mít. Balicek se jmenuje kernel-devel.

Uz som to vzriesil, dakujem za pomoc

rudyno napsal(a):

Uz som to vzriesil, dakujem za pomoc

Mohl bys napsat, jaks to vyřešil? Mám podobný problém.

No problem bol ten ye ked som nanovo nainstaloval fedoru, tak si stiahla aktualizacie a medzi nimi aj update toho kernelu, po tejto aktuallizacii som vsetko nainstaloval okolo 189 balickov a skusil som nainstalovat ati ovladace, pri instalacii zistilo, ze musi stiahnut novu verziu kernela a ta potom prisla do konfliktu a uz som to nerozbehal. Takze som to vyriesil tak , ze som najprv hned nainstaloval na cistu instalacku fedory ovladace z depozitara livny a tato instalacka si sama stiahla potrebnu novu verziu jadra, a uz to islo, nakoniec som stiahol vsetkz aktualizacie a updaty. Takze asi tak dufam ze ti to pomoze.

Vsechny konflikty se daji opravit bez reinstalace. Protoze ale z predchozi zmeti vypisu ani z prispevku neni jasne co je vlastne nainstalovane a co s cim koliduje neni mozne ani poradit jak tu kolizi vyresit. Obecne to jde za pouziti nastroje rpm a nekterych jeho parametru jako --replacepkgs nebo --nodeps.