Přístup přes Samba na USB disk

Ahoj všichni,
mám jeden malý problém. Připojím externí disk přes USB, ten disk mám přístupný přes složku na Fedora pro čtení i zápis, vše OK. Přes sambu ho nasdílím pro ostatní, ale ve win ho mám pouze pro čtení, nedá se na něj zapsat. Nevíte někdo, co s tím? asi práva, ale už nevím, co bych kde nastavil. Ostatní standardní adresáře jsou z windows přístupné normálně. Díky moc

Sám sice nejsem přes Sambu expert, ale jestli Vám mohu poradit, hoďte se obsah souboru /etc/samba/smb.conf. Bez toho Vám pomůže maximálně kouzelník :).

Macky

PS: Je to tak, že disk máte připojený k Fedoře a přes Sambu jste ho “zviditelnil” pro Win OS užitale?

[global]

workgroup = skupina
server string = Server
security = share
encrypt passwords = yes
guest ok = no
guest account = nobody

[public]
path = /usr
writeable = yes
printable = no
create mask = 0777
directory mask = 0777
browseable = no
comment = all
guest ok = yes

[Hry]
path = /usr/games
writeable = yes
create mask = 0777
directory mask = 0777
guest ok = yes
printable = no
browseable = yes
comment = Hry

[test]
path = /media/radek
writeable = yes
create mask = 0777
directory mask = 0777
guest ok = yes
browseable = yes

Public vidět není (to jsem chtěl), hry jsou pro zápis OK, ikriminovaná záležitost je test.
A technicky to je správné, na linuxu připojeno přes USB a chtěl bych zapisovat z Win.
Díky moc za rady

Podle me to takle nepujde, protoze v dobe kdy spustis sambu, tak tam tento pripojny bod neni - resp. jeho obsah. Nejsem si jist, jak se s tim pak samba vyporada. Nezkousel si po pripojeni toho disku restartovat sambu?

Zkoušel, jediný problém je ten, že na ten disk se jakoby z win dostanu, ale nemám právo zápisu.Číst jde bez problémů. Nevím, jak nastavit na tento připojený disk práva zápisu ostatním uživatelům. Je tam pouze čtení. A u samby mám přístup bez zadávání jména a hesla …

Díky

Dokonce mám vyzkoušeno, že než připojím USB disk, tak do toho adresáře bez problémů zapíšu. Jakmile ale připojím disk, tak na ten disk nezapíšu. Asi je problém se zápisem na vfat disk pro libovolného uživatele mimo roota, který ten disk namapuje…

Jo to by mohlo. A z toho Linuxu na to zarizeni jde zapisovat? Pokud ne, ten disk vam tam automaticky pripojuje HAL/gnome-vfs, nastaveni pro vfat by mohlo jit zmenit v gconf-editor v zalozce system/storage/default options/vfat.

Tak už to jede :slight_smile:
Nastavil jsem v fstab:
/dev/sda1 /media/zalohy auto defaults,umask=0000
a do smb.conf:
[test]
path = /media/zalohy
valid users =
read only = no
guest ok = yes
a ono to jede !!!
Díky moc za pomoc…