nvidia - riva tnt2 (jen 800x600) - VYSERENO! (sem idiot)

zdravim fsechny,
dostal se mi do ruky stoj s vyse zminovanou grafarnou a za allaha se mi na nem nedari nastavit vyssi rozliseni, nez 800x600 /ovladac nvidia-legacy - “funkcni” zda se, “autoupraveni” xorg neprobehlo/ … googlil sem partu casu, hledal a zkousel dost (i divokejch modifikaci), ale porad nic :(…xorg.0.log hlasi pro nize uvedeny rozlizeni “hsync out of range a vrefr taky out of range”, chtel bych se teda zeptat kolik by to melo bejt pro 17" monitor - stacilo by mi jedno 1024x768, prip. esi mate nekdo naky special napady. napr. na modelines ci nejaky options, kterym by se to mohlo napravit? predem diky

…neco z xorgu:

Section “Device”
Identifier “Videocard0”
Driver “nvidia”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Videocard0”
DefaultDepth 24
SubSection “Display”
Depth 4
Modes “1280x1024” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 8
Modes “1280x1024” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 16
Modes “1280x1024” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 24
Modes “1280x1024” “1024x768” “800x600”
EndSubSection
EndSection

Tak v tom pripade mate spatne nebo vubec vyplnenou sekci Monitor a parametry monitoru.

Zkuste kouknout sem:
http://forum.fedora.cz/read.php?1,4971,4971#msg-4971

mno…ze este votravuju: frekvence sou nastaveny podle “Xorglogu” a “gtf” vygenerovany modelines sou pridany do sekce monitor, ale sem na to stejne - 800x600 - ani vo prd vic :confused: … pro predstavu prikladam casti:

Xorg:

Section “Monitor”
Identifier “Monitor0”
VendorName “Monitor Vendor”
ModelName “Monitor Model”
HorizSync 31.50-37.90
VertRefresh 50.00-70.00
Option “DDCmode” “on”
Option “dpms” “on”
# 1024x768 @ 75.00 Hz (GTF) hsync: 60.15 kHz; pclk: 81.80 MHz
Modeline “1024x768_75.00” 81.80 1024 1080 1192 1360 768 769 772 802 -HSync +Vsync
# 1024x768 @ 85.00 Hz (GTF) hsync: 68.60 kHz; pclk: 94.39 MHz
Modeline “1024x768_85.00” 94.39 1024 1088 1200 1376 768 769 772 807 -HSync +Vsync
EndSection

Section “Screen”
Identifier “Screen0”
Device “Videocard0”
DefaultDepth 24
SubSection “Display”
Depth 4
Modes “1280x1024” “1024x768” “800x600” “640x480”
EndSubSection
SubSection “Display”
Depth 8
Modes atd, atd…

Xorg.0.log:
(II) Loading /usr/lib/xorg/modules/libddc.so
(II) Module ddc: vendor=“X.Org Foundation”
compiled for 7.1.1, module version = 1.0.0
ABI class: X.Org Video Driver, version 1.0
(WW) NVIDIA(0): Failure reading EDID parameters for display device CRT-0
(II) NVIDIA(0): : Using default hsync range of 31.50-37.90 kHz
(II) NVIDIA(0): : Using default vrefresh range of 50.00-70.00 Hz
(II) NVIDIA(0): Clock range: 12.00 to 215.00 MHz
(II) NVIDIA(0): Not using default mode “640x350” (vrefresh out of range)
(II) NVIDIA(0): Not using default mode “320x175” (vrefresh out of range)
… … … …
(II) NVIDIA(0): Not using default mode “512x384” (hsync out of range)
(II) NVIDIA(0): Not using default mode “1024x768” (hsync out of range)
(II) NVIDIA(0): Not using default mode “512x384” (hsync out of range)
atd atd atd …

Diky moc za pripadny napady kuda

(WW) NVIDIA(0): Failure reading EDID parameters for display device CRT-0 - se mi moc nepozdava, google vyflusne par napadu, ale sou vesmes prozkouseny …

No kdybyste se podival na ten odkaz tady do fara co jsem dal do predchoziho meho prispevku tady, tak uz byste to mel vyreseny…

Covexi, omlouvam se, mel sem napsat, ze aji toto sem zkousel … a i pres option “UseEDID” “False” xorglog pise to samy, z cehoz samo nemam ubec radost, ale i tak diky!!!

A dal si to do spravne sekce? Z toho vypisu co si sem dal to vypada ze ti to nakonec skutecne bere ty hodnoty z toho xorg.conf jak je tam mas napsane, ale to je tak mozna pro LCDcko. Pro 19" CRT mam napr.:


        HorizSync    31.0 - 115.0
        VertRefresh  50.0 - 160.0

Pokud nemas manual k tomu monitoru odkud bysto opsal, koukni na ten typ monitoru na siti jesli neco nenajdes, nebo se podivej zezadu na stitek monitoru, mohl by tam rozsah frekvenci byt napsany.

mne to prijde, ze Xka pri nacitani uplne ignorujou xorg.conf bo alespon z velky casti, pac prece kdyz zakazu “UseEDID” (v sekci “device”), tak by to nemelo bejt nacitany, ale tak se nedeje … to samy s tema frekvencema, uz sem zkusil asi tisic ruznejch kombinaci …

apropos: ve spravny sekci to je …, a ty frekvence byly ve vyssich rozsazich, ale nakonec (spis ze zoufalosti) sem je nastavil podle xorglogu

vesa rozliseni 1024x768 nabizi, ale na ukor priserny frekvence (priserny:) - to ste este panove a damy nikda nevideli, pocitam tak 30 hz :slight_smile:

Tak to uz fakt nevim. Jediny co - vykaslete se na nvidia-legacy a pouzijte normalni Driver “nv” (staci prepsat v xorg.conf). Nebo na teto karte chcete honit jeste nejake 3D?

nn - na 3D nepomejslim … nv driver sem tam uz mel a je to uplne stejny … sere me to jxvina!! (pardon, ale inac uz to nejde), stravil sem na tim tri dny a uz na to nemam :), inac na fedore (linuxu) uz nakou chvili sem, ale todle mi proste hlava nebere! peknej vikend fsem!

A tam je taky ten option EDID ignorovanej? Este me napada jedna takova… hm… vec. Pred casem se mi stalo ze Xka totiz hledaji pri startu konfigurak na nekolika mistech a jedno z nich byl home roota. Jesli tam mate zkopirovanej konfigurak tak pak se muze pouzivat ten a ne ten v /etc/X11/Xorg.conf.

…tak - zapomnel sem na polozku v sekci “screen” - “monitor” “monitor0” - tot reseni celyho problemu a ja se omlouvam vsem, kteri si tim lamali hlavu, a taky panu Covexovi!! ale znate to: c´ek do toho cuci a soustredi se na jednu vec, ve ktery si mysli, ze by mohla bejt chyba a pak je to v takovyto blbosti! DIKY!