nvidia geforce2 MX ve F9

Zdravím,

potřeboval bych nainstalovat akcelerovaný ovladač staré grafické karty nvidia geforce2 MX 400.

Dle příručky je potřeba nainstalovat balíček kmod-nvidia-96xx. Ten je pouze zatím v livna-testing repozitáři. Nainstaloval jsem tedy akmod-nvidia-96xx a pomocí akmods --kernel uname -r vytvořil kmod-nvidia-96xx pro nejnovější jádro. Nainstalovalo se i několik dalších závislých balíčků. Po restartu ale nenaběhl xorg s chybou v logu

(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
dlopen: /usr/lib/xorg/modules/drivers//nvidia_drv.so: undefined symbol: AllocateScreenPrivateIndex
(EE) Failed to load /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) UnloadModule: “nvidia”
(EE) Failed to load module “nvidia” (loader failed, 7)
(II) LoadModule: “kbd”

Postup z příručky tedy v tomto případě nefunguje.

Nevíte někdo, jak na problém vyřešit?

Podle me jsou potreba dva balicky - kmod-nvidia-96xx a xorg-x11-drv-nvidia-96xx - ten druhy obsahuje onen /usr/lib/xorg/modules/drivers/nvidia_dvr.so.

Je vsak velice dobre mozne, ze tento ovladac uz s F9 fungovat nebude. V F9 je novy Xorg server a byly problemy s rozchozenim i novych ovladacu, nevmluve o tom, ze fglrx pro ati neni do dnes vubec.

I druhý balíček se nainstaloval jako jeden ze závislých.

Toto je velmi nepříjemné. To, že nefunguje akcelerace grafické karty, pak velmi degraduje systém jako takový. Nabízí se otázka, v čem je nový Xorg server tak výjimečný, že jeho nainstalováním přestane fungovat desítka starších grafických karet a zda bylo vhodné jej do distribuce zařadit? Ale toto je asi obecný problém uzavřeného kódu ovladačů od nvidie, že?

Ano je to problem s uzavrenym ovladacem. O problemech s novym Xserverem uz se hodne diskutovalo a asi to nema cenu tady znovu resit. Co muzes udelat jsou dve veci - pouzivat F8, ktera ma stary Xorg a kde to funguje, smazat v F9 Xorg server a naroubovat do nej Xorg z F8… to jde take, navody jsou na netu.