nvidia driver v FC4

Mam nainstalovanou fedoru 4 a nedari se mi zprovoznit ovladace na geforce 4.
Nainstaloval jsem ovladace a nasledne je treba upravit konf. soubor X serveru (xconf. ), zadam-li podle readme souboru dodavaneho s ovladaci do sekce “modules” prikaz load glxcore, X-server nenastartuje a vyziva me, abych mu dovolil nejakou defaultni konfiguraci. Problem je ze mi od instalace tehto driveru nefunguje nic, co pracuje pod GL rozhranim (i kdyz obnovim puvodni konfiguraci). Rad bych tedy ty ovladace nejak zprovoznil abych nemusel nejak slozite preinstalovavat nejake knihovny nebo cely system (proto jsem prece zrusil Win32).
Navic jako takova tresnicka na dortu mi dela problemy i knihovna lib-x-klavier, takze v Gnome nemohu nijak zmenit rozlozeni klaves.

Zadny module “glxcore” neni nebo o nem nevim. Moje sekce modulu vypada nasledovne:
Section “Module”
Load “dbe”
Load “extmod”
Load “fbdevhw”
Load “glx”
Load “record”
Load “freetype”
Load “type1”
Load “dri”
EndSection

Jedine co je pak potreba upravit je
Section “Device”
Identifier “Videocard0”
Driver “nvidia”
VendorName “Videocard vendor”
EndSection

Tedy zmenit zpravidla Driver “nv” na Driver “nvidia”. Vse funguje jak ma. Otestovat lze pomoci prikazu glxgears, pripadne pres glxinfo
$ glxinfo | grep rendering
direct rendering: Yes

Jak souvisi nvidia a lib-x-klavier netusim, menit klavesnici lze i pres X server. Prislusna sekce xorg.conf vypada nasledovne:
Section “InputDevice”
Identifier “Keyboard0”
Driver “kbd”
Option “XkbModel” “pc105”
Option “XkbLayout” “us,cz_qwerty”
Option “XkbOptions” “grp:shift_toggle,grp_led:scroll”
EndSection

Prepina se obema shifty. Klavesova zkratka prepinani je samozrejme konfigurovatelna a jeji syntaxi lze nalezt na netu.