nvidia-2.6.26.3-29.fc9.i686

Stáhnul jsem si kernel Fedora (2.6.26.3-29.fc9.i686) ale nevyšel ještě ovladač na grafiku nvidia kde najdu aktualiazace ?

Tezko rict ale pred chvilkou se ukazal tenhle post http://thorstenl.blogspot.com/2008/09/livna-buildsys-still-down.html. Zda se ze livna ma momenatlne nejake technicke problemy. Osobne holt furt jedu na starem jadre.

Jedu zatím taky na starém jádru ale už je to 14 dní myslel jsem že to bude v aktualiazacích a nic možná potději.

ideální je nainstalovat balík akmod-nvidia a modul pro nvidiu pro jádro se po změně jádra a restartu automaticky přeloží a není nutné čekat na kmod-nvidia. Používám a funguje bezvadně. Ten první balíček je ale taky z livny :wink:

No ja uz to cekani nejak nevydrzel, takze jsem zkusil odinstalovat kmod-nvidia a nainstalovat akmod-nvidia. Po restartu to ale chodi bohuzel jen napul. Rozchodil jsem video pres xv, ale OpenGL nejede. Vypis glxinfo skonci nasledujici chybou:

name of display: :0.0
Error: glXCreateContext failed

3 GLX Visuals
visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat

0x21 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
0x22 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
0x5b 32 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 None

32 GLXFBConfigs:
visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat

0x5c 0 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 None
0x5d 0 tc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 Slow
0x5e 0 tc 0 32 0 r y . 8 8 8 8 0 0 0 0 0 0 0 0 0 None
0x5f 0 tc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 Slow
0x60 0 tc 0 32 0 r . . 8 8 8 8 0 0 8 0 0 0 0 0 0 None
0x61 0 tc 0 32 0 r . . 8 8 8 8 0 0 8 16 16 16 16 0 0 Slow
0x62 0 tc 0 32 0 r y . 8 8 8 8 0 0 8 0 0 0 0 0 0 None
0x63 0 tc 0 32 0 r y . 8 8 8 8 0 0 8 16 16 16 16 0 0 Slow
0x64 0 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 0 0 None
0x65 0 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow
0x66 0 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 0 0 None
0x67 0 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow
0x68 0 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
0x69 0 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
0x6a 0 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
0x6b 0 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
0x6c 0 dc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 None
0x6d 0 dc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 Slow
0x6e 0 dc 0 32 0 r y . 8 8 8 8 0 0 0 0 0 0 0 0 0 None
0x6f 0 dc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 Slow
0x70 0 dc 0 32 0 r . . 8 8 8 8 0 0 8 0 0 0 0 0 0 None
0x71 0 dc 0 32 0 r . . 8 8 8 8 0 0 8 16 16 16 16 0 0 Slow
0x72 0 dc 0 32 0 r y . 8 8 8 8 0 0 8 0 0 0 0 0 0 None
0x73 0 dc 0 32 0 r y . 8 8 8 8 0 0 8 16 16 16 16 0 0 Slow
0x74 0 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 0 0 None
0x75 0 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow
0x76 0 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 0 0 None
0x77 0 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow
0x78 0 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
0x79 0 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
0x7a 0 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
0x7b 0 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow

X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 4 (X_DestroyWindow)
Resource id in failed request: 0x0
Serial number of failed request: 24
Current serial number in output stream: 26
Locking assertion failure. Backtrace:
#0 /usr/lib64/libxcb-xlib.so.0 [0x3b24e0097c]
#1 /usr/lib64/libxcb-xlib.so.0(xcb_xlib_lock+0x17) [0x3b24e00af7]
#2 /usr/lib64/libX11.so.6 [0x3b2464c610]
#3 /usr/lib64/libX11.so.6(XESetCloseDisplay+0x43) [0x3b2462e693]
#4 /usr/lib64/nvidia/libGL.so.1 [0x3a1825c7b2]

Zapomnel jsem na neco?

Počkam raděj až vyjdou aktualizace.

To pro me nebyla moznost. Pro kernel na instalacnim CD uz neni v repozitari prislusny modul a kernel 2.6.25.14-108 (pro ktery existuje posledni kmod-nvidia) uz neni v repozitari (po zmene repozitaru na updates-newkey - nevim, co bylo duvodem). Sice jsem jeho rpm nekde nasel, stahnul, nainstalil, ale bohuzel mi v nem z nejakeho duvodu nejde rozchodit sit… Grafika fungovala bez problemu, ale bez site je to na nic… Takhle muzu aspon prehravat akcelerovane filmy (coz je pro me hlavni duvod me potreby mit nainstalovane nvidia ovladace).

Tak vyhra! Trochu jsem googlil a zjistil, ze je to jen o chybejicich cestach (ModulePath) v xorg.conf. Ted mi jede vse jak ma. Muj xorg.conf tedy ted vypada nasledovne:


# Xorg configuration created by livna-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
[b]	ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
	ModulePath "/usr/lib64/xorg/modules/extensions"
	ModulePath "/usr/lib64/xorg/modules"[/b]
EndSection

Section "ServerFlags"
	Option	    "AIGLX" "on"
	Option	    "Xinerama" "0"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Lenovo"
	ModelName    "LEN L220xwC"
	HorizSync    30.0 - 75.0
	VertRefresh  50.0 - 75.0
EndSection

Section "Device"
	Identifier  "Videocard0"
	[b]Driver      "nvidia"[/b]
	VendorName  "NVIDIA Corporation"
	BoardName   "GeForce 8600 GT"
	[b]Option	    "AddARGBGLXVisuals" "True"[/b]
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	Option	    "TwinView" "0"
	Option	    "metamodes" "1920x1200 +0+0"
	SubSection "Display"
		Depth     24
	EndSubSection
EndSection

Section "Extensions"
	Option	    "Composite" "Enable"
EndSection

EDIT: Zjistil jsem, ze nic z toho nebylo treba resit rucne. Staci nainstalovat akmod-nvidia, restartovat, cimz se prelozi ovladac a pote restartovat jeste jednou, cimz se do xorg.conf pridaji prislusne ModulePath a zmeni se ovladac na nvidia.