nove jadro, nejde automount ntfs

Zdarec, …trvalo mi dost dlho, kym sa mi podarilo rozbehat NTFS, fungovalo mi to bez problemov, ale po aktualizacii jadra mi nefunguje automount a musim ich pripajat rucne, co je otravne.

v /etc/fstab mam toto. Toto mi fangovalo na starom jadre

/dev/sda1 /media/windows ntfs-3g rw,nls=utf8,umask=0000 0 0
/dev/sda5 /media/Data_D ntfs-3g rw,nls=utf8,umask=0000 0 0
/dev/sdb5 /media/Data_F ntfs-3g rw,nls=utf8,umask=0000 0 0

Vsimol som si ze uz pri starte fedory mi hodi textovu konzolu a

“Pripojenie inych suborovych systemov [ZLYHALO]” neskor
“Mount another file systems [ZLYHALO]”

Pls co tam mam zmenit aby mi to slo

Nenapsal si s jakym kernelm ti to nefunguje. kernel 2.6.22.1-33.fc7 se evidentne nepovedl: http://forum.fedora.cz/read.php?1,8939
Pouzivej starsi.

nefanguje to ani na 2.6.22.1-41.fc7

Podle me bude problem ve vygenerovanem initrd. Prvni pripojovani z fstab se mozna deje jeste v dobe, kdy neni pouzivany normalni korenovy system ale jeho nahrada z initrd (initial ram disk). Nejsem si tim samozrejme jisty, ale vysvetlovalo by to proc to nejde pri startu a potom uz ano. NTFS nemam takze to nemohu vyzkouset.

http://www.logix.cz/michal/doc/article.xp/initrd


http://forums.fedoraforum.org/showthread.php?t=98154

Aha… tak to je tim ze mate zapnuty selinux.
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249835

covex napsal(a):

Podle me bude problem ve vygenerovanem initrd.
Prvni pripojovani z fstab se mozna deje jeste v
dobe, kdy neni pouzivany normalni korenovy system
ale jeho nahrada z initrd (initial ram disk).
Nejsem si tim samozrejme jisty, ale vysvetlovalo
by to proc to nejde pri startu a potom uz ano.
NTFS nemam takze to nemohu vyzkouset.

http://www.logix.cz/michal/doc/article.xp/initrd
Initial ramdisk - Wikipedia
Firefox
54

selinux je uz aktivny pri bootovani ???

Ano, je.

velmi nerozumiem po anglicky, dalo by sa to v tom SElinuxe aj nastavit, aby nerobilo problem pri bootovani, alebo ho musim vypnut(co velmi nechcem)??

Jde udelat nekolik veci - tusim aktualizovat selinux policy z repozitare testing, dopsat pravidla sam jak je nekde popsano, zmenit selinux policy na permisive misto enforcing v nastaveni selinuxu a nebo ho uplne vypnout.
Za nejjednoduzsi povazuji 1.:
yum --enablerepo updates-testing update selinux-policy

Potvrzuji, mel jsem ted taky problemy s automountem ale po aplikaci Selinux uz vse jede jak ma. Nahral jsem taky vsechny updaty. Diky za radu. Zajimave je ze drive se starsim kernelem me to jelo…