nektere aplikace nemaji pismo

U aplikaci zacinajicich na K (Predpokladam KDE aplikace, ale mam je v menu Gnome, tak by asi meli jit spoustet a pracovat s nima i pod Gnome) se mi nezobrazuje zadne pismo.
Kiosk, Kron, Klamav, Kdat, …
A prave jsem prisel na to, ze i u OpenOffice quick starter nejsou pismenka.

Znamena to tedy ze aplikace, ikonky atd, nabehne, ale menu atd (pismenka) nevidim.

Jak je tam dostat?


Kdyz uz pisu, tak kdyz spustim spravu napajeni, tak chvilku se to zobrazi na liste a kurzor rotuje (aplikace se nacita) a pak to zmizi. ?
Mozna to ale bude souviset s tim prnim, protoze to same udela kdyz chci spustit OpenOffice (writer, calc, …).

Tak a pismenka nejsou ani v terminalu, takze ho nemuzu pouzivat, u linuxu trochu blby.
Prosim, fakt bych ocenil kdyby jste se nad tim nekdo zamysleli, ja uz jsem v koncich. Potreboval bych ten system pouzivat, ale nejak se nemuzu hnout z mista.

Doufam, ze aspon textova konzole funguje. (ctrl+alt+F1) Tam bych zkusil zadat prikaz

package-cleanup --problems

To by melo skoncit s no problems. Jo, ten prikaz je z baliku yum-utils. Nepise se neco o tech problemech v logu - /var/log/messages nebo Xorg.0.log atd.?

Moc nechapu jak k necemu takovemu muze dojit, zrejme vam chybi nejake fonty. Ja mam tyto baliky:
bitmap-fonts-0.3-5.1.2.fc7
bitstream-vera-fonts-1.10-8
dejavu-lgc-fonts-2.19-1
fontconfig-devel-2.4.2-5.fc8
fontconfig-2.4.2-5.fc8
fonts-ISO8859-2-100dpi-1.0-18.fc8
fonts-ISO8859-2-1.0-18.fc8
fonts-ISO8859-2-75dpi-1.0-18.fc8
ghostscript-fonts-5.50-18.fc8
chkfontpath-1.10.1-2.fc8
liberation-fonts-1.0-1.fc8
libfontenc-1.0.4-4.fc8
libXfontcache-1.0.4-3.fc8
libXfont-1.3.1-2.fc8
tetex-fonts-3.0-44.3.fc8
urw-fonts-2.4-3.fc8
xorg-x11-fonts-ISO8859-1-100dpi-7.2-3.fc8
xorg-x11-fonts-ISO8859-1-75dpi-7.2-3.fc8
xorg-x11-fonts-misc-7.2-3.fc8
xorg-x11-fonts-truetype-7.2-3.fc8
xorg-x11-fonts-Type1-7.2-3.fc8
xorg-x11-fonts-100dpi-7.2-3.fc8
xorg-x11-fonts-75dpi-7.2-3.fc8
xorg-x11-font-utils-7.2-2.fc8

a vsechny aplikace fonty maji.

Nejedna se o problem pouze jednoho uctu? Kdyz zalozite noveho uzivatele dela mu to taky?

package-cleanup --problems vypise no problems

logy - nic + vypis logu message-dnesni datum je dlouhy tak moc, ze bych ho snad ani sem nevypisoval a nevyznam se v nem.

fonty mam jako vy

ano, mate pravdu, dela to pouze v jednom uctu, bohuzel se jedna o ucet root.

Mam krome uctu root jeste uzivatelsky ucet, ktery bezne pouzivam a tam to nedela, do uctu root se hlasim kvuli nastavovani aplikaci, je to rychlejsi.

Takze chyba bude nekde v rootovi, ze vas napadne kde ?
(dekuji za pomoc)

Kdyz uz jsem byl v tom uzivateli, tak OpenOffice normalne spustim, nespousti se jen pod rootem, ale sprava napajeni nejde spustit ani pod rootem ani pod uzivatelem. Stve me to, protoze mi onitor vypina po 15 minutach a ja bych to rad nastavil na dyl.

A jeste jeden problem ktery nechapu v uzivateli nejde zvuk, kdyz dam ovladani hlasitosti, tak to napise:
Nenalezen zadny zasuvny modul GStreameru nebo zarizeni pro ovladani hlasitosti.

Kdyz chci nastavit zvukovku, tak to chce prava root a pod rootem zvuk funguje (nejen pri prihlaseni do X jako root, ale i kdyz se prihlasim do kterehokoliv programu jako root).

Tak to bude chyba v nastaveni neceho v adresari /root. Proste nastaveni treba presunte (aby byla zaloha) do najakeho adresare (treba /root/zaloha) - vsechny soubory a adresare zacinajici teckou. A to s tou praci pod rootem radeji nedelejte.

Michate prilis mnoho veci najednou.

ad fonty: na roota se neni potreba prihlasovat z uvodniho logiu abyste mohl menit nastaveni, staci v terminalu napsat “su -” a pote poustet dane aplikace jako uzivatel root. To zaprve. Zadruhe - zrejme je neco spatne v domovskem adresari root jako pise Kalidah. Zpusobil jste si to dost mozna prave tou praci jako root.

ad zvukovka: jedna se bohuzel existujisi problem s nekterymi zvukovymi kartami a pravy k jejich zarizeni, ktera se spatne nastavuji. Tento problem je v F8. Vzhledem k tomu ze o typ zvukove karty ste se s nami nepodelil a pouze predpokladam ze mate F8, tak reseni jsou dve - 1. aktualizovat system, pokud nemate - nektere karty jako SB Live uz jsou opravene, 2. nastavit prava pri startu systemu rucne - coz neni idealni a muze zpusobovat jine problemy.
Do /etc/rc.local si pridejte radek


chmod 0666 /dev/snd/* # workaround for kernel/hal bug in F8

Byl bych vam vdecny kdybyste uvedl kartu a potvrdil, ze i aktualizovany system ma tento zvukovy problem abysme to mohli ohlasit autorovi.

Asi toho mam moc, ale nechtel jsem zbytecne kazdou blbosti zakladat nove tema. Myslite ze bych mel?

problem pismen: skutecne pomohlo smazani konfiguracnich souboru v rootovi. Dekuji.

zustava:

  1. sprava napajeni nejde spustit ani pod rootem ani pod uzivatelem. Stve me to, protoze mi monitor vypina po 15 minutach a ja bych to rad nastavil na dyl.

  2. nejde zvukova karta pod uzivatelem - radu jsem jeste nezkousel, vyzkousim a dam vedet

zvukove karty mam v PC dve:

  1. Intel Corporation 82801EB/ER (ICH5/ICH5R) AC97 (onboard)
  2. C-Media CM8738

bezne pouzivam tu onboard, ale zkousel jsem obe a nefunguje ani jedna.

Fedora 8, plne aktualizovana.

Z konstatovani nejde spustit taky nejde zjistit co vlastne delas. Je to system->nastaveni->system->sprava napajeni?
Muzes zkusit pusit z terminalu gnome-power-preferences? Pokud nemas doinstaluj balik gnome-power-manager.

Pokud nepomuze ta zmena prav u audio zarizeni posli sem prosim
ll /dev/snd
aplay -l (jako root)
aplay -l (jako uzivatel kteremu to nejde)
lshal | grep alsa (jako uzivatel kteremu to nejde)

Ta zmena prav u audio zarizeni pomohla. Dekuju.

Sprava napajeni vypisuje tohle. Nevim co to znamena, ale haldaemona jsem vypnul, jak jsme se pred casem bavili, ze se mi automaticky pripojujou vsechny disky, tak pomohlo, kdyz jsem ho zastavil.

[redmarx@homepc ~]$ gnome-power-preferences

** (gnome-power-preferences:3043): WARNING **: DBUS error: Could not get owner of name ‘org.freedesktop.Hal’: no such name
** (gnome-power-preferences:3043): DEBUG: proxy is NULL, maybe the daemon responsible for org.freedesktop.Hal is not running?

** (gnome-power-preferences:3043): WARNING **: Either HAL or DBUS are not working!

To bude ono. Program si stezuje, ze haldaemon nebezi. Zkuste ho zapnout a uvidite, ze to zacne fungovat. Pripojovani disku zkuste vyresit jinak nez vypnutim haldaemonu.

jj, po zapnuti haldaemona funguje, jenze zase se na plose objevili ty disky a ty dostat pryc jinak nez vypnutim haldaemona nejde, tak ja ho radeji zase vypnu.

jinak, musim vyjadrit svou radost, bezi mi 3D, proprietalni ovladac ATI konecne funguje, ale nejde spustit desktop effects, je na jejich spusteni nejaky prikaz do konzoli, abych se dovedel proc ?

kdyz teda pomineme spravu napajeni, tu zapinat nehodlam, prtoze proste HAL zustane vypnuty, jak v linuxu nastavit dobu necinosti po ktere se vypne monitor ?

Uz si nepamatuju co mas s tema diskama a jesli to neslo vyresit jinak, ale HAL daemon je dnes uz velice dulezitou soucasti systemu, ktera se nepouziva jen na pripojovani disku. Jeho vypnuti nepovazuju za stastny napad. Jak nastavit dobu - hledej ServerFlags a DPMS.

Dialog 3D se podle me spousti prikazem desktop-effects.

3D vypise:
bash-3.2# desktop-effects
compiz (core) - Warn: SmcOpenConnection failed: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
compiz (core) - Fatal: No valid GL extensions string found.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0
bash-3.2#

dobu necinosti na vypnuti monitoru jsem nenasel a ni s Serverflags a DPMS

Nebyl jsem schopen ty disky vyresit jinak nez vypnutim HAL.
http://forum.fedora.cz/read.php?1,10907 - asi uprostred je to s tema diskama.

Ad 3D - evidentne ti nejde akcelerace…
Ad DPMS - man xorg.conf stiskni klavesu / a napis DPMS
Ad HAL - pokud sem nedas ty svoje upravne soubory pro hal a vypis jmen windows oddilu disku tak vic nemuzu poradit