Nefunkční pulseaudio

Dobrý den, po aktualizace nebo možná spíš po nainstalování pár věcí k alse (alsa-utils…) mi přestalo fungovat pulseaudio, přehrávače které měli nastavený na zvukový výstup pulseaudio buď nehrají vůbec, u videa jen video bez zvuku. Když se mi tohle stalo ve Fedoře 8, tak sem pulseaudio odinstaloval a znova nainstaloval, aby to opět fungovalo, ale zdá se mi to zbytečné. Nevíte někdo, jak pulseaudio opět zprovoznit bez odinstalace a znovunainstalování?

Pulseaudio se do zuvkoveho retezce zarazuje pres alsa plugin a to sice pridanim se to sekce @hooks v /etc/alsa/alsa.conf.
Neco malo zde: http://forum.fedora.cz/read.php?2,10277

Záznam v /etc/alsa/alsa.conf byl v pořádku, ale nakonec byl nějak poškozený balíček pulse plugin pro alsu, pomohla přeinstalace tohoto balíčku.

Tak tu mám opět problém s pulseaudiem. Občas přestane fungovat, někdy po několika hodinách, někdy po několika minutách, někdy hned po puštění PC někdy funguje dokud PC nevypnu.
Ve /var/log/messages jsem našel něco co by s tím mohlo souviset, ale nevím co s tím:
Jun 26 12:54:49 hp pulseaudio[2530]: pid.c: Stale PID file, overwriting.
Jun 26 12:54:49 hp pulseaudio[2530]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operace není povolena
Jun 26 12:54:49 hp pulseaudio[2530]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operace není povolena
Jun 26 12:54:52 hp gconfd (venda-2406): Resolved address “xml:readwrite:/home/venda/.gconf” to a writable configuration source at position 0
Jun 26 12:54:53 hp pulseaudio[2530]: module-x11-xsmp.c: X11 session manager not running.
Jun 26 12:54:53 hp pulseaudio[2530]: module.c: Failed to load module “module-x11-xsmp” (argument: “”): initialization failed.

Otazka je kdy se tohle vypisuje.

Stale PID bude zpusoben tim, ze pulseaudio spatne a nestaci po sobe uklidit. Pri dalsim startu pak zjisti se nebezi ale PID je stare zapsan nekde ve /var/lock apod. Ta hlaska s tim modulem mi prijde ze muze nastat tak leda pri odhlaseni kdyz se ukoncuje gnome, jinak nevim.

Možná by se mohlo někomu hodit, jak znovu nahodit pulseaudio bez restartu pokud vytuhne:
pod rootem:
killall -9 pulseaudio
pod normálním uživatelem:
pulseaudio -D

Nojo, ale proc to pulseaudio vytuhne… to neni moc pekne…

To bych také rád zjistil, ale po hledání na internetu jsem zjistil, že to nedělá jen mě. Konkrétně tenhle postup, jak pulse audio znovu nahodit, jsem našel v bugzille Opensuse.

Me se zase stava, ze pulseaudio nevytuhne, jen proste nejede zvuk. Mplayer v klidu prehrava, ale nic neni slyset.
Restart pulseaudia (viz. predchozi) nesel, protoze to nekdo drzi…

“Reseni”

  1. fuser -v /dev/snd/* /dev/dsp* … najit vsechny co to drzi
  2. killall xyz … sejmout vsechny
  3. restart pulseaudia

Konkretne u me to drzel operapluginwrap. kmix tomu nevadil.