Nefunkcne aktualizacie

Kazda aktualizacia sa normalne stiahne ale ked dojde na instalaciu skoncim s takymto hlasenim:

Component: pirut
Summary: TB2f66aac2 init.py:633:keyImportCallback:TypeError: not all arguments converted during string formatting

Traceback (most recent call last):
File “/usr/sbin/pup”, line 406, in _apply
output = self.applyChanges(self.mainwin)
File “/usr/lib/python2.5/site-packages/pirut/init.py”, line 803, in applyChanges
self.checkSignatures(dlpkgs, mainwin)
File “/usr/lib/python2.5/site-packages/pirut/init.py”, line 662, in checkSignatures
self.getKeyForPackage(po, fullaskcb = keyImportCallback)
File “/usr/lib/python2.5/site-packages/yum/init.py”, line 2177, in getKeyForPackage
“fingerprint”: fingerprint, “timestamp”: timestamp})
File “/usr/lib/python2.5/site-packages/pirut/init.py”, line 633, in keyImportCallback
“import this key?”) %(po, userid, hexkeyid, keyurl)
TypeError: not all arguments converted during string formatting

Local variables in innermost frame:
d: <gtk.MessageDialog object at 0xf084324 (GtkMessageDialog at 0xf0c1030)>
mainwin: <gtk.Window object at 0x91c5dc4 (GtkWindow at 0x92110e0)>
userid: Fedora Project fedora@redhat.com
keyurl: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
keydict: {‘timestamp’: 1067294011, ‘userid’: ‘Fedora Project fedora@redhat.com’, ‘keyurl’: ‘file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora’, ‘fingerprint’: <bound method public_key.fingerprint of <yum.pgpmsg.public_key instance at 0xf074e6c>>, ‘hexkeyid’: ‘4F2A6FD2’, ‘po’: <yum.sqlitesack.YumAvailablePackageSqlite object at 0xd765aec>}
hexkeyid: 4F2A6FD2
po: libacl - 2.2.39-12.fc8.i386

Este mi to odporuca zverejnit to na bugzille ze je to pravdepodbne bug, len ja nie som zrovna zdatny v anglictine alebo sa to da vyriesit nejako inak. Jednoducho nenainstalujem zidnu aktualizaciu pri kazdom komponente sa obmienaju viac menej podobne hlasky.

Zkuste s terminalu pustit pirut bud v anglictine nebo v cestine a to takto:
LANG=en_US.utf8 pup
nebo
LANG=cs_CZ.utf8 pup

(Mimochodem pisete ze vam nejdou aktualizace (aplikace pup), ale chyba je v aplikaci na instalaci dodatecneho sw (pirut)).
Pokud to v anglictine bude fungovat dejte sem vedet - chyba bude ve slovenske lokalizaci (predpokladam pouzivate slovenstinu).

Je to presne ako pisete vyskusal som cz aj us a oboje funguje.Dakujem

Zadal jsem jako bug:
https://bugzilla.redhat.com/show_bug.cgi?id=426197
snad se tomu nekdo z SK bude venovat.