Nastavení Wi-Fi AR242x 802.11abg

Dobrý den, mám problém s sprovozněním Wi-Fi karty na notebooku Acer Aspire 5315. Karta se nejspíš podle vípisu z lspci jmenuje Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01).
Postupoval sem podle návodu http://wiki.fedora.cz/doku.php?id=navody:hw_a_ovladace#pokud_linux_zarizeni_zna
ale zasekl jsem se u toho odstavce “Zda je ovladač pro fedoru dostupný…” V příkladu říkají že jméno ovladače pro PCI ID 168c:0013 je to madwifi. Jaké jméno je pro kartu kterou mám já? Je to Atheros?
Prosím poraďte mi kdo se v tom vyznáte, já totiž moc ne:(

Aha, takže je to madwifi, ale nevím kde bych ten ovladač pro fedoru mohl stáhnout, nikde sem ho nenašel. Nevíte prosím jak bych měl teda pokračovat? Jestli mám stáhnout ovladač pro windows a pomocí ndiswrapperu ho nainstalovat? Tak to píšou na http://ubuntuforums.org/showthread.php?t=610603&highlight=5315

madwifi je v repozitáři livna.
pokud jste ho nepřidával tak postupujte dle příručky.http://wiki.fedora.cz/doku.php?id=navody:prirucka:instalace_aplikaci&rev=1211101606
a pak už jen yum install madwifi

Děkuju za radu. Postupoval jsem jak jste napsal - přidal sem repozitář livna podle návodu, na který jste mi dal odkaz, ale po příkazu yum install madwifi mi to vypíše tohle:

[root@localhost ~]# yum install madwifi
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package madwifi.i386 0:0.9.4-1.lvn9 set to be updated
--> Processing Dependency: madwifi-kmod >= 0.9.4 for package: madwifi
--> Running transaction check
---> Package kmod-madwifi.i686 0:0.9.4-39.lvn9 set to be updated
--> Processing Dependency: kmod-madwifi-2.6.25.14-108.fc9.i686 = 0.9.4-39.lvn9 for package: kmod-madwifi
--> Running transaction check
---> Package kmod-madwifi-2.6.25.14-108.fc9.i686.i686 0:0.9.4-39.lvn9 set to be updated
--> Processing Dependency: kernel-uname-r = 2.6.25.14-108.fc9.i686 for package: kmod-madwifi-2.6.25.14-108.fc9.i686
--> Finished Dependency Resolution
kmod-madwifi-2.6.25.14-108.fc9.i686-0.9.4-39.lvn9.i686 from livna has depsolving problems
  --> Missing Dependency: kernel-uname-r = 2.6.25.14-108.fc9.i686 is needed by package kmod-madwifi-2.6.25.14-108.fc9.i686-0.9.4-39.lvn9.i686 (livna)
Error: Missing Dependency: kernel-uname-r = 2.6.25.14-108.fc9.i686 is needed by package kmod-madwifi-2.6.25.14-108.fc9.i686-0.9.4-39.lvn9.i686 (livna)
[root@localhost ~]# 

Předpokládám že to asi není tak jak by to mělo být, nevíte v čem je chyba?

Kvuli vypadku livna neni k dispozici kmod-madwifi pro posledni kernel. Zkusil bych spise “yum install akmod-madwifi”

Děkuju, tenhle příkaz proběhl bez problémů. Znamená to tedy že mám nainstalovaný ovladač k wi-fi kartě? Nevím jak to zjistím.

Jeste se musi restartovat. Akmod jsou jen zdrojaky kernel modulu. Pri startu se prelozi pro aktualni jadro - prvni start tedy bude trvat dele, ale melo by to skoncit OK. Madwifi neznam, ale melo by to byt vse. Zkus se pripojit pres NetworkManager.

S NetworkManagerem jsem se zatín nesetkal, není na něj nějaký návod na internetu?
Jinak podle jednoho návodu jsem zadal do terminálu příkazy iwlist scanning a iwconfig a výstup byl následující:


[root@notebook ~]# iwlist scanning
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

pan0      Interface doesn't support scanning.

[root@notebook ~]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

pan0      no wireless extensions.

Nevíte co je příčinou že mi nejde pořád wi-fi?

http://www.thinkwiki.org/wiki/Madwifi#Problems_on_Fedora_Core_9

Pokud jss prikaz iwconfig zadaval po restartu systemu (pri kterem by melo dijit ke kompilaci modulu ovladace madwifi), pak je to celkem divne protoze vypis neobsahuje zadne wifi zarizeni.

Krom navodu ktery odkazoval Kalidah, muzes postupovat i rucne:
lsmod - vypise zavedne ovladace - je mezi nimi ath5k? je mezi nimi ath_pci (z madwifi?)
Pokud tam ath_pci neni pak
rmmod ath5k (musi skoncit bez chyby)
modprobe ath_pci

Na konci vypisu prikazu dmesg by se mela objevit informace o detekci zarizeni Atheros. Prikaz iwconfig by jiz mel obsahovat zarizeni ath0.

NetworkManager je sluzba, ktera je standardne ve Fedore. Prikaz
service NetwrkManager start
sluzbu spusti pokud spustena neni - v gnome se objevi ikona ve stavove liste.
http://www.gnome.org/projects/NetworkManager/

Podle http://madwifi.org/ticket/1192 by mely tyto karty fungovat s madwifi-hal-0.10.5.6. To se ale musi kompilovat rucne.

Take je doporucen starsi kernel 2.6.25 misto 2.6.26

Děkuju všem, hodně jste mi pomohly už to funguje.
Na fedoraforum.org jsem našel přesný popis jak postupovat vycházející z návodu na madwifi.org. Přepíšu ho i sem pro případ že by měl někdo stejný problém jako já.

1, Otevřte soubor blacklist

sudo gedit /etc/modprobe.d/blacklist

2, Přidejte do něj následující řádek

blacklist ath5k

3, Uložte soubor, a restartujte počítač

4, Odinstalujte madwifi z livna, prý nepracuje dobře

sudo yum remove madwifi

5, Stáhněte a rozbalte tento balíček z madwifi do vašeho domovského adresáře
http://snapshots.madwifi.org/madwifi...0080903.tar.gz

6, Jděte do adresáře, který jste právě rozbalili

cd madwifi-hal-0.10.5.6-r3861-20080903

7, Jděte do adresáře scripts proveďte následující kód a jděte zase zpět

cd scripts
./madwifi-unload
./find-madwifi-modules.sh $(uname -r)
cd ..

8, Nainstalujte ovladač

make
make install

9, Tento kód můžete přeskočit, ale autor ho potřeboval aby mohl provést následující krok.

sudo /sbin/depmod -ae

10, Nyní spusťte modprobe a restartujte počítač

sudo /sbin/modprobe ath_pci

Doufám že to pomůže i někomu dalšímu.
(původně od uživatele rambo3543 na fedoraforum.org)

Upozornuji ze to bude fungovat do te doby nez se v aktualizacich objevi novy kernel. Bud tedy zakaz aktualizace kernelu, nebo se priprav na to, ze po aktualizaci budes muset kroky 7-10 opakovat.