mplayerplug-in ve FC5 - problem

Milí linuxáci,
mám problémy s rozchozením mplayeru ve firefox (verze 1.0.4.) pod FC5 (gnome). Je zajímavé, že pod FC4 to fungovalo bez problémů. Instaloval jsem nejdříve z rpm, posléze, když to nefungovalo, odinstaloval jsem plugin a jal jsem se ho kompilovat. Výsledek byl však stejný. Nakonec jsem použil k nainstalování yum (poslední verze pluginu pro FC5). Opět se stejnným výsledkem. Plugin jsem testoval pouze na stránkách ČT. Zkopíroval jsem dokonce nastavení ve FC4, ale nepomohlo to.

Popis chování:
mplayerplugin načítá playlist a pak oznámí stop, nejde však přehrát v prohlížeči. Stáhne však soubor, resp. odkaz do $HOME, kde je možno jej otevřít bez větších problémů v mplayeru. Ve stránce firefox se však nerozjede. Oproti obdobnému streamingu pod MS Windows má poněkud horší obraz, což je asi dáno kodekem. Budiž, ale proč nejede ve stránce netuším. Máte někdo podobné zkušenosti?

Poskytuji náhled do /etc/mplayerplug-in.conf

debug=1
vo=xv,x11
ao=arts,esd,oss
download=1
dload-dir=$HOME/mpp.log
keep-download=1
noembed=1
cachesize=256
use-mimetypes=1
enable-ogg=1
enable-smil=1
enable-helix=1
qt-speed=med
rtsp-use-tcp=0
nomediacache=0
framedrop=0
autosync=0
mc=1
black-background=0
user-agent=NSPlayer
a zároveň výpis z $HOME/.mplayer/mplayerplug-in.conf

vo=xv, x11
ao=arts,esd,oss
cachesize=715
cache-percent=25
dload-dir=/home/vlad/mpp.log
showtime=1
enable-wmp=1
enable-qt=0
enable-rm=1
enable-gmp=0
enable-mpeg=1
enable-mp3=0
enable-ogg=0
enable-midi=0
enable-pls=0
enable-smil=0
enable-helix=0
nomediacache=0
nopauseonhide=1
rtsp-use-tcp=0
rtsp-use-http=0

a prosím zdvořile o radu.

Tuším, že chyba bude buď:

  1. gtk1 vs. gtk2 (netuším jak řešit)
  2. chyba někde mezi gnome, firefox, FC5, ČT
  3. nějaká debilně jednoduchá skrčka v nastavení pluginu

Budu opravdu vděčný za radu, řeším to už týden bez úspěchu.

Problem je zrejme v tom, ze rpm balik z livna.org je ve FC5 jiz pouze pro firefox 1.5.x.
Jak jste vubec do FC5 dostal firefox 1.0.4 a proc pouzivate tak starou verzi?

Nainstaluj si novou verzi Firefoxu (aktualni 1.5.0.2) tam uvedeny plugin jede v poho.

Děkuji za odpověď. Nainstaloval jsem současnou verzi, ale zatím se nic nezměnilo. Tak nevím.

Nemůže to souviset s tímto problémem? (viz. níže)

All I see is the “mplayerplug-in buffering” message. What do I do?

This seems to be a very common question. Usually it means that either the video you are trying to view is unreachable by mplayer, the media is corrupt, mplayer does not have a codec to play the video, it is a misconfiguration or you have an old version of mplayer.

mplayerplug-in buffers 99% and hangs

This can becaused by a few things:

* mplayer is not in the path
* An older version of mplayer is installed
* The config option "rtsp-use-tcp=1" is set and mplayer is not compiled with the live.com support

A zkusil si to?