MagicMedia 256AV Audio - nefunkcni zvuk

Zdravím,
dostal se mi do ruky notebook HP Omnibook 900. Je to starý stroj PII 366Mhz, 160RAM, dostal jsem do toho 20GB disk…Jelikož se jedná o malý typ, 13", rozhodl jsem se ho používat do školy na psaní atd.
Podařilo se mi v něm rozjet Fedoru 6 s Xfce, jede to celkem svižně. Ted problem:

Zvukovka MagicMedia 256AV:
Ovladac se sice nacte, ale zvuk nejede. Nasel jsem o tom pomerne hodne na ubuntu forech, ale jejich reseni s blacklistem nm256 a pouzitim cs4231(ted nevim jiste) se mi nedari rozjet. Proto se chci zeptat zda neresil nekdo problem s touto zvukovkou primo ve federe.

Pokud jsem neco vynechal, rad doplnim.

Uvitam jakoukoliv radu. Diky Mira

Nejdříve lspci:
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:04.0 CardBus bridge: Texas Instruments PCI1225 (rev 01)
00:04.1 CardBus bridge: Texas Instruments PCI1225 (rev 01)
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
01:00.0 VGA compatible controller: Neomagic Corporation NM2200 [MagicGraph 256AV] (rev 12)
01:00.1 Multimedia audio controller: Neomagic Corporation NM2200 [MagicMedia 256AV Audio] (rev 12)

dmesg
pcmcia: registering new device pcmcia0.0
eth0: NE2000 (DL10019 rev 05): io 0x300, irq 3, hw_addr 00:E0:98:16:55:CF
pcmcia: registering new device pcmcia0.1
0.1: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
ACPI: PCI Interrupt 0000:01:00.1[B] -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
nm256: no ac97 is found!
force the driver to load by passing in the module parameter
force_ac97=1
or try sb16 or cs423x drivers instead.
ACPI: PCI interrupt for device 0000:01:00.1 disabled
floppy0: no floppy controllers found
PnP manual resources are invalid, using auto config
opl3sa2: can’t grab port 0x0
pnp: Device 00:09 disabled.
snd-opl3sa2-pnpbios: probe of 00:09 failed with error -16
usbcore: registered new interface driver snd-usb-audio

cat modprobe.conf:
options snd cards_limit=8
alias snd-card-0 snd-nm256
options snd-nm256 index=0
alias snd-card-1 snd-opl3sa2
options snd-opl3sa2 index=1
alias snd-card-7 snd-usb-audio
options snd-usb-audio index=7

po zadani prikazu alsamixer:
alsamixer: function snd_ctl_open failed for default: No such device

Presne tenhle notebook jsem dlouho mel a linux na nem provozoval, snad i se zvukem. (Pozor tohoto notebooku existuji dve varianty - 900 a 900B, ktere se lisi.) Navody jsem nehledal, problem je podle me ale v tom, ze v tomto notebooku je zvukovka pripojena pres ISA a nikoli pres PCI a tedy nemuze byt automaticky detekovana. Podle vypisu dmesg, ktery jste poskytl se stale snazi jadro zavest modul snd-nm256 ktery je asi spatne. Takze je potreba tento skutecne dat do /etc/modprobe.d/blacklist - proste pripiste snd-nm256 nakonec. Nevim kdo nebo co vam vytvorilo /etc/modprobe conf, ale je v tom pripade asi spatne. Misto snd-nm256 by tam zrejme melo byt snd-cs4236. Mozna to bude chtit jeste nejak poladit options. ISA karty proste nejde automaticky detekovat a parametry se musi doladit rucne. Pripadne zkuste ten modul nahrat rucne po startu systemu.