Livna a Freshrpms pro FC6

Ahoj,
kdo již máte FC6 nainstalovanou (pre-release), tak si můžete přidat repozitáře Livna a Freshrpms…

LIVNA:
stáhnout http://rpm.livna.org/fedora/development/i386/livna-release-5-6.noarch.rpm

a instalovat: rpm -ivh livna-release-5-6.noarch.rpm

FRESHRPMS:
vytvořit soubor /etc/yum.repos.d/freshrpms.repo

a vložit:
[freshrpms]
name=Fedora Core 6 - $basearch - Freshrpms
#baseurl=http://ayo.freshrpms.net/fedora/linux/$releasever/$basearch/freshrpms/
mirrorlist=http://ayo.freshrpms.net/fedora/linux/6/mirrors-freshrpms
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-freshrpms
gpgcheck=1

Díky za info.

FF=Fedora forever :wink:

Který z těch tří repozitářů mám použít? livna-development, livna nebo livna testing?

Podle toho co psal covex o repozitářích obecně tak bych tipoval že livna-development a až bude fc6 prohlášená za stabilní tak to vyměním za livna? Nebo si to označují jinak a devel, testing znamená něco jiného než u repozitářů od FC?

Nemátě někdo tip - odkaz na nějaký podrobnější vysvětlení jak je to s těmi repozitáři, co přesně který znamená, jak je používat apod?

Díky

Přesně tak, devel je pro FC6 dokud nebude oficialne vydana, pak bude fungovat normalne Livna a Livna-devel by mela byt pro FC7.

No vypadá to že devel už je pro FC 7 a normálné ještě pro FC 5, při yum update to hlasí :

Error: Missing Dependency: fedora-release >= 7 is needed by package livna-release

Když to přehodím na livna tak zase dostanu

Error: Cannot open/read repomd.xml file for repository: livna

Tak zkuste ten testing :slight_smile:

Už vím čím to je. Po nainstalováni toho rpm se sice vytvoří livno.repo a spol, ale nemůže to logicky najít žádný balíček. V configu jsou totiž mirrory zadány jako:

http://rpm.livna.org/fedora/$releasever/$basearch/

Proměnná $releasev ale mnení momentálně 6 ale 5.92. Takže stačí do livna.repo dát

http://rpm.livna.org/fedora/6/$basearch/

a mělo by to fungovat.

Aha, ja žádný problém nezaznamenal, asi to je tím, že jsem stáhl již “Pre release” verzi…

Zdravím všechny,
protože jsem absolutní začátečník potřeboval bych poradit, jak zprovoznit yum update (hlavně abych mohl nainstalovat kmod-NTFS). Postupoval jsem podle výše uvedeného postupu ale při pokudu o update se mi neustále zobrazuje chyba ve smyslu že nemám fedru 6 (mám nainstalovanou test3 verzi):
Missing Dependency: fedora-release >= 6 is needed by package livna-release

Pokud je chyba právě ve špatné verzi fedory je možné nějak upgradovat celou fedoru přes web (yum)? O délku upgradu mi až tak nejde, hlavně aby to šlapalo. Při instalaci kmod-ntfs to piše tohle:
Missing Dependency: kernel-i586 = 2.6.18-1.2747.fc6 is needed by package kmod-ntfs

Velké díky za každou dobrou radu

P.S.:docela rád bych přešel na linuxy, ale ze začátku budu potřebovat trošku poradit

Nejsem si jisty ze pro zacinajiciho uzivatele je idelani pouzivat pre-release nebo testovaci verzi - prave kuli takovymto problemum.

  1. co bych udelal je - vyhodit repozitar livna (enable=0)
  2. yum update z fedora-development repo - ti aktualizujete na posledni verzi pre-release FC6
  3. pridejte livnu a zkuste nainstalovat kmod-ntfs

Jinak vam doporucuji pockat do uterka a stahnout a nainstalovat finalni verzi FC6.

Budu muset přehazovat po nainstalování šestky něco z nastavení repozitářů? A pokud dám jenom aktualizaci - budu muset znovu doinstalovávat podporu mp3 apod?
A programy - když mám Program1.5-FC5 přepíše mi ho třeba Program1.4.5-FC6 ?

Zalezi jakym zpusobem jste instaloval FC6. (Upgrade z FC5, upgrade z FC6test atd.)

Nastaveni repozitaru snad nebude potreba menit - pokud tedy pouzivate v adresach repozitaru $releasever a $basearch. Instalace FC6 vam zmeni obsah techto dvou promennych a tim se zacnou pouzivat repozitare pro jine verze.

Pokud delate upgrade pak se muze stat ze vam v systemu zustanou baliky s mp3 podporou ale pro stare programy. Pokud spravne nastavite repozitare livna atd. yum update by vam mel aktualizovat i tyto baliky.

Co se tyce baliku vyssi verze pro FC5 tam si nejsem jist. Zalezi zda je balik soucasti core nebo ne. Pokud je v core pri upgrade se pravdepodobne prepise verzi pro FC6, pokud ho mate doinstalovany extra, bude zrejme rozhodovat cislo verze.