Fedora 8 - terminal

Zdravim, nainstaloval jsem si Fedoru 8 a nemuzu v terminalu zprovoznit copy/paste mysi. S linuxem zacinam ale na tohle jsem zvykli z prace na serverech kde funguje kopirovani vyberu pres prave tlacitko mysi pripadne nekde na konzolich pres leve+prave soucasne. Setkal jsem se i s kopirovanim pres prostredni tlacitko ale ten ve FC8 vyjede roletka a je to nemuzu nikde prenastavit :(. Zkusil jsem stahnout Terminal X ale to same. Nevite nekdo pls?

Dale mam ve FC8 problem s nastavenim klavesnice (mam prohozene Z/Y) a pres Nastaveni->klavesnice nebo Sprava->klavesnice se mi zobrazi stejne okno s prehledem vsech moznych klavesnic bez moznosti menit nejake nastaveni.

myslim, ze by mohli fungovat aj skratky Ctrl-Insert a Shift-Insert pre kopy a paste…

Pres Nastaveni->klavesnice to zmenit jde. Musite vybrat ceskou bud qwerty nebo qwertz. V gnome-terminalu mi paste funguje na prostredni tlacitko(kolecko). V menu terninalu lze upravit klavesove zkratky. V napovede je popis pouzivani mysi - anglicky.

Nastaveni -> klavesnice mi to nabidne jen Czech a Czech qwerty a to stejne pres Sprava -> klavesnice. Zatim to resim v terminalu pres
" setxkbmap cz " ale nastaveni ktere ve Fedore bylo nefunguje resp. nepamatuji si ze by mi pres tyto dve volby zobrazovalo stejne okno:(.

V nastaveni terminalu neni problem definovat klavesove zkratky ale me jde o mys kdy si jen oznacim mysi vyber a kliknutim se mi to zkopiruje.
Prostredi mam KDEcko.

V terminalu z gnome (gnome-terminal) se levym mysitkem a tazenim oznacuje (paste), kliknutim prostrednim mysitka vklada (paste) - takle to funguje a fungovalo ve vsech linuxem a unixech co sem kdy videl.

Stejne tak to funguje v kde terminalu (konsole) nebo v X terminalu (xterm). Pokud vam to funguje jinak, je chyba bohuzel jen u vas. Jedine co me napada je, ze vam xterm nejak preprideli tlacitka mysi nebo spatne nadetekuje mys.

Jako obvykle se podivejte do /var/log/Xorg.0.log a hledejte “pointer”, ja tam mam asi toto:


(WW) <default pointer>: No Device specified, looking for one...
(II) <default pointer>: Setting Device option to "/dev/input/mice"
(--) <default pointer>: Device: "/dev/input/mice"
(==) <default pointer>: Protocol: "Auto"
(**) Option "CorePointer"
(**) <default pointer>: Core Pointer
(==) <default pointer>: Emulate3Buttons, Emulate3Timeout: 50
(**) <default pointer>: ZAxisMapping: buttons 4 and 5
(**) <default pointer>: Buttons: 9
(**) <default pointer>: Sensitivity: 1
(II) XINPUT: Adding extended input device "<default pointer>" (type: MOUSE)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) <default pointer>: Setting mouse protocol to "ExplorerPS/2"
(II) <default pointer>: ps2EnableDataReporting: succeeded

Klavesnice ktere jste zminoval - Czech je qwertz, Czech qwerty je qwerty - tedy jsou to varianty s nebo bez prohozeneho Z/Y. Co jineho potrebujete? Puvodni ceska klavesnice byla qwertz ale protoze to spoustu lidi akorat stve, pouziva se spis qwerty.

Zrejme se to necha nekde nastavit, v praci mam nastaveno ve FC7 kopirovani na stisk L+P tlacitka mysi soucasne. Ted jsem si na to zvyknul a chtel bych to prenastavit. Koukal jsem do logu a tim ze ji mam pod VMwarem tak tam mam toto:

(WW) : No Device specified, looking for one…
(II) : Setting Device option to “/dev/input/mice”
(–) : Device: “/dev/input/mice”
(==) : Protocol: “Auto”
() Option “AlwaysCore”
(
) : always reports core events
(==) : Emulate3Buttons, Emulate3Timeout: 50
() : ZAxisMapping: buttons 4 and 5
(
) : Buttons: 9
(**) : Sensitivity: 1
(II) XINPUT: Adding extended input device “” (type: MOUSE)
(II) XINPUT: Adding extended input device “VMMouse” (type: MOUSE)
(II) XINPUT: Adding extended input device “Keyboard0” (type: KEYBOARD)
(II) VMWARE(0): VMMOUSE DEVICE_INIT
(II) VMWARE(0): VMMOUSE DEVICE_ON
(II) VMWARE(0): vmmouse enabled
(II) : Setting mouse protocol to “ExplorerPS/2”
(II) : ps2EnableDataReporting: succeeded

Hledal jsem nastaveni Mysi - kde se necha zmenit driver nebo neco ale jedine co jsem nasel bylo Ovladaci centrum -> Periferie -> Mys, kdy muzu nastavit motiv ukazatele, interval kliknuti aj. ptakoviny.

Klavesnici mam “Czech” ale bouzel neni qwertz ale qwerty.

jeste jednou ke klavesnici: Ja mam volbu Czechia a ta ma 4 varianty - implicitni je qwertz, pak tam jsou 2x qwerty a jeste jedna qwertz (qwertz neni popsano jako qwertz).
U 2-tlacitkove mysi lze emulovat 3. tlacitko - stiskem L+P. Toto nastaveni je v xorg.conf

S klavesnicema jsem na tom stejne. Implicitni czechia je qwertz.

Co se mysi tyce nastaveni by mohlo vypadat nejak takto:


Section "InputDevice"
       Identifier  "Mouse0"
       Driver      "mouse"
       Option      "Protocol" "IMPS/2"
       Option      "Device" "/dev/input/mice"
       Option      "ZAxisMapping" "4 5"
       Option      "Emulate3Buttons" "no"
EndSection

Uz dve verze Fedory by ale tohle v xorg.conf byt nemelo, protoze mys se detekuje automaticky. Podivejte se do sve F7 konfigurace jak a zda to tam mate nastavene a zkopirujte si sekci mouse do F8. Snad to bude fungovat.

Klavesnice jem vyresil v xorg.conf jsem mel na prvnim miste US (“XkbLayout” “us, cz”), ale proc ve Fedore s KDE nemam okno “Vlastnosti klavesnice” kde by si jen prepnul implicitni ceskou to nevim.

Kopirovani pres mys nejde. Zkusil jsem dat Emulate3Buttons na NO zadna zmena.
Zajimave je ze kdyz si otevru xterm tak tam kopirovani normalne jde pres LP tlacitko soucasne ale v klasickem terminalu nebo v X terminalu nic :(.

Aha… nejak jsem nepostrehl ze se nejedna o gnome ale o KDE… takze problem s kopirovanim mate v programu konzole v terminalu z Xfce, nikoli gnome-terminalu…

Muzes to malinko upresnit jaky soubor upravit ja jsem zadny config okolo Xfce nenasel. Dik

Ja predevsim porad nevim ve kterych terminalovych aplikacich to funguje a ve kterych ne. Tzn. kdyz pustis libovolny terminal a z nej spustis

gnome-terminal
Terminal
konsole
xterm

Tak ve kterem to funguje ve kterem ne?

Zkousel jsem ve VMwaru jeste dalsi distra a ve vsech to normalne jde.

Kopirovani mi normalne funguje pouze v xterm.
V terminalu ani konsoli ne.