Fedora 16 - nvidia 2 monitory

Mám takový zapeklitý problém, táhnoucí se od Fedory 13, kdy jsem začal používat nový notebook…

Problém:
Po každém novém startu mám rozlišení 1024x768, ať už mám v Xorg.conf zadáno cokoliv.
A pokaždé musím spustit nvidia X server settings a nastavit si nativní rozlišení ručně :frowning:

Systém:

  1. Používám proprietární ovladač nvidia (kvůli vmware workstation a ohlášené podpoře hw akcelerace)
  2. Mám NB s nativním rozlišením 1920x1080
  3. Monitor má nativní rozlišení 1920x1200
    4.Používám buď display NB nebo jen monitor.

Jakákoliv rada je vítána…

xorg.conf



# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 270.41.06  (mockbuild@hephaestus.wilsonet.com)  Sun May  1 15:55:36 EDT 2011

# RPM Fusion - nvidia-xorg.conf
# 

Section "ServerLayout"

# Removed Option "Xinerama" "0"
# Removed Option "Xinerama" "1"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout" "cz_qwerty"
    Option         "XkbModel" "pc105"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "HP LP2465"
    HorizSync       30.0 - 94.0
    VertRefresh     48.0 - 85.0
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "HP LP2465"
    HorizSync       30.0 - 94.0
    VertRefresh     48.0 - 85.0
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro FX 1800M"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro FX 1800M"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Videocard0"
    Monitor        "Monitor0"
EndSection

Section "Screen"

# Removed Option "TwinView" "0"
# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0"
# Removed Option "TwinView" "1"
# Removed Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP: nvidia-auto-select +1920+0"
# Removed Option "TwinView" "0"
# Removed Option "metamodes" "CRT: nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "DFP-2: nvidia-auto-select +0+0, DFP-2: nvidia-auto-select +1920+0"
#    option 	   DPMS
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT: nvidia-auto-select +0+0"
#    option 	   DPMS
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

nechce se mi to teď hledat, ale fedora xorg.conf defaultně ignoruje - provádí autodetekci a pro normální provoz ho většinou nepotřebuje a funguje i bez něj. Pokud xorg.conf existuje, je do něj nutné přidat instrukce, které autodetekci vypnou, tuším to bylo:

Section “ServerFlags”
Option “AutoAddDevices” “off”
Option “AutoEnableDevices” “off”

EndSection

snad to pomůže… (doby, kdy Fedora byla linux už jsou dávno pryč…)

Pro graficky mod je podle me zbytecne hned vypina autodetekci. Zkusil bych pouzit direktivu preferredmode cimz reknes ze nechces pouzivat mod na zaklade EDID. Nvidia olvadac umi jeste UseEDID “false”. Proc je edid spatne pochopen nevim - mohlo by to byt videt v Xorg.0.log. Jinak muzes zkusit si nvidia X config pridat do programu po spusteni, odhadoval bych ze to ma nejake commandline parametry, treba to pujde nastavit automaticky abys to nemusel delat rucne.

Díky za TIPy.

Nastavení obsažené v xorg.conf se rozhodně respektuje.
Preffered mode byl bez efektu.
Další pokusy co jsem našel taé bez efektu.

Při “zrušení” 2. monitoru (tzn. display NB) z xorg.conf způsobí správné rozlišení po restartu.

Holt se s touto “vlastností” budu muset smířit…

Pěkný den,
Nikilauda v.r.