Fedora 13/64 , Vaio s nVidia go7400 a 2.monitor

Ahoj lidi, vse v pohode, funguje jak ma - jen si nVidia nepamatuje nastaveni a vzdy nabehne na primarni monitor, 2. musim pres nVidia display settings vzdy opetovne nahodit. Pres live CD se mi nepodarilo vymenit config za prepsany a pri pokusu o ulozeni nastaveni napise ze nemam opravneni menit / zapisovat - prihlasen jako root a SElinux vypnuty.
Dekuju moc za kazdou radu

V tom pripade si to zrejme ukladal na to liveCD a nikolik na disk…

Dik za odpo…ne, urcite jsem ale ukladal na disk, take me toto napadlo takze jsem si to ohlidal ;o)

Jeste jednou - pres zadne distro se nepodari vymenit xorg.conf …ten spravny mam ulozeny jinde, nemuzu ho ale dostat tam kam potrebuju stejne jako livna-config…proste do etc/X11 nic nezapisu :frowning: …jdou nejak ziskat prava na takove soubory ? slysel jsem o chmod ale nevim jak to pouzit …dik

Jsou, ale pokud jsi root nemusis zadna prava menit. Napis sem presne co za chybu to pise. Je mozne ze mas system souboru pripojeni read-only. Takze vypis napr. prikazu mount by se taky hodil.

v permissions je vse “vysvicene” cili se ''read only" zmenit neda a spodni radek ve vlastnostech " You are not the owner, so you cannot change these permissions" a pri pokusu o ulozeni to proto hodi stopku s “Unable to create new X config…” …proto jsem zkousel ulozit jinam a pomoci live cd je potom vymenit mimo beh systemu…nejde to ale ani s jinou distribuci. Zmenit read only bylo asi prvni co jsem chtel udelat

To co popisuješ je vše správně. Pokud to chápu dobře, tak stačí normálně nahodit systém, otevřít terminál, hoď do něj příkaz

su -c 'nvidia-settings'

udělej změny a ulož. Nemělo by to už řvát, že nemá práva.

Ahoj a diky moooc
Vain a Covex maji u me pivko az budu v Cesku ;o)

No a oni ti celou tu dobu rikali, ze se mas prihlasit jako root ;-)))

Ale no tak, asi spatne ctes :slight_smile: zkus si nekdy ulozit nastaveni bez toho co napsal vain :slight_smile: nebo zmenit u xorg.conf permissions a prihlas se na tu vec klidne jak chces :slight_smile: a v prvnim dotazu pisu “prihlasen jako root”