FC6 - nabíhání systému

Zdravím.
Nainstaloval jsem si FC 6 (jako novou instalaci místo FC5). Vše proběhlo v pořádku. Nastavil jsem účty atd.Ukončil jsem práci a vypnul počítač. Po dalším zapnutí počítače naběhla FC pouze do režimu příkazové řádky (s hláškou pouze jako serverová instalace). Po nalogování jsem zkusil “startx” a vyhodilo to hlášku, že se jedná pouze o serverovou instalaci. Restartoval jsem proto počítač a FC naběhla normálně do grafického režimu. Tak na to koukám jako jelen a nevím, čím to může být. Těžko budu své žene vysvětlovat, že když se to stane jí, tak co musí udělat. Zkuste mi nějak poradit.
Díky.

Já včera nainstaloval 64bit a taky končí u textového loginu, a to je na Alt+F7 je rozjetá graf. konzole. Ale ještě jsem se v tom neměl čas hrabat.

Eh… tomu tedy vakt nerozumim. Chtel bych znat presne tu hlasu o tom co napisete startx.

Faktem je ze jiz nekolik lidi hlasilo, ze grafika sice nabehne, ale po dokonceni startovani se system prepne na konzoli. Je to ale zatim hlaseno pouze u karet nvidia a jeste tusim s proprietarnim ovladacem (zrejme chyba v init scriptu).

Melo by stacit se prave prepnout na Alt+F7.

To by odpovídalo, nvidii s proprietárním ovladačem mám. Ale dělalo mi to i než jsem ho nainstaloval. Dost mě to překvapilo, dojel průvodce prvním spuštěním a buch, textová konzole.

Po zadání “startx” dostanu tento výpis:
xauth: creating new authority file /root/.serverauth.2847
xauth: creating new authority file /root/.Xyuthority

Fatal server error:
Server is alredy active for display 0
If this server is no longer running, remove /tmp/.X0-lock and start again

Xlib: connection to “0.0” refused by server
Xlib: Invalid MIT-MAXIC-COOKIE-1 key giving up
xinit: unable to connect to X server
xinit: No such process (errno 3): Server error

Po Alt+F7 grafika naběhne

Fatal server error:
Server is alredy active for display 0

Tady ti to píše, že X už beží.

No vidite… tak to ale pise neco uplne jineho nez jak jste to interpretoval. Chyba je tedy v tom, ze postartu se vam obrazovka prekne do konzole ale grafika bezi = Server is alredy active for display 0

  1. nepracujte jako root
  2. grafika evidentne na alt+f7 (= :0) uz bezi
  3. pokud chcete nastartovat druhy Xserver napiste start – :1

Jinak staci Alt+F7 - pouze prepinate virtualni konzole. (mmch: Z te :0 se na :1 dostanete pomoci Alt+F8, pokud ji nastartujete.)
Uznavam ze to neni idealni, ale snad se brzy objevi oprava.

souvisí s tím tohle?
[kuba@paladin ~]$ sudo kate
Xlib: connection to “:0.0” refused by server
Xlib: No protocol specified

kate: cannot connect to X server :0.0
[kuba@paladin ~]$

Rekl bych ze ne. Pokud nepomuze Ctrl+Alt+Backspace (tedy restart Xserveru) tak pak mi melo fungovat
xhost + && sudo kate

pokud teda mate nastavene sudo, fedora neni ubuntu.

covex napsal(a):

Rekl bych ze ne. Pokud nepomuze Ctrl+Alt+Backspace
(tedy restart Xserveru) tak pak mi melo fungovat
xhost + && sudo kate

pokud teda mate nastavene sudo, fedora neni
ubuntu.

Tak ten problém je už vyřešen.
Ale stalo se mi něco podobneho co tvrdí nahoře jirg - na 32bit FC6 se mi normálně graficky bootovalo, pak to skočilo do konzole kde se objevila žádost o login a než jsem stačil cokoliv udělat, tak to skočilo zase do grafiky už normálně do výzvy o přihlášení. Divné…

To já včera zapnul FC6 64bit a stejně jako mi předevčírem najížděla po startu textová konzole, tak mi bez jakéhokoliv zásahu najíždí grafická.