FC13 x64 upgrade z FC12 - nefunguje

No tak to zase vyvojari podelali na maximum, oni jsou snad uplne padli na halvu.

Takze upgraduji: mam x86_64 asi 7 disku 1xIDE a 6x SATA … vse v RAID boot /dev/md0 / /dev/md1 zbytek jsete ve 2 sw_raid5 spojeny VLM … ale to uz FC nemusi zajimat, sytem tam neni jenom data

Takze

  1. … nenabootvalo DVD … no asi je gygabyte a LG divna, ale FC12 nabootvala … neb jsem ji upfadoval v FC11 pres DVD ;-))) … jednoduchy problem, uprava GRUB a nabootovalo.

  2. ojojoj, nastesti je tam VESA, ale co me dostalo, ze vyber upgrade to da, az mu dam disky … dal jsem mu vsechny … pak hura nasel FC12 a ze ji muzu upgradovat … aleluja

  3. Kurna, znova disky … kdyz nevyberu nic, tak nic nedela, kdyz vyberu vsechny, tak zhavaruje, kdyz vyberu cokoliv tak zhavaruje. … ERROR konec, smrt, dovoli jen debug, nebo restart …

KURVA zlaty slackware, ten nic nedetekuje, rekne mi at si to pripojim sam a upgraduje, to je vazne takovy problem se zeptat a nebo to detekovat … kdyz si ty md0 md1 delala FC sama a FS ma patricny label ?
Takze jestli vam to nejde jako mi, tak mate asi smulu a mozna to nekdy vyresi FC14 … a nebo taky ne a uz to nikdy nepujde upgradovat … boot mam jen 200MB … tak mozn jeste nepodporovany upgrade pres YUM, ktery tak nejak zhavaruje beztak a bude pokracovat instalaci z disku …
Jako ze mi nesla upgradovat FC8 na FC12 … proto, ze byla na XFS … no budiz, neni to podporovano, i kdyz instalace XFS zna … ze kdyz jsem ho k tomu donutil, ze znicil linux … budiz, mozna byla spatna i mechanika, netusim … ale ze neumi upgradovat podporovany a uplne normalni system … tak to je uz vrchol … ja fakt nevim, jak to tam ti hosi delaji … at udelaji instalaci pro profiky jako jsem ja, kde si vse pripravi, namontuji do danych adr. a rekne se ted to upgraduj … o to jsem se kdysi pokousel v modu rescue, ze jsem to pustil pak rucne na tom XFS … pak to spadlo, ale mozna kvuli mechanice.

Teda ted me napada, jak mozna nato, rezim rescue, pripojit si to a vnutit mu instalaci, mozna projde, ale jestli zase anaku*nda neco detekuje, tak mi to stejne shodi …

Upgraduj pres yum a mas po starostech s instalatorem = mas to stejny jako udpate slacku.

No uvazuji o tom, ale je to opruz, ze uz se nemuzu spolehnout, ze se mi FC upgraduje z DVD … jestli to tak pujde dal, tak budu vubec rad, ze bude fungovat instalace, abych pak nemusel zkopirovat LIVE a tu si patricne upravit … a priste uz ani ta nenabehne, hezky si spustim systemrescuecd, napokiruji FC a doladim … jeste ze ten CentOS/RHEL prozatim funguje, delat to servery, tak se picnu …

preupgrade jsi zkoušel? s tím jsem zatím moc problémů nezažil.

Souhlas, preupgrade bývá naprosto v pohodě. Jen s ním teď mám problém na jednom historickém notebooku z F11 na F13, kde instalátor po startu zahlásí, že /dev/sda1 nebyl v pořádku odpojen a že to mám nějak spravit, ale nejspíš bude problém v notebooku. Přeci jen jeho způsob hibernace/vypínání/restartů zdá se mi poněkud nešťastný.

Podle me jsou metody zalozene na mediich typu CD a DVD na ustupu. Takze je skutecne dobre mozne, ze to casem s nimi dopadne jako s floppy. Podle me zacinaji prevladat USB a sitove instalace.

No takze jsem to delal pres RPM a YUM

… znicilo mi to kernel a ac jsem daval i rucne, ze mam raid0 … tak nenabeh ;-))) … ale uz nepsal kernel panic, unable find rootfs ne co ;-))

Takze DVD mod rescue, oprava chroot /mnt… (samo ze to nic nenaslo, natkze mdadm --assembly -s --run … no a v chrootu mknod a mount /proc a sys), pri upgrade … po nejake dobe, RPM missmatch ;-)) … pak jeste par nakopirovanych lib z jineho PC (ftp demona jsem si rozjel) …
no nastesti stacilo smazat /var/lib/rpm/__* … a rpm --rpmrebuild ;-)))
pak doupgradovat pres YUM, ha novy kernel, pry grubby nema template a smazal mi grub uplne … ale laleluja, initramdisk ma v sobe jiz RAID1 etc … no teda stejne jako kdyz jsem to tvoril ja, ale tentokrat to najelo … po napsani 3 radku do grub.conf

No a mezi tim par rpm -Uv --nodeps --force ci neco odebrat s --allmatches … a tak … no uz bezim zase normalne ;-)))

… tak se mi zda, ze nebyt linux GURU tak muzu tak leda formatovat disky ;-)) … to jako vazne vsichni nemate data na SW_RAID a neco na LVM2 ? … no ja be RAID nehodlam existovat, HDD jsou za hubicku a uz mi i odesel … novy disk … no ale zadny problem ze ;-)))

No aspon ze vim co s tim ;-)))

No ale mi by nepomohla ani USB ani sitova instalace ;-)))

… a to nehovorim o tom, ze DVD FC13 mi odmitlo nabootvat … no jde to pres grub a syslinux ;-)))

Prijde mi divne ze bys jen kuli raidu mel tolik problemu. Tam musela byt jeste nejaka komplikace navic. Grubby template chybi, kdyz neni nainstalovany grub. V jake fazi se ti odinstaloval tezko rict.