FC 6 - problém se síťovkou

Zdravím.
Řeším problém se síťovou kartou Realtek RTL8168/8111. Dneska jsem si nainstaloval velice pěknou a hlavně vybavenou FC 6. Vše bylo v pohodě do doby když jsem se chtěl připojit do sítě. Zjistil jsem, že pro mou síťovou kartu není nainstalovany ovladač. Tak jsem vygooglil kromě jiného toto:
http://www.abclinuxu.cz/forum/show/136007
http://gentoo-wiki.com/HARDWARE_RTL8168
Jenže když jsem zkoušel oba dva návody tak jsem byl neúspěšný. Jsem z toho po 5 hodinách hledání jak v knihách tak na fórech docela zoufalý.
FC 6 je totiž to co potřebuji (vývojové prostředí Eclipse - Java) atd.
Tak bych někoho z Vás poprosil o nějaký lepší návod nebo odkaz na návod.
Předem děkuji za odpověď. Tomáš

Tuhle sitovku jsem na FC6 uspesne nainstaloval a navod je nekde na tomto foru. Zkuste dat hledat Realtek, RTL nebo 8111, urcite to tady najdete…

No tak jsem zkoušel to co mi doporučil rocher. viz http://forum.fedora.cz/read.php?1,4157
a všechno jsem dělal podle toho návodu…
vše v pohodě až na příkaz depmod -a tak se napíše command not found…
vygoogloval jsem si neco malo o depmod -a a taky jsem kukal do manualu, ale pokud mě oči neklamali tak tam s parametrem -a(myslímv man) nic nebylo .
Tak už nevím…
A to připojení do sítě opravdu potřebuji…
Dík,

Hm… a jako root ste se na to asi neprihlasil ze… a jste si jisty, ze ten prikaz “make install” skoncil bez “Error” nakonci? Protoze kdyz nevite jak pustit depmod pochybuju, ze mate nainstalovany kompilator a hlavickove soubory jadra bez kterych tohle bohuzel nepujde.

MMCH co to je zase za pocitace ve kterych je tato sitovka? Nejaky hit od Asusu?:slight_smile:

Tady Vám vkládám cely výpis mé práce v shellu myslím si že tam chyba není.
Jako root jsem samozřejmě přihlášen byl. Myslím si že i ten kompilátor a hlavičkové soubory mám, ale pro jistotu mi napište jestli je nějaká special cesta jak je získat bud z webu nebo z instalačního DVD, ale říkám myslím si, že je mám.
výpis:
[Tomas@b02-406a ~]$ su-
bash: su-: command not found
[Tomas@b02-406a ~]$ su
Heslo:
[root@b02-406a Tomas]# cd Desktop/
[root@b02-406a Desktop]# cd Linux/
[root@b02-406a Linux]# cd r1000_v1.05
[root@b02-406a r1000_v1.05]# ls
Makefile README release_note.txt src
[root@b02-406a r1000_v1.05]# make clean modules
make -C src/ clean
make[1]: Entering directory /home/Tomas/Desktop/Linux/r1000_v1.05/src' rm -rf *.o *.ko *~ core* .dep* .*.d .*.cmd *.mod.c *.a *.s .*.flags .tmp_versions make[1]: Leaving directory/home/Tomas/Desktop/Linux/r1000_v1.05/src’
make -C src/ modules
make[1]: Entering directory /home/Tomas/Desktop/Linux/r1000_v1.05/src' make -C /lib/modules/2.6.18-1.2798.fc6/build SUBDIRS=/home/Tomas/Desktop/Linux/r1000_v1.05/src modules make[2]: Entering directory/usr/src/kernels/2.6.18-1.2798.fc6-i586’
CC [M] /home/Tomas/Desktop/Linux/r1000_v1.05/src/r1000_n.o
CC [M] /home/Tomas/Desktop/Linux/r1000_v1.05/src/r1000_ioctl.o
LD [M] /home/Tomas/Desktop/Linux/r1000_v1.05/src/r1000.o
Building modules, stage 2.
MODPOST
CC /home/Tomas/Desktop/Linux/r1000_v1.05/src/r1000.mod.o
LD [M] /home/Tomas/Desktop/Linux/r1000_v1.05/src/r1000.ko
make[2]: Leaving directory /usr/src/kernels/2.6.18-1.2798.fc6-i586' strip --strip-debug r1000.ko make[1]: Leaving directory/home/Tomas/Desktop/Linux/r1000_v1.05/src’
[root@b02-406a r1000_v1.05]# make install
make -C src/ install
make[1]: Entering directory /home/Tomas/Desktop/Linux/r1000_v1.05/src' install -m 644 -c r1000.ko /lib/modules/2.6.18-1.2798.fc6/kernel/drivers/net/ make[1]: Leaving directory/home/Tomas/Desktop/Linux/r1000_v1.05/src’
[root@b02-406a r1000_v1.05]# depmod -a
bash: depmod: command not found
[root@b02-406a r1000_v1.05]#

Tak chyba je hned v tom prvni su. Musit to byt totiz


su -

Na tu mezeru nesmite zapomenout. Pokud date pouze


su

pak se vam nenastavi cesta pro utility ktere muze spoustet pouze root, mezi ne patri i depmod. Po prikazu “su -” se akorat nezapomente presunout do adresare s ovladacem protoze budete v home uzivatele root.

hmmm vypadá to že to pojede ale ted jsem na wifi takže nemou vyzkoušet.
Děkuji.

Problem s depmod by byl jit take vyresit nasledovne. Namisto

depmod

zadejte

/sbin/depmod

Vysvetleni naleznete zde (http://wiki.fedora.cz/doku.php?id=navody:fc6prompt) v kapitole “Promenna PATH”.

Macky

Mám také Asus A67 a zkoušel jsem nyní Fedoru 7 Test2. Chová se jako kdyby z danou síťovou kartou uměla pracovat, jenže při pokusu o připojení do sítě (ihned po zahájení pokusu získat IP z DHCP) se celá fedora totálně kousne a blíkají jen LED na klávesnici. Předpokládám, že zkoušet zde popsaný návod asi nemá smysl. Zajímavé je, že třeba Live CD s Fedorou Test 2 se na Internet v pořádku připojí. Hledal jsem nějaké řešení a nenašel.

Ještě dodám, že nainstalovaná fedora je 64bitová verze, zatímco Live CD je 32 bitové.

Tak ten rozdil architektur bude ten problem. Blikajici LED na klavesnici znamenaji chybu kernelu. V /var/log/messages byste mozna po dalsim startu nasel nejaky vypis za ktery by vam vyvojari byly vdecni v bugzille. Kazdopadne instalaci 32bitove verze o nic neprijdete.

Chybu samozřejmě nahlásím, jen pohledám kde se to dělá, když teď už vím, co popsat.

Přece jen když už mám 64bit. procesor, tak je škoda instalovat 32 bitový Linux, ne?

covex napsal(a):

/var/log/messages byste mozna po dalsim
startu nasel nejaky vypis za ktery by vam vyvojari
byly vdecni v bugzille.

Já tam tedy nic, co by mohlo vývojáům nějak pomoci nevidím, samotý pád tam vůbec není, končí to posledním restartem.
http://atom.mamto.cz/projekty/linux/messages

Tenhle vypis je ale z normalniho startu systemu a jeho regulerniho ukonceni. Starsi vypisu jsou v souboru bud predtim nebo v messages.0 atd. Neni samozrejme vylouceno, ze chyba nastane tak rychle ze se informace o ni neulozi, pokud ale blikaji diody mel by kernel byt schopen chybu zapsat.

No, byl ten soubor mod dlouhý, tak jsem ho zalohoval jinam, normálně restartoval, ověřil že si Fedora udělala soubor nový. Připojil kabel do síťovky a restartoval znovu, to už fedora nenajela, ale zůstala stát na inicializaci sítě.

Ptal jsem se ještě zde:
http://forums.fedoraforum.org/showthread.php?p=755870
Něco mi také poradili, ale zatím se to nevyřešilo.

Nejednoduzsi jak bys zjistil na co mas nastavit interface je pouzit to live CD pak opsat parametry z ifconfig (nebo toho grafickeho udelatka) na papir a prepsat je to ten x86_64 instalace. Pokud si ale aktualizoval kernel a porad to dela, tak yum update asi nepomuze.

Na bugzille ani RH ani kernelu jsem zadny bug ohledne rtl8168 nenasel. :frowning:

Už tam je a dokonce mě někdo podpořil:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=231269

Proc si to priradil k fc3test2? Jo ono pro f7test uz se musi pouziva devel ale neni to nikdo moc napsane…

Tak jsem to změnil na devel, není problém :wink: