F9 a Canon PowerShot A510

Dobrý den,

ve Fedoře 9 mi přestalo fungovat stahování fotek z foťáku Canon PowerShot A510.

Vypadá to, že se usb zařízení se připojí a pozná se foťák, ale stažení fotek se nezdaří.

V Nautilu se píše chyba: Nemohu připojit umístění Error initializing camera: -114: OS error in camera communication nebo Error initializing camera: -53: Nemohu alokovat USB zařízení

V gThumb foťák taky rozpozná, ale při importu Žádné obrázky nebyly nalezeny.

V digiKam se import zasekne na 26 % s Failed to connect to the camera. Please make sure it is connected properly and turned on. Would you like to try again?

Ve výpisu dmesg se mi moc nelíbí:
hub 1-0:1.0: unable to enumerate USB device on port 1

Na F6 vše fungovalo bezvadně.

Další informace:

[rad@eros ~]$ uname -a
Linux eros 2.6.25.9-76.fc9.x86_64 #1 SMP Fri Jun 27 15:58:30 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

[rad@eros ~]$ /sbin/lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 005: ID 04a9:30c2 Canon, Inc. PowerShot A510 (normal mode) / PowerShot A510 (PTP mode)
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

S tim vypisem v dmesg podle me nic spatne neni. S Canonem je totiz jeden problem - neni (a do dnes snad nedelaji zadne canony) jako USB Mass Storage al emaji na to nejaky svuj cupr protokol. Takze fotaky Canon se nehlasi jako normalni USB zarizeni a jadro ho tak nedokaze rozpoznat. Fotaky jako canon pak obsluhuje knihovna gphoto2.

Co ale s timto problemem ale nevim. Muze to byt spousta veci, navic mezi F6 a F9 se zmenilo hrozne moc veci. Takze leda zkusit hlasit chybu - a to bud do gphoto, nebo do fedory. Obavam se ale, ze ve Fedore moc velkou prioritu tato chyba mit nebude. :frowning:

PS: zacal bych teda tady: http://www.gphoto.org/feedback/ - zeptej se v mailing listu.

Kdo by měl podobný problém, tak se to řeší na https://bugzilla.redhat.com/show_bug.cgi?id=443515

Pomohlo nainstalování nových verzí následujících balíčků:

gphoto2-2.4.1-0.99.fc9.x86_64
libgphoto2-2.4.1-2.99.fc9.x86_64

Zatím z repozitáře Atrpms.