CURL a NTLM

Zdravim,
narazil jsem na problém. Při instalaci balíčkové libcurl (pomocí yum), knihovna nepodporuje NTLM. Chtěl bych se zeptat zda existuje způsob jak NTLM přidat bez nutnosti vlastní kompilace libcurl. Děkuji za pomoc :slight_smile:

Takovymto problemem sem se nastesti nikdy nemusel zabyvat, ale z toho co jsem nasel to vypada ze jednoduche reseni neexistuje.

Díky za odpověď, každopádně mě příliš nepotěšila.

Zdravím,

můj další dotaz spočívá v tom jak z fedory (10) odstranit libcurl. Problém je v tom že jakmile použiji yum remove libcurl označí se k odstranění 556 balíčků, což asi není správně. Poradíte mi někdo prosím? Děkuji

Na F11 je jich u me jen 162 :). Je to celkem logicke:
–> Processing Dependency: libcurl.so.4()(64bit) for package: libtunepimp-0.5.3-15.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: gnupg2-2.0.12-1.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: gmpc-0.18.0-1.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: gnupg-1.4.9-5.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: git-1.6.2.5-1.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: curl-7.19.6-1.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: audacious-plugins-1.5.1-11.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: gnome-mplayer-0.9.7-1.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: transmission-1.72-1.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: 1:openoffice.org-core-3.1.1-19.2.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: xine-ui-0.99.5-16.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: amarok-2.1.1-4.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: 1:grip-3.2.0-26.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: nspluginwrapper-1.3.0-6.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: 1:vorbis-tools-1.2.0-4.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: raptor-1.4.18-2.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: kerneloops-0.12-5.fc11.x86_64
–> Processing Dependency: libcurl.so.4()(64bit) for package: libcurl-devel-7.19.6-1.fc11.x86_64
–> Processing Dependency: libcurl = 7.19.6-1.fc11 for package: libcurl-devel-7.19.6-1.fc11.x86_64

Knihovnu vyuziva velkem mnozstvi aplikaci, takze pokud chces odstranit knihovnu, musis odstranit i aplikace ktere ji potrebuji, jinak by nefungovali, nebo aspon jejich cast.

Pokud opravu libcurl chces odstranit (a napr. nahradit vlastni) a vis co to udela, pak to samozjreme jde:
rpm -e --nodeps libcurl
Durazne upozornuji, ze tim se databaze balicku stane nekonzistentni a pokud nedodas jiny balicek s libcurl muzes cekat spoustu zajimavych veci. Pokud chces naistalovat vlastni libcurl neni potreba starou mazat, staci ji nahradit:
rpm -ivh --replacepkgs libcurl-moje