chybi zavislosti

Ahoj, pri aktualizaci me hlasi toto:
Chybí závislost: libnautilus-burn.so.4 je vyžadován balíčkem gnome-python2-nautilus-cd-burner-2.26.0-3.fc11.i586
Chybí závislost: nautilus-cd-burner-libs >= 2.15.3 je vyžadován balíčkem gnome-python2-nautilus-cd-burner-2.26.0-3.fc11.i586

Musim je rucne stahnout nainstalovat, a pak se update povede, nebo existuje zdroj SW, ktery pridam?

Hlasi Vam to taky?

Dekuji.

nautilus balicky jsou vetsinou ve standartnich repo. pockej den nebo dva a melo by to byt v poradku. pokud potrebujes nainstalovat nejake jine balicky ignoruj ty potrebujou tu zavislost.

FL

Pravdepodobne chyba synchronize zrcadla ze ktereho stahuje aktulizace, nebo se proste obe aktualizace nedostaly do updates naraz. Pouzij yum --skip-broken

Nehlasi. Oba baliky jsou normalne v repozitari fedora. Zadny jejich update nebyl, pokud vim.

Chtelo by to kosatejsi vystup toho, co vlastne delas.

Tak zde je vypis:

[hypnos@Fedora ~]$ sudo yum update 
[sudo] password for hypnos: 
Zavedeny zásuvné moduly:presto, refresh-packagekit
Uspořádává se průběh aktualizace
Řeší se závislosti
--> Spouští se kontrola transakce
---> Balíček ModemManager.i686 0:0.2-4.20091105.fc12 nastaven k/ke aktualizováno
---> Balíček NetworkManager.i686 1:0.7.996-7.git20091113.fc12 nastaven k/ke aktualizováno
---> Balíček NetworkManager-glib.i686 1:0.7.996-7.git20091113.fc12 nastaven k/ke aktualizováno
---> Balíček NetworkManager-gnome.i686 1:0.7.996-7.git20091113.fc12 nastaven k/ke aktualizováno
---> Balíček PyQt4.i686 0:4.6.2-3.fc12 nastaven k/ke aktualizováno
---> Balíček abrt.i686 0:1.0.0-1.fc12 nastaven k/ke aktualizováno
---> Balíček abrt-addon-ccpp.i686 0:1.0.0-1.fc12 nastaven k/ke aktualizováno
---> Balíček abrt-addon-kerneloops.i686 0:1.0.0-1.fc12 nastaven k/ke aktualizováno
---> Balíček abrt-addon-python.i686 0:1.0.0-1.fc12 nastaven k/ke aktualizováno
---> Balíček abrt-desktop.i686 0:1.0.0-1.fc12 nastaven k/ke aktualizováno
---> Balíček abrt-gui.i686 0:1.0.0-1.fc12 nastaven k/ke aktualizováno
---> Balíček abrt-libs.i686 0:1.0.0-1.fc12 nastaven k/ke aktualizováno
---> Balíček abrt-plugin-bugzilla.i686 0:1.0.0-1.fc12 nastaven k/ke aktualizováno
---> Balíček abrt-plugin-kerneloopsreporter.i686 0:1.0.0-1.fc12 nastaven k/ke aktualizováno
---> Balíček abrt-plugin-logger.i686 0:1.0.0-1.fc12 nastaven k/ke aktualizováno
---> Balíček abrt-plugin-sqlite3.i686 0:1.0.0-1.fc12 nastaven k/ke aktualizováno
---> Balíček bash-completion.noarch 1:1.1-3.fc12 nastaven k/ke aktualizováno
---> Balíček bind-libs.i686 32:9.6.1-13.P2.fc12 nastaven k/ke aktualizováno
---> Balíček bind-utils.i686 32:9.6.1-13.P2.fc12 nastaven k/ke aktualizováno
---> Balíček bluez.i686 0:4.58-1.fc12 nastaven k/ke aktualizováno
---> Balíček bluez-cups.i686 0:4.58-1.fc12 nastaven k/ke aktualizováno
---> Balíček bluez-libs.i686 0:4.58-1.fc12 nastaven k/ke aktualizováno
---> Balíček brasero.i686 0:2.28.2-3.fc12 nastaven k/ke aktualizováno
---> Balíček brasero-libs.i686 0:2.28.2-3.fc12 nastaven k/ke aktualizováno
---> Balíček control-center.i686 1:2.28.1-8.fc12 nastaven k/ke aktualizováno
---> Balíček control-center-filesystem.i686 1:2.28.1-8.fc12 nastaven k/ke aktualizováno
---> Balíček coreutils.i686 0:7.6-7.fc12 nastaven k/ke aktualizováno
---> Balíček coreutils-libs.i686 0:7.6-7.fc12 nastaven k/ke aktualizováno
---> Balíček crda.i686 0:1.1.0_2009.11.25-1.fc12 nastaven k/ke aktualizováno
---> Balíček cups.i686 1:1.4.2-7.fc12 nastaven k/ke aktualizováno
---> Balíček cups-libs.i686 1:1.4.2-7.fc12 nastaven k/ke aktualizováno
---> Balíček cups-pk-helper.i686 0:0.0.4-9.fc12 nastaven k/ke aktualizováno
---> Balíček empathy.i686 0:2.28.1.2-1.fc12 nastaven k/ke aktualizováno
---> Balíček empathy-libs.i686 0:2.28.1.2-1.fc12 nastaven k/ke aktualizováno
---> Balíček expat.i686 0:2.0.1-8.fc12 nastaven k/ke aktualizováno
---> Balíček fedora-usermgmt.noarch 0:0.10-1200.fc12 nastaven k/ke aktualizováno
---> Balíček fedora-usermgmt-core.noarch 0:0.10-1200.fc12 nastaven k/ke aktualizováno
---> Balíček fedora-usermgmt-default-fedora-setup.noarch 0:0.10-1200.fc12 nastaven k/ke aktualizováno
---> Balíček fedora-usermgmt-shadow-utils.noarch 0:0.10-1200.fc12 nastaven k/ke aktualizováno
---> Balíček file.i686 0:5.03-12.fc12 nastaven k/ke aktualizováno
---> Balíček file-libs.i686 0:5.03-12.fc12 nastaven k/ke aktualizováno
---> Balíček fontpackages-filesystem.noarch 0:1.41-1.fc12 nastaven k/ke aktualizováno
---> Balíček fuse.i686 0:2.8.1-3.fc12 nastaven k/ke aktualizováno
---> Balíček fuse-libs.i686 0:2.8.1-3.fc12 nastaven k/ke aktualizováno
---> Balíček gdb.i686 0:7.0-8.fc12 nastaven k/ke aktualizováno
---> Balíček glib2.i686 0:2.22.2-3.fc12 nastaven k/ke aktualizováno
---> Balíček glib2-devel.i686 0:2.22.2-3.fc12 nastaven k/ke aktualizováno
---> Balíček gmime.i686 0:2.4.11-1.fc12 nastaven k/ke aktualizováno
---> Balíček gmime-sharp.i686 0:2.4.11-1.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-commander.i686 1:1.2.8.4-1.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-desktop.i686 0:2.28.1-5.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-desktop-devel.i686 0:2.28.1-5.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-panel.i686 0:2.28.0-15.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-panel-libs.i686 0:2.28.0-15.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-python2-applet.i686 0:2.28.0-2.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-python2-brasero.i686 0:2.28.0-2.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-python2-desktop.i686 0:2.28.0-2.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-python2-gnomedesktop.i686 0:2.28.0-2.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-python2-gnomekeyring.i686 0:2.28.0-2.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-python2-gnomeprint.i686 0:2.28.0-2.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-python2-gtksourceview.i686 0:2.28.0-2.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-python2-libwnck.i686 0:2.28.0-2.fc12 nastaven k/ke aktualizováno
--> Zpracování závislosti: gnome-python2-nautilus-cd-burner pro balíček: serpentine-0.9-4.fc11.noarch
---> Balíček gnome-python2-rsvg.i686 0:2.28.0-2.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-python2-totem.i686 0:2.28.0-2.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-settings-daemon.i686 0:2.28.1-8.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-user-share.i686 0:2.28.1-3.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-utils.i686 1:2.28.1-4.fc12 nastaven k/ke aktualizováno
---> Balíček gnome-utils-libs.i686 1:2.28.1-4.fc12 nastaven k/ke aktualizováno
---> Balíček gparted.i686 0:0.4.8-1.fc12 nastaven k/ke aktualizováno
---> Balíček gpm-libs.i686 0:1.20.6-8.fc12 nastaven k/ke aktualizováno
---> Balíček grub.i686 1:0.97-62.fc12 nastaven k/ke aktualizováno
---> Balíček grubby.i686 0:7.0.9-1.fc12 nastaven k/ke aktualizováno
---> Balíček gstreamer.i686 0:0.10.25.1-1.fc12 nastaven k/ke aktualizováno
---> Balíček gstreamer-plugins-base.i686 0:0.10.25.1-1.fc12 nastaven k/ke aktualizováno
---> Balíček gstreamer-plugins-good.i686 0:0.10.17-3.fc12 nastaven k/ke aktualizováno
---> Balíček gstreamer-tools.i686 0:0.10.25.1-1.fc12 nastaven k/ke aktualizováno
---> Balíček gtk2.i686 0:2.18.3-22.fc12 nastaven k/ke aktualizováno
---> Balíček gtk2-devel.i686 0:2.18.3-22.fc12 nastaven k/ke aktualizováno
---> Balíček gvfs.i686 0:1.4.2-1.fc12 nastaven k/ke aktualizováno
---> Balíček gvfs-archive.i686 0:1.4.2-1.fc12 nastaven k/ke aktualizováno
---> Balíček gvfs-fuse.i686 0:1.4.2-1.fc12 nastaven k/ke aktualizováno
---> Balíček gvfs-gphoto2.i686 0:1.4.2-1.fc12 nastaven k/ke aktualizováno
---> Balíček gvfs-obexftp.i686 0:1.4.2-1.fc12 nastaven k/ke aktualizováno
---> Balíček gvfs-smb.i686 0:1.4.2-1.fc12 nastaven k/ke aktualizováno
---> Balíček ibus.i686 0:1.2.0.20091124-1.fc12 nastaven k/ke aktualizováno
---> Balíček ibus-gtk.i686 0:1.2.0.20091124-1.fc12 nastaven k/ke aktualizováno
---> Balíček ibus-libs.i686 0:1.2.0.20091124-1.fc12 nastaven k/ke aktualizováno
---> Balíček ibus-m17n.i686 0:1.2.0.20091120-1.fc12 nastaven k/ke aktualizováno
---> Balíček imsettings.i686 0:0.107.4-3.fc12 nastaven k/ke aktualizováno
---> Balíček imsettings-libs.i686 0:0.107.4-3.fc12 nastaven k/ke aktualizováno
---> Balíček jack-audio-connection-kit.i686 0:0.118.0-1.fc12 nastaven k/ke aktualizováno
---> Balíček kdebase-runtime.i686 0:4.3.3-5.fc12 nastaven k/ke aktualizováno
---> Balíček kdebase-runtime-libs.i686 0:4.3.3-5.fc12 nastaven k/ke aktualizováno
---> Balíček kdebase-workspace.i686 0:4.3.3-7.fc12.1 nastaven k/ke aktualizováno
---> Balíček kdebase-workspace-libs.i686 0:4.3.3-7.fc12.1 nastaven k/ke aktualizováno
---> Balíček kdelibs.i686 6:4.3.3-4.fc12 nastaven k/ke aktualizováno
---> Balíček kdelibs-common.i686 6:4.3.3-4.fc12 nastaven k/ke aktualizováno
---> Balíček kdelibs-experimental.i686 0:4.3.3-1.fc12 nastaven k/ke aktualizováno
---> Balíček kdepimlibs.i686 0:4.3.3-1.fc12 nastaven k/ke aktualizováno
---> Balíček kdm.i686 0:4.3.3-7.fc12.1 nastaven k/ke aktualizováno
---> Balíček kernel-PAE.i686 0:2.6.31.6-162.fc12 nastaven k/ke nainstalováno
---> Balíček kernel-firmware.noarch 0:2.6.31.6-162.fc12 nastaven k/ke aktualizováno
---> Balíček kernel-headers.i686 0:2.6.31.6-162.fc12 nastaven k/ke aktualizováno
---> Balíček kernel-tuxonice.i686 0:2.6.31.6-145_1.cubbi_tuxonice.fc12 nastaven k/ke nainstalováno
---> Balíček kernel-tuxonice-PAE.i686 0:2.6.31.6-145_1.cubbi_tuxonice.fc12 nastaven k/ke nainstalováno
---> Balíček kernel-tuxonice-devel.i686 0:2.6.31.6-145_1.cubbi_tuxonice.fc12 nastaven k/ke nainstalováno
---> Balíček kernel-tuxonice-firmware.i686 0:2.6.31.6-145_1.cubbi_tuxonice.fc12 nastaven k/ke aktualizováno
---> Balíček krb5-libs.i686 0:1.7-10.fc12 nastaven k/ke aktualizováno
---> Balíček krb5-workstation.i686 0:1.7-10.fc12 nastaven k/ke aktualizováno
---> Balíček ksysguardd.i686 0:4.3.3-7.fc12.1 nastaven k/ke aktualizováno
---> Balíček libblkid.i686 0:2.16-10.3.fc12 nastaven k/ke aktualizováno
---> Balíček libgudev1.i686 0:145-14.fc12 nastaven k/ke aktualizováno
---> Balíček libnotify.i686 0:0.4.5-4.fc12 nastaven k/ke aktualizováno
---> Balíček libpurple.i686 0:2.6.4-2.fc12 nastaven k/ke aktualizováno
---> Balíček libsexy.i686 0:0.1.11-13.fc12 nastaven k/ke aktualizováno
---> Balíček libsndfile.i686 0:1.0.20-3.fc12 nastaven k/ke aktualizováno
---> Balíček libudev.i686 0:145-14.fc12 nastaven k/ke aktualizováno
---> Balíček libuuid.i686 0:2.16-10.3.fc12 nastaven k/ke aktualizováno
---> Balíček libxcb.i686 0:1.4-2.fc12 nastaven k/ke aktualizováno
---> Balíček libxcb-devel.i686 0:1.4-2.fc12 nastaven k/ke aktualizováno
---> Balíček libxklavier.i686 0:4.0-6.fc12 nastaven k/ke aktualizováno
---> Balíček lohit-gujarati-fonts.noarch 0:2.4.4-1.fc12 nastaven k/ke aktualizováno
---> Balíček lohit-tamil-fonts.noarch 0:2.4.5-1.fc12 nastaven k/ke aktualizováno
---> Balíček lohit-telugu-fonts.noarch 0:2.4.5-1.fc12 nastaven k/ke aktualizováno
---> Balíček mailcap.noarch 0:2.1.31-1.fc12 nastaven k/ke aktualizováno
---> Balíček mdadm.i686 0:3.0.3-2.fc12 nastaven k/ke aktualizováno
---> Balíček metacity.i686 0:2.28.0-11.fc12 nastaven k/ke aktualizováno
---> Balíček nano.i686 0:2.0.9-4.fc12 nastaven k/ke aktualizováno
---> Balíček nautilus.i686 0:2.28.2-1.fc12 nastaven k/ke aktualizováno
---> Balíček nautilus-extensions.i686 0:2.28.2-1.fc12 nastaven k/ke aktualizováno
---> Balíček net-tools.i686 0:1.60-99.fc12 nastaven k/ke aktualizováno
---> Balíček netpbm.i686 0:10.47.04-2.fc12 nastaven k/ke aktualizováno
---> Balíček netpbm-progs.i686 0:10.47.04-2.fc12 nastaven k/ke aktualizováno
---> Balíček nspluginwrapper.i686 0:1.3.0-10.fc12 nastaven k/ke aktualizováno
---> Balíček oxygen-icon-theme.noarch 0:4.3.3-1.fc12 nastaven k/ke aktualizováno
---> Balíček papyon.noarch 0:0.4.3-1.fc12 nastaven k/ke aktualizováno
---> Balíček patch.i686 0:2.6-1.fc12 nastaven k/ke aktualizováno
---> Balíček pidgin.i686 0:2.6.4-2.fc12 nastaven k/ke aktualizováno
---> Balíček planner.i686 0:0.14.4-5.fc12 nastaven k/ke aktualizováno
---> Balíček pulseaudio.i686 0:0.9.21-1.fc12 nastaven k/ke aktualizováno
---> Balíček pulseaudio-gdm-hooks.i686 0:0.9.21-1.fc12 nastaven k/ke aktualizováno
---> Balíček pulseaudio-libs.i686 0:0.9.21-1.fc12 nastaven k/ke aktualizováno
---> Balíček pulseaudio-libs-glib2.i686 0:0.9.21-1.fc12 nastaven k/ke aktualizováno
---> Balíček pulseaudio-module-bluetooth.i686 0:0.9.21-1.fc12 nastaven k/ke aktualizováno
---> Balíček pulseaudio-utils.i686 0:0.9.21-1.fc12 nastaven k/ke aktualizováno
---> Balíček python-urlgrabber.noarch 0:3.9.1-4.fc12 nastaven k/ke aktualizováno
---> Balíček qedje.i686 0:0.4.0-4.fc12 nastaven k/ke aktualizováno
---> Balíček qzion.i686 0:0.4.0-5.fc12 nastaven k/ke aktualizováno
---> Balíček schroedinger.i686 0:1.0.8-3.fc12 nastaven k/ke aktualizováno
---> Balíček selinux-policy.noarch 0:3.6.32-49.fc12 nastaven k/ke aktualizováno
---> Balíček selinux-policy-targeted.noarch 0:3.6.32-49.fc12 nastaven k/ke aktualizováno
---> Balíček sip.i686 0:4.9.3-1.fc12 nastaven k/ke aktualizováno
---> Balíček smartmontools.i686 1:5.38-23.fc12 nastaven k/ke aktualizováno
---> Balíček sos.noarch 0:1.8-18.fc12 nastaven k/ke aktualizováno
---> Balíček sound-juicer.i686 0:2.28.1-1.fc12 nastaven k/ke aktualizováno
---> Balíček sound-theme-freedesktop.noarch 0:0.7-2.fc12 nastaven k/ke aktualizováno
---> Balíček sqlite.i686 0:3.6.20-1.fc12 nastaven k/ke aktualizováno
---> Balíček sqlite-devel.i686 0:3.6.20-1.fc12 nastaven k/ke aktualizováno
---> Balíček telepathy-butterfly.noarch 0:0.5.3-1.fc12 nastaven k/ke aktualizováno
---> Balíček telepathy-gabble.i686 0:0.8.8-2.fc12 nastaven k/ke aktualizováno
---> Balíček telepathy-mission-control.i686 1:5.2.6-1.fc12 nastaven k/ke aktualizováno
---> Balíček tree.i686 0:1.5.3-1.fc12 nastaven k/ke aktualizováno
---> Balíček udev.i686 0:145-14.fc12 nastaven k/ke aktualizováno
---> Balíček unrar.i686 0:3.8.5-3.fc12 nastaven k/ke aktualizováno
---> Balíček util-linux-ng.i686 0:2.16-10.3.fc12 nastaven k/ke aktualizováno
---> Balíček vcdimager.i686 0:0.7.23-11.fc12 nastaven k/ke aktualizováno
---> Balíček vcdimager-libs.i686 0:0.7.23-11.fc12 nastaven k/ke aktualizováno
---> Balíček vdr.i686 0:1.6.0-29.fc12 nastaven k/ke aktualizováno
---> Balíček wavemon.i686 0:0.6.10-1.fc12 nastaven k/ke aktualizováno
---> Balíček wget.i686 0:1.12-2.fc12 nastaven k/ke aktualizováno
---> Balíček wireshark.i686 0:1.2.4-1.fc12 nastaven k/ke aktualizováno
---> Balíček xorg-x11-drv-ati.i686 0:6.13.0-0.11.20091119git437113124.fc12 nastaven k/ke aktualizováno
---> Balíček xorg-x11-drv-dummy.i686 0:0.3.3-1.fc12 nastaven k/ke aktualizováno
---> Balíček xorg-x11-drv-evdev.i686 0:2.3.1-2.fc12 nastaven k/ke aktualizováno
--> Řešení závislostí dokončeno
serpentine-0.9-4.fc11.noarch z installed má problémy se závislostmi
  --> Chybí závislost: gnome-python2-nautilus-cd-burner je vyžadován balíčkem serpentine-0.9-4.fc11.noarch (installed)
--> Spouští se kontrola transakce
--> Zpracování závislosti: gnome-python2-nautilus-cd-burner pro balíček: serpentine-0.9-4.fc11.noarch
---> Balíček kernel-tuxonice-PAE.i686 0:2.6.30.8-64_1.cubbi_tuxonice.fc11 nastaven k/ke vymazáno
--> Řešení závislostí dokončeno
serpentine-0.9-4.fc11.noarch z installed má problémy se závislostmi
  --> Chybí závislost: gnome-python2-nautilus-cd-burner je vyžadován balíčkem serpentine-0.9-4.fc11.noarch (installed)
Chyba: Chybí závislost: gnome-python2-nautilus-cd-burner je vyžadován balíčkem serpentine-0.9-4.fc11.noarch (installed)
 Můžete zkusit volbu --skip-broken k překonání tohoto problému
 Můžete zkusit spustit: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Dekuji.

Edit: takze po sudo yum --skip-broken update me to pustilo dale a nyni probihaji aktualizace. Nicmene problem stale pretrvava a je to stejne.

Ted by to chtelo videt vypisy tech prikazu:
package-cleanup --problems
package-cleanup --dupes

Problem je celkem jasny - provadel si aktualizaci z F11 na F12 a v systemu ti zustaly baliky z F11 ktere zrejme nemaji v F12 nasledovnika, nebo jsou jinak sestaveny.
Vsecho se vyresi podle toho co tam je nasano - odinstalovanim serpentine-0.9-4.fc11.noarch
pote znovu update a muzes zkusit nainstlovatl serpentine pro F12.

Diky vsem, je to vyresene, diky byl jsem slepy, bude to tim, ze jsem serpentine vubec nepouzival. Na vypalovani pouzivam Brasero.

Jeste jednou dekuji a omlouvam se za moji chybu.