Bluetooth & F10 (x86_64)

Tak nám po poslední dávce aktualizací na F10 (x86_64) na všech kompech přestal jet bluetooth. Bluetooth Applet v Gnome už ani není schopný uložit jméno zařízení. Máte stejnou zkušenost?
Aktualizoval se mimo jiné dbus na novou verzi. A tak nějak z toho podezřívám jeho. Po zasunutí (nebo zapnutí na nb) bluetoothu se záznamy o něm objeví v dmesg, poslušně naskáčou drivery (btusb, bluetooth, rfcomm a pod.) ale gnome nepozná že se něco stalo. S debusem jsem zatím moc nelaoboroval, ale zkusil jsem si pustit dbus-monitor a během připojení bt se v něm nic neděje.

Jojo, může za to dbus. Downgrade na předchozí verzi zabral.

Pokud se vám stane totéž, downgrade na x86_64 lze provést třeba takto:


rpm -Uvh --oldpackage http://koji.fedoraproject.org/packages/dbus/1.2.4/1.fc10/x86_64/dbus-1.2.4-1.fc10.x86_64.rpm http://koji.fedoraproject.org/packages/dbus/1.2.4/1.fc10/x86_64/dbus-libs-1.2.4-1.fc10.x86_64.rpm http://koji.fedoraproject.org/packages/dbus/1.2.4/1.fc10/x86_64/dbus-x11-1.2.4-1.fc10.x86_64.rpm

Jen kruci nevím jak udělat aby v tom kódu byly odkazy celé a ne v těch hnusných závorkách.

Tak jsem se ještě podíval odkud se ten nový dbus vlastně vzal. Byl sestavený v pátek (5.12.) a najednou je v neděli v updates repozitáři. Tak si říkám že prošel opravdu důkladným testováním. :slight_smile:

Tak už to i někdo nahlásil. To je fofr. :slight_smile:

https://bugzilla.redhat.com/show_bug.cgi?id=475068

Dneska prisla (aspon me) poradna davka aktualizaci a je tam i dbus…

To jsou ty aktualizace co už byly puštěné v neděli. Pokud dbus zaktualizuješ, vyzkoušej prosím nějaký bluetooth. Ale on ten nový dbus způsobuje i více špatných věcí, takže si myslím že taky tak jako tak downogroadneš.

tak jsem taky provedl downgrade na předchozí verzi. Ono toho nefungovalo víc
např. system-config-samba a system-config-services nešli vubec spustit ,pouze z konzole pod rootem.

Jjj. Nakopat toho zmrda co způsobil, že páteční sestavení dbusu šlo bez prověření v neděli do update repozitáře, do prdele. Nebo lépe do stejných souřadnic opačné poloroviny.
Se zase někdo za čas nebude moc vynadivit, že někdo ztratil v linux důvěru. A komunitní manager běhá nasraný po fedoraforum.org a všem tam nadává za double-posty.

V koji už je aktualizace dbusu na 1.2.8-1 a bluez na 1.22.-2. S tím už bluetooth jede. Ale problém některých system-config… toolsů zůstává. A bůhví co dalšího ještě nepojede.

btw.: Zmrd není sprosté slovo. Viz http://www.dfens-cz.com/.

Tak nám z pana komunitního managera (Demz) vypadla tahle další perla:

newbies should know, why do you think half of us tell people to use a stable Linux OS like Ubuntu, or Mint or CentOS …to the point Fedora is NOT for Newbies

Tak jsem chtěl dnes vyzkoušet na druhém PC to grafické udělátko pro nastavení lirc
dvakrát mě to vytuhlo. Tak jsem to spustil z konzole a světe div se dbus.
takže nasledoval downgrade i na druhém PC.

tak jsem ted dal šanci té nové aktualizaci dbusu a ted jsem rychle prováděl znovu downgrade. :slight_smile:

Já začínám vážně zvažovat cross-grade. Ať si je Novell jaký je a ať si se klidně paktuje s M$, takový průser by si nedovolil udělat.
Já chci kupříkladu dceři na její nový noťas nainstalovat Linuch. A chci se stranit situacím typu “já jsem aktualizovala, protože mně systém nahlásil že jsou opraveny kritické chyby a teď to vůbec nejede”.

no nechci ti brat iluze, ale co se tyka updatu tak chyby delaji vsichni. I MS mel par aktualizaci, ktere nedelaly to co mely. Pokud chces mit stabilni pocitac tak ho do toho stavu dostan a prestan aktualizovat a nebo cekej a aktualizuj treba pouze tyden stare overene baliky kde se neukazaly chyby. Osobne bych se o bezpecnost sveho pocitace neobaval.

Je problémový update který způsobí, že něco nejede vůbec a problémový update s nějakou tou drobnou chybkou nebo nestabilitou. Tohle byl bohužel ten prvý případ.

Ať je to jak chce, někdo prostě a jednoduše obešel standardní filosofii update, která říká:

  • když už jsou s něčím dobré zkušenosti v rawhide, tak to to šoupneme do updates-testing,
  • když to nasbírá dobrou karmu v updates-testing, tak to teprve pak poleze do ostrého updates!!!

Navíc, sdělení od někoho, kdo je komunitní manažer, že Fedora není pro začátečníky je naprosté popření myšlenky, že Linux by měl být pro širší veřejnost. To je jako by tady kdokoliv na jakoukoliv otázku začátečníka napsal “Táhni smrade, Fedora je pro pokročilé”.

Nejen ze to je popreni myslenky, hlavne je to nelogicke a mozna az “spinave/lzive” tvrzeni… Fedora neni zadna vyvojarska testovaci distribuce, ale klasicke stable distro, to ze je bleeding edge a vsechno se snazi byt nejnovejsi neznamena, ze to tak musi byt za kazdou cenu (cenu stability a plne funkcnosti), neco jako znalost uzivatele systemu nema nic spolecneho s neschopnosti tuto funkcnost poskytnout, uprimne receno me timto dost nastvali, takove veci by se stavat nemeli. A kdyz uz, oprava by mela byt pokud mozno rychla a s omluvou navrch, ne svoji vinu schazovat na uzivatele.
Btw takze rikate, ze ani nova verze dbus-1.2.8 radsi jeste ne?

Se zatnutými zuby už dbus-1.2.8 jo.
Ale plus:

Ono totiž čert věz co nového tiše kdy přibude co by zase neběželo se starým dbusem.

Hm, zatim radsi pockam jak se co vyvrbi… popr. az budu mit naladu, tak si s tim zkusim pohrat na me prozatimni testovaci instalaci Fedory 10. Zatim pouzivam porad 9tku, protoze v 10tce mam problem s vykonem graficke karty.

A nebo se s aktualizovaným dbusem 1.2.8 v souboru /etc/dbus-1/system.conf vyhodí řádky:


a nahradí se

Jen je potřeba restartovat messagebus a na něm závislé služby. Takže raději restartnout celý systém.

Tak se zdá (polde fedoraforum.org), že definitivním řešením je update PolicyKitu. Zatím je jen, stejně jako souvztažné aktualizované balíčky v updates testing, takže:


yum -y update
yum -y update PolicyKit system-config-services system-config-samba *bluez* --enablerepo=updates-testing

Jen výše uvedené gnome-lirc-properties se do aktualizací ještě neprotlačilo.
Takže se zdá, že do týdne bude problém vyřešen. Jen mně pořád přijde k picnutí že dbus šel tenkrát do aktualizací hned a opravy visí poctivě v updates-testing. Na druhé straně je to tak správné. Zřejmě se zase pravidla začínají dodržovat.

Tak se oficiálně slavně vracíme k dbus 1.2.4. Tak na tohle už fakt začínám být starej.