Automaticke zvuky do sluchatek

Zdravim,
nevite jak nastavit F8 tak aby mi zvuk prepinala automaticky do sluchatek po jejich pripojeni ?
Pri pripojeni sluchatek jede porad speaker ale ve sluchatkach ani pip.
Jde o desktop HP Compaq dc7600 a je tam jako zvukovka tento hw


#lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

Uz jsem zkusil tohle


options snd-hda-intel index=0 model=laptop
options snd-hda-intel index=0 model=hp

Ale porad to hraje jenom do speakru :frowning:

Diky za pomoc a radu

IkaR

Uz to tu ve foru nekdo, a myslim i uspesne resil.

Jo to jsem take zkousel, ale nejak to na tu moji krabici nejde.
Uz jsem ruzne zkousel nastavovat ruzne reezimy hw:0.0, hw:0.1, zvuk 5.1, ale porad se to vzpecuje, necham to dva tri dny byt a snad me neco napadne.

Vyreseno,
Takze jsem si nedal pokoj a zkusil posledni vec co me napadla a to


rpm -qa | grep -iE 'alsa|pulse'
alsa-plugins-jack-1.0.15-2.fc8
pulseaudio-core-libs-0.9.8-5.fc8
alsa-oss-libs-1.0.14-3.fc8
pulseaudio-module-jack-0.9.8-5.fc8
bluez-utils-alsa-3.20-6.fc8
pulseaudio-esound-compat-0.9.8-5.fc8
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8
alsamixergui-0.9.0-0.3.rc1.fc8.2
pulseaudio-module-x11-0.9.8-5.fc8
alsa-oss-1.0.14-3.fc8
pulseaudio-module-bluetooth-0.9.8-5.fc8
pulseaudio-0.9.8-5.fc8
alsa-tools-1.0.12-4.fc7
pulseaudio-libs-0.9.8-5.fc8
alsa-plugins-oss-1.0.15-2.fc8
pulseaudio-utils-0.9.8-5.fc8
pulseaudio-libs-glib2-0.9.8-5.fc8
akode-pulseaudio-2.0.2-4.fc8
alsa-lib-1.0.15-1.fc8

nasledne jsem je vyhazel


rpm -e --nodeps --force <nasledne vsechny veci alsa a pulse>

A pak je opet nasypal pres yum.
A najednou to jde tak jak mam, tak do toho zatim nebudu stourat a az bude chvilka tak zkusim zjistit proc to najednou jde.

Diky

IkaR

No mám ten samý problém.Když připojím sluchátka do netobooku Toshiba A200 1S9 -zvuková karta:Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03),tak mi do nich nejde zvuk,ale stále hraje z reproduktoru.Vím,že už to tu bylo řešeno,ale už to tu hledám 2.den a nikde to nevidím.Prosím,jestli někdo víte,kde to bylo řešeno,jestli by nebylo možné sem hodit odkaz.Díky moc.

Nechce se mi to hledat - nezkousel si pustit alsamixer s takovym tim parametrem aby ukazal vsechny hardwarova hejblata a pak tam je neco o external amplifier apod.

To jsem zkoušel.Po zadání alsamixer -c 0 -V all mám pouze headphone -zapnuto a naplno , PCM -zapnuto a naplno ,front -zapnuto a naplno ,Front Mi -zapnuto a napůl , Mic Boos -staženo ,Capture -zapnuto a naplno , Capture -zapnuto a naplno ,Caller I -vypnuto (když ho zapnu,nejde stejně ovládat jeho hlasitost), Off-hook - vypnuto ( po zapnutí nejde ovládat jeho hlasitost),Input So (mic),Input So (mic)oboje zapnuto a staženo.Fakt už nevím.

Ja bohuzel taky ne… nevim proc vyrobci presli od konektoru ktery odpojoval po zasunuti sluchatek draty do bedynek k temhle trapnejm softwarovejm hejblatum.

Tak přeci jen se něco podařilo.Už mi jde zvuk do sluchátek.Sice jde zároveň i do repráků,ale ty se dají už stáhnout ručně.Automatika se zatím nezdařila,ale i tak jsem spokojen,protože toto je už použitelné.Řešení:
#vim /etc/modprobe.config
Původní config:

alias eth0 r8169
alias scsi_hostadapter libata
alias scsi_hostadapter1 ata_piix
alias scsi_hostadapter2 ahci
alias wlan0 ath5k
alias snd-card-1 snd-hda-intel
options snd-card-1 index=1
options snd-hda-intel index=1

Nový config:

alias eth0 r8169
alias scsi_hostadapter libata
alias scsi_hostadapter1 ata_piix
alias scsi_hostadapter2 ahci
alias snd-card-1 snd-hda-intel
options snd-card-1 index=1
options snd-hda-intel model=toshiba

UPOZORŇUJI,ŽE JE TO ODZKOUŠENO NA A200 1S9.
Na jiném stroji to bude ale obdobné.Dočetl jsem se,že někdo píše místo toshiba acer a nebo laptop.Chce to zkoušet :-)Uff jupiiiiiiiiiiii

Tak už mi to funguje i automaticky.Jen jsem zpět přidal do :/etc/modprobe.conf řádek:options snd-hda-intel index=1
a umístil jsem ho nad řádek options snd-hda-intel model=toshiba
.Jupiiiiiiiiiiiiiiiiiii.Snad to někomu pomůže.